diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-04-03 03:48:53 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-04-03 03:48:53 +0000 |
commit | 46e13cec412dda538fb74b7a013e7abd5f6c79c7 (patch) | |
tree | acd32fd9b3d3ebfd77cf49eeb2cb0331119c0081 /meta-extras/packages/python | |
parent | 6569da9da91f16411175110a69a9611d774fdc21 (diff) | |
download | poky-46e13cec412dda538fb74b7a013e7abd5f6c79c7.tar.gz |
python-pygtk: imported changes from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4156 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python')
3 files changed, 53 insertions, 7 deletions
diff --git a/meta-extras/packages/python/python-pygtk/nodocs.patch b/meta-extras/packages/python/python-pygtk/nodocs.patch new file mode 100644 index 0000000000..9b2387e959 --- /dev/null +++ b/meta-extras/packages/python/python-pygtk/nodocs.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: pygtk-2.10.4/Makefile.am | ||
2 | =================================================================== | ||
3 | --- pygtk-2.10.4.orig/Makefile.am | ||
4 | +++ pygtk-2.10.4/Makefile.am | ||
5 | @@ -4,7 +4,7 @@ if BUILD_GTK | ||
6 | GTK_SUBDIR = gtk | ||
7 | endif | ||
8 | |||
9 | -SUBDIRS = codegen . $(GTK_SUBDIR) examples tests docs | ||
10 | +SUBDIRS = codegen . $(GTK_SUBDIR) examples tests | ||
11 | |||
12 | PLATFORM_VERSION = 2.0 | ||
13 | |||
diff --git a/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch b/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch new file mode 100644 index 0000000000..db3469ef57 --- /dev/null +++ b/meta-extras/packages/python/python-pygtk/prevent_to_get_display_during_import.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Index: pygtk-2.10.4/gtk/__init__.py | ||
2 | =================================================================== | ||
3 | --- pygtk-2.10.4.orig/gtk/__init__.py 2007-11-27 19:27:05.000000000 -0300 | ||
4 | +++ pygtk-2.10.4/gtk/__init__.py 2007-11-27 19:28:22.000000000 -0300 | ||
5 | @@ -78,7 +78,8 @@ | ||
6 | |||
7 | keysyms = LazyModule('keysyms', locals()) | ||
8 | |||
9 | -_init() | ||
10 | +if not hasattr(sys.modules['__main__'], 'python_launcher_enabled'): | ||
11 | + init() | ||
12 | |||
13 | # CAPI | ||
14 | _PyGtk_API = _gtk._PyGtk_API | ||
diff --git a/meta-extras/packages/python/python-pygtk_2.10.4.bb b/meta-extras/packages/python/python-pygtk_2.10.4.bb index 0584d119c9..645aad11e0 100644 --- a/meta-extras/packages/python/python-pygtk_2.10.4.bb +++ b/meta-extras/packages/python/python-pygtk_2.10.4.bb | |||
@@ -6,29 +6,48 @@ RDEPENDS = "python-shell python-pycairo python-pygobject" | |||
6 | PROVIDES = "python-pygtk2" | 6 | PROVIDES = "python-pygtk2" |
7 | SRCNAME = "pygtk" | 7 | SRCNAME = "pygtk" |
8 | LICENSE = "LGPL" | 8 | LICENSE = "LGPL" |
9 | PR = "ml3" | 9 | PR = "ml7" |
10 | 10 | ||
11 | SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar.bz2 \ | 11 | SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.10/${SRCNAME}-${PV}.tar.bz2 \ |
12 | file://fix-gtkunixprint.patch;patch=1 \ | 12 | file://fix-gtkunixprint.patch;patch=1 \ |
13 | file://prevent_to_get_display_during_import.patch;patch=1 \ | ||
14 | file://nodocs.patch;patch=1 \ | ||
13 | file://acinclude.m4" | 15 | file://acinclude.m4" |
14 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 16 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
15 | 17 | ||
16 | EXTRA_OECONF = "--disable-docs" | 18 | EXTRA_OECONF = "\ |
17 | EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../" | 19 | --disable-docs \ |
20 | --with-python-includes=${STAGING_INCDIR}/../ \ | ||
21 | " | ||
18 | 22 | ||
19 | inherit autotools pkgconfig distutils-base | 23 | inherit autotools pkgconfig distutils-base |
20 | 24 | ||
21 | do_configure_prepend() { | 25 | do_configure_prepend() { |
22 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | 26 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ |
23 | } | 27 | } |
24 | 28 | ||
25 | do_configure_prepend() { | 29 | # dirty fix #1: remove dependency on python-pygobject-dev |
26 | install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/ | 30 | do_install_append() { |
31 | find ${D} -name "*.la"|xargs rm -f | ||
32 | rm -f ${D}/${bindir}/pygtk-codegen-2.0 | ||
33 | rm -rf ${D}/${libdir}/pkgconfig | ||
27 | } | 34 | } |
28 | 35 | ||
36 | # dirty fix #2: fix build system paths leaking in | ||
29 | require fix-path.inc | 37 | require fix-path.inc |
30 | 38 | ||
31 | FILES_${PN}-dev += "${libdir}/pygtk/2.0 ${bindir}/pygtk-*" | 39 | PACKAGES =+ "${PN}-demo" |
40 | FILES_${PN}-demo = "\ | ||
41 | ${bindir}/pygtk-demo \ | ||
42 | ${libdir}/pygtk \ | ||
43 | " | ||
44 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" | ||
45 | |||
46 | # todo: revamp packaging, package demo seperatly | ||
47 | FILES_${PN}-dev += "\ | ||
48 | ${libdir}/pygtk/2.0 \ | ||
49 | ${bindir}/pygtk-* \ | ||
50 | ${datadir}/pygtk/2.0" | ||
32 | 51 | ||
33 | do_stage() { | 52 | do_stage() { |
34 | autotools_stage_includes | 53 | autotools_stage_includes |