diff options
author | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-04-03 13:38:23 +0000 |
---|---|---|
committer | Marcin Juszkiewicz <hrw@openedhand.com> | 2008-04-03 13:38:23 +0000 |
commit | 98eb6feeb643977694ddd8ba88bf35f9df114d26 (patch) | |
tree | ab882a607228742d008c8902f58d24ba0f539f36 /meta-extras/packages/python | |
parent | 2f3ca937d66ce6b9f2bdb1c09fbf066818ac92f4 (diff) | |
download | poky-98eb6feeb643977694ddd8ba88bf35f9df114d26.tar.gz |
python-native: added forgotten patches
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4173 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python')
4 files changed, 83 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch b/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch new file mode 100644 index 0000000000..999bddc449 --- /dev/null +++ b/meta-extras/packages/python/python-native-2.5.1/bindir-libdir.patch | |||
@@ -0,0 +1,18 @@ | |||
1 | |||
2 | # | ||
3 | # Made by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200 | ||
7 | +++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100 | ||
8 | @@ -78,8 +78,8 @@ | ||
9 | exec_prefix= @exec_prefix@ | ||
10 | |||
11 | # Expanded directories | ||
12 | -BINDIR= $(exec_prefix)/bin | ||
13 | -LIBDIR= $(exec_prefix)/lib | ||
14 | +BINDIR= @bindir@ | ||
15 | +LIBDIR= @libdir@ | ||
16 | MANDIR= @mandir@ | ||
17 | INCLUDEDIR= @includedir@ | ||
18 | CONFINCLUDEDIR= $(exec_prefix)/include | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch b/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch new file mode 100644 index 0000000000..3356c1abbe --- /dev/null +++ b/meta-extras/packages/python/python-native-2.5.1/cross-distutils.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100 | ||
7 | +++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100 | ||
8 | @@ -19,8 +19,8 @@ | ||
9 | from errors import DistutilsPlatformError | ||
10 | |||
11 | # These are needed in a couple of spots, so just compute them once. | ||
12 | -PREFIX = os.path.normpath(sys.prefix) | ||
13 | -EXEC_PREFIX = os.path.normpath(sys.exec_prefix) | ||
14 | +PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
15 | +EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
16 | |||
17 | # python_build: (Boolean) if true, we're either building Python or | ||
18 | # building an extension with an un-installed Python, so we use | ||
19 | @@ -192,7 +192,7 @@ | ||
20 | else: | ||
21 | # The name of the config.h file changed in 2.2 | ||
22 | config_h = 'pyconfig.h' | ||
23 | - return os.path.join(inc_dir, config_h) | ||
24 | + return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
25 | |||
26 | |||
27 | def get_makefile_filename(): | ||
28 | @@ -200,7 +200,7 @@ | ||
29 | if python_build: | ||
30 | return os.path.join(os.path.dirname(sys.executable), "Makefile") | ||
31 | lib_dir = get_python_lib(plat_specific=1, standard_lib=1) | ||
32 | - return os.path.join(lib_dir, "config", "Makefile") | ||
33 | + return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") ) | ||
34 | |||
35 | |||
36 | def parse_config_h(fp, g=None): | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch b/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch new file mode 100644 index 0000000000..6beeb6e022 --- /dev/null +++ b/meta-extras/packages/python/python-native-2.5.1/default-is-optimized.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: Python-2.5.1/Python/compile.c | ||
2 | =================================================================== | ||
3 | --- Python-2.5.1.orig/Python/compile.c | ||
4 | +++ Python-2.5.1/Python/compile.c | ||
5 | @@ -30,7 +30,7 @@ | ||
6 | #include "symtable.h" | ||
7 | #include "opcode.h" | ||
8 | |||
9 | -int Py_OptimizeFlag = 0; | ||
10 | +int Py_OptimizeFlag = 1; | ||
11 | |||
12 | /* | ||
13 | ISSUES: | ||
diff --git a/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch b/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch new file mode 100644 index 0000000000..54109afd62 --- /dev/null +++ b/meta-extras/packages/python/python-native-2.5.1/dont-modify-shebang-line.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | |||
2 | # | ||
3 | # Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de> | ||
4 | # | ||
5 | |||
6 | --- Python-2.4/Lib/distutils/command/build_scripts.py~dont-modify-shebang-line | ||
7 | +++ Python-2.4/Lib/distutils/command/build_scripts.py | ||
8 | @@ -87,7 +87,7 @@ | ||
9 | continue | ||
10 | |||
11 | match = first_line_re.match(first_line) | ||
12 | - if match: | ||
13 | + if False: #match: | ||
14 | adjust = 1 | ||
15 | post_interp = match.group(1) or '' | ||
16 | |||