summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-03-01 16:16:56 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-03-01 16:16:56 +0000
commit1b7b0c28d8d6a99e7a52feeb0bfce7b5bd305691 (patch)
tree3d5b85d1e94acab14e7d8a9409a2265610ff5444 /meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
parenteff0c4b55a43d204ae6da4cbc57a0be1cbb33241 (diff)
downloadpoky-1b7b0c28d8d6a99e7a52feeb0bfce7b5bd305691.tar.gz
python: sync with OE .dev and dropped Tcl/Tk support
- updated to 2.4.4 - cleaned manifest git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1305 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch')
-rw-r--r--meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch b/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..602aa8e021
--- /dev/null
+++ b/meta-extras/packages/python/python-2.4.4/fix-tkinter-detection.patch
@@ -0,0 +1,39 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- Python-2.4.1/setup.py~fix-tkinter-detection
7+++ Python-2.4.1/setup.py
8@@ -999,7 +999,7 @@
9 dotversion = dotversion[:-1] + '.' + dotversion[-1]
10 tcl_include_sub = []
11 tk_include_sub = []
12- for dir in inc_dirs:
13+ for dir in [os.getenv("STAGING_INCDIR")]:
14 tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
15 tk_include_sub += [dir + os.sep + "tk" + dotversion]
16 tk_include_sub += tcl_include_sub
17@@ -1018,22 +1018,6 @@
18 if dir not in include_dirs:
19 include_dirs.append(dir)
20
21- # Check for various platform-specific directories
22- if platform == 'sunos5':
23- include_dirs.append('/usr/openwin/include')
24- added_lib_dirs.append('/usr/openwin/lib')
25- elif os.path.exists('/usr/X11R6/include'):
26- include_dirs.append('/usr/X11R6/include')
27- added_lib_dirs.append('/usr/X11R6/lib64')
28- added_lib_dirs.append('/usr/X11R6/lib')
29- elif os.path.exists('/usr/X11R5/include'):
30- include_dirs.append('/usr/X11R5/include')
31- added_lib_dirs.append('/usr/X11R5/lib')
32- else:
33- # Assume default location for X11
34- include_dirs.append('/usr/X11/include')
35- added_lib_dirs.append('/usr/X11/lib')
36-
37 # If Cygwin, then verify that X is installed before proceeding
38 if platform == 'cygwin':
39 x11_inc = find_file('X11/Xlib.h', [], include_dirs)