diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta-extras/packages/maemo | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-extras/packages/maemo')
-rw-r--r-- | meta-extras/packages/maemo/nokia770-init/fixup-770.sh | 26 | ||||
-rw-r--r-- | meta-extras/packages/maemo/nokia770-init_1.0.bb | 38 | ||||
-rw-r--r-- | meta-extras/packages/maemo/xpext/auxdir.patch | 13 | ||||
-rw-r--r-- | meta-extras/packages/maemo/xpext_1.0-5.bb | 22 | ||||
-rw-r--r-- | meta-extras/packages/maemo/xsp_1.0.0-8.bb | 12 |
5 files changed, 111 insertions, 0 deletions
diff --git a/meta-extras/packages/maemo/nokia770-init/fixup-770.sh b/meta-extras/packages/maemo/nokia770-init/fixup-770.sh new file mode 100644 index 0000000000..0f1734d2ab --- /dev/null +++ b/meta-extras/packages/maemo/nokia770-init/fixup-770.sh | |||
@@ -0,0 +1,26 @@ | |||
1 | #! /bin/sh | ||
2 | case "$1" in | ||
3 | start) | ||
4 | echo -n "Unmounting virtual fs from initrd" | ||
5 | umount /mnt/initfs/sys | ||
6 | umount /mnt/initfs/proc | ||
7 | ln -s /dev/vc/0 /dev/tty0 | ||
8 | ln -s /dev/vc/1 /dev/tty1 | ||
9 | ln -s /dev/vc/2 /dev/tty2 | ||
10 | ln -s /dev/vc/3 /dev/tty3 | ||
11 | ln -s /dev/vc/4 /dev/tty4 | ||
12 | ln -s /dev/vc/5 /dev/tty5 | ||
13 | ln -s /dev/vc/6 /dev/tty6 | ||
14 | ln -s /dev/vc/7 /dev/tty7 | ||
15 | /sbin/ifconfig wlan0 up | ||
16 | ;; | ||
17 | stop) | ||
18 | ;; | ||
19 | *) | ||
20 | echo "Usage: $SCRIPTNAME {start|stop}" >&2 | ||
21 | exit 1 | ||
22 | ;; | ||
23 | esac | ||
24 | |||
25 | exit 0 | ||
26 | \ No newline at end of file | ||
diff --git a/meta-extras/packages/maemo/nokia770-init_1.0.bb b/meta-extras/packages/maemo/nokia770-init_1.0.bb new file mode 100644 index 0000000000..9075c016a6 --- /dev/null +++ b/meta-extras/packages/maemo/nokia770-init_1.0.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | LICENSE = "GPL" | ||
2 | PR = "r7" | ||
3 | |||
4 | DEPENDS = "base-passwd" | ||
5 | |||
6 | SRC_URI = "file://fixup-770.sh" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "(nokia770|nokia800)" | ||
9 | |||
10 | inherit update-rc.d | ||
11 | |||
12 | INITSCRIPT_NAME = "fixup-770.sh" | ||
13 | INITSCRIPT_PARAMS = "defaults 01" | ||
14 | |||
15 | FILES_${PN} = "${sysconfdir} ${libdir}" | ||
16 | |||
17 | do_install () { | ||
18 | install -d ${D}${sysconfdir}/init.d | ||
19 | install -m 755 ${WORKDIR}/fixup-770.sh ${D}/${sysconfdir}/init.d/fixup-770.sh | ||
20 | |||
21 | install -d ${D}/lib/firmware | ||
22 | } | ||
23 | |||
24 | pkg_postinst () { | ||
25 | #!/bin/sh | ||
26 | |||
27 | # set up some links to firmware and modules in initrd | ||
28 | mkdir -p $D/lib/firmware | ||
29 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3825.arm $D/lib/firmware/3825.arm | ||
30 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/3826.arm $D/lib/firmware/3826.arm | ||
31 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/bc4fw.bin $D/lib/firmware/bc4fw.bin | ||
32 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/brf6150fw.bin $D/lib/firmware/brf6150fw.bin | ||
33 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3825.arm $D/lib/firmware/mtlm3825.arm | ||
34 | ln -sf /mnt/initfs/usr/lib/hotplug/firmware/mtlm3826.arm $D/lib/firmware/mtlm3826.arm | ||
35 | |||
36 | # rm -rf $D/lib/modules | ||
37 | # ln -s /mnt/initfs/lib/modules $D/lib/modules | ||
38 | } | ||
diff --git a/meta-extras/packages/maemo/xpext/auxdir.patch b/meta-extras/packages/maemo/xpext/auxdir.patch new file mode 100644 index 0000000000..da5841a132 --- /dev/null +++ b/meta-extras/packages/maemo/xpext/auxdir.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | --- configure.ac.old 2005-06-03 12:53:28.000000000 +0200 | ||
2 | +++ configure.ac 2005-06-03 12:54:29.000000000 +0200 | ||
3 | @@ -25,9 +25,9 @@ | ||
4 | |||
5 | AC_PREREQ([2.57]) | ||
6 | AC_INIT([spext], [1.0], [lauri.leukkunen@nokia.com], spext) | ||
7 | +AC_CONFIG_AUX_DIR(.) | ||
8 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
9 | AM_MAINTAINER_MODE | ||
10 | -AC_CONFIG_AUX_DIR(.) | ||
11 | |||
12 | dnl PKG_CHECK_MODULES(FIXESEXT, fixesext) | ||
13 | |||
diff --git a/meta-extras/packages/maemo/xpext_1.0-5.bb b/meta-extras/packages/maemo/xpext_1.0-5.bb new file mode 100644 index 0000000000..5be3d1c041 --- /dev/null +++ b/meta-extras/packages/maemo/xpext_1.0-5.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "X Server Nokia 770 extensions library" | ||
2 | LICENSE= "MIT" | ||
3 | SECTION = "x11/libs" | ||
4 | PRIORITY = "optional" | ||
5 | DEPENDS = "virtual/libx11 libxext" | ||
6 | PR = "r1" | ||
7 | |||
8 | SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${PN}/${PN}_${PV}.tar.gz \ | ||
9 | file://auxdir.patch;patch=1;pnum=0" | ||
10 | S = "${WORKDIR}/xpext-1.0" | ||
11 | |||
12 | # ${PN} is empty so we need to tweak -dev and -dbg package dependencies | ||
13 | RDEPENDS_${PN}-dev = "" | ||
14 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPV})" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | do_configure_prepend () { | ||
19 | cd ${S} | ||
20 | chmod +x ./autogen.sh | ||
21 | ./autogen.sh | ||
22 | } | ||
diff --git a/meta-extras/packages/maemo/xsp_1.0.0-8.bb b/meta-extras/packages/maemo/xsp_1.0.0-8.bb new file mode 100644 index 0000000000..c722213c86 --- /dev/null +++ b/meta-extras/packages/maemo/xsp_1.0.0-8.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | DESCRIPTION = "X Server Nokia 770 extensions library" | ||
2 | SECTION = "x11/libs" | ||
3 | PRIORITY = "optional" | ||
4 | LICENSE= "MIT" | ||
5 | DEPENDS = "virtual/libx11 libxext xpext" | ||
6 | |||
7 | PR = "r1" | ||
8 | |||
9 | SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/xsp/${PN}_${PV}.tar.gz" | ||
10 | S = "${WORKDIR}/Xsp" | ||
11 | |||
12 | inherit autotools pkgconfig | ||