diff options
author | Richard Purdie <richard@openedhand.com> | 2007-05-30 13:46:03 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-05-30 13:46:03 +0000 |
commit | 85d3283d2fd79069654933817d200e6dd6d6254b (patch) | |
tree | eb113a631598355dd469cb3c257b66def53a10d4 /meta-extras/packages/images | |
parent | ab5005a4720daa149b65e7caafcaea85d2ccb755 (diff) | |
download | poky-85d3283d2fd79069654933817d200e6dd6d6254b.tar.gz |
meta-extras: Various cleanups
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1825 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/images')
-rw-r--r-- | meta-extras/packages/images/oh-image-extras.bb | 31 | ||||
-rw-r--r-- | meta-extras/packages/images/poky-image.inc | 43 |
2 files changed, 49 insertions, 25 deletions
diff --git a/meta-extras/packages/images/oh-image-extras.bb b/meta-extras/packages/images/oh-image-extras.bb index b62774205e..d9b879683b 100644 --- a/meta-extras/packages/images/oh-image-extras.bb +++ b/meta-extras/packages/images/oh-image-extras.bb | |||
@@ -1,28 +1,9 @@ | |||
1 | PR = "r9" | 1 | # |
2 | # Copyright (C) 2007 OpenedHand Ltd. | ||
3 | # | ||
2 | 4 | ||
3 | export IMAGE_BASENAME = "oh-extras" | 5 | IMAGE_FEATURES += "apps-core apps-pda" |
4 | 6 | ||
5 | GUI_MACHINE_CLASS ?= "none" | 7 | require poky-image.inc |
6 | 8 | ||
7 | XSERVER ?= "xserver-kdrive-fbdev" | 9 | IMAGE_INSTALL += "task-oh-extraapps" |
8 | |||
9 | DEPENDS = "\ | ||
10 | task-oh \ | ||
11 | task-oh-extras" | ||
12 | |||
13 | RDEPENDS = "\ | ||
14 | task-base \ | ||
15 | task-oh-boot \ | ||
16 | task-oh-boot-extras \ | ||
17 | task-oh-base \ | ||
18 | task-oh-standard \ | ||
19 | task-oh-testapps \ | ||
20 | task-oh-devtools \ | ||
21 | task-oh-extraapps \ | ||
22 | ${XSERVER} " | ||
23 | |||
24 | export PACKAGE_INSTALL = "${RDEPENDS}" | ||
25 | #ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; " | ||
26 | |||
27 | inherit image | ||
28 | LICENSE = MIT | ||
diff --git a/meta-extras/packages/images/poky-image.inc b/meta-extras/packages/images/poky-image.inc new file mode 100644 index 0000000000..6f1bed9760 --- /dev/null +++ b/meta-extras/packages/images/poky-image.inc | |||
@@ -0,0 +1,43 @@ | |||
1 | # Common for Poky images | ||
2 | # | ||
3 | # Copyright (C) 2007 OpenedHand LTD | ||
4 | |||
5 | # IMAGE_FEATURES control content of images built with Poky. | ||
6 | # | ||
7 | # By default we install task-oh-boot and task-oh-boot-extras packages - this | ||
8 | # gives us working (console only) rootfs. | ||
9 | # | ||
10 | # "apps-core", "apps-pda" and other tasks are defined in task-oh recipe and have | ||
11 | # to add needed packages for selected task. | ||
12 | # | ||
13 | |||
14 | DISTRO_TASKS += '\ | ||
15 | ${@base_contains("IMAGE_FEATURES", "dbg-pkgs", "task-oh-boot-dbg task-oh-boot-extras-dbg", "",d)} \ | ||
16 | ${@base_contains("IMAGE_FEATURES", "dev-pkgs", "task-oh-boot-dev task-oh-boot-extras-dev", "",d)} \ | ||
17 | \ | ||
18 | ${@base_contains("IMAGE_FEATURES", "apps-core", "task-oh-base", "",d)} \ | ||
19 | ${@base_contains("IMAGE_FEATURES", ["apps-core", "dbg-pkgs"], "task-oh-base-dbg", "",d)} \ | ||
20 | ${@base_contains("IMAGE_FEATURES", ["apps-core", "dev-pkgs"], "task-oh-base-dev", "",d)} \ | ||
21 | \ | ||
22 | ${@base_contains("IMAGE_FEATURES", "apps-pda", "task-oh-standard", "",d)} \ | ||
23 | ${@base_contains("IMAGE_FEATURES", ["apps-pda", "dbg-pkgs"], "task-oh-standard-dbg", "",d)} \ | ||
24 | ${@base_contains("IMAGE_FEATURES", ["apps-pda", "dev-pkgs"], "task-oh-standard-dev", "",d)} \ | ||
25 | \ | ||
26 | ${@base_contains("IMAGE_FEATURES", "dev-tools", "task-oh-sdk", "",d)} \ | ||
27 | ${@base_contains("IMAGE_FEATURES", ["dev-tools", "dbg-pkgs"], "task-oh-sdk-dbg", "",d)} \ | ||
28 | ${@base_contains("IMAGE_FEATURES", ["dev-tools", "dev-pkgs"], "task-oh-sdk-dev", "",d)} \ | ||
29 | \ | ||
30 | ${@base_contains("IMAGE_FEATURES", "dbg-tools", "task-oh-devtools", "",d)} \ | ||
31 | ${@base_contains("IMAGE_FEATURES", ["dbg-tools", "dbg-pkgs"], "task-oh-devtools-dbg", "",d)} \ | ||
32 | ${@base_contains("IMAGE_FEATURES", ["dbg-tools", "dev-pkgs"], "task-oh-devtools-dev", "",d)} \ | ||
33 | \ | ||
34 | ${@base_contains("IMAGE_FEATURES", "test-tools", "task-oh-testapps", "",d)} \ | ||
35 | ${@base_contains("IMAGE_FEATURES", ["test-tools", "dbg-pkgs"], "task-oh-testapps-dbg", "",d)} \ | ||
36 | ${@base_contains("IMAGE_FEATURES", ["test-tools", "dev-pkgs"], "task-oh-testapps-dev", "",d)} \ | ||
37 | \ | ||
38 | ${@base_contains("IMAGE_FEATURES", "nfs-server", "task-oh-nfs-server", "",d)} \ | ||
39 | ' | ||
40 | |||
41 | IMAGE_INSTALL ?= "${DISTRO_TASKS}" | ||
42 | |||
43 | inherit image | ||