summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-kernel
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-20 12:24:36 -0600
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:20:50 +0000
commiteca21e63590c165c5aaf14cbd51c7f325b731aba (patch)
treee04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-kernel
parentab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff)
downloadpoky-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP standard layout as defined in the latestYocto BSP Developer's Guide. There's no change in functionality here - this simply moves things around, adds a README, and makes the SRCREVs local. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-kernel')
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig68
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend3
-rw-r--r--meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend3
3 files changed, 74 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig b/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig
new file mode 100644
index 0000000000..a516dc987e
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-2.6.33.2/defconfig
@@ -0,0 +1,68 @@
1CONFIG_X86_32=y
2CONFIG_PRINTK=y
3
4# Basic hardware support for the box - network, USB, PCI, sound
5CONFIG_NETDEVICES=y
6CONFIG_NETDEV_1000=y
7CONFIG_ATA=y
8CONFIG_ATA_GENERIC=y
9CONFIG_ATA_SFF=y
10CONFIG_PCI=y
11CONFIG_MMC=y
12CONFIG_MMC_SDHCI=y
13CONFIG_USB_SUPPORT=y
14CONFIG_USB=y
15CONFIG_USB_ARCH_HAS_EHCI=y
16CONFIG_E1000E=y
17CONFIG_R8169=y
18CONFIG_PATA_SCH=y
19CONFIG_MMC_SDHCI_PCI=y
20CONFIG_USB_EHCI_HCD=y
21CONFIG_PCIEPORTBUS=y
22CONFIG_NET=y
23CONFIG_USB_UHCI_HCD=y
24CONFIG_BLK_DEV_SD=y
25CONFIG_CHR_DEV_SG=y
26CONFIG_SOUND=y
27CONFIG_SND=y
28CONFIG_SND_HDA_INTEL=y
29
30# Make sure these are on, otherwise the bootup won't be fun
31CONFIG_EXT3_FS=y
32CONFIG_UNIX=y
33CONFIG_INET=y
34CONFIG_MODULES=y
35CONFIG_SHMEM=y
36CONFIG_TMPFS=y
37CONFIG_PACKET=y
38
39# These are needed for the Poulsbo kernel modules
40CONFIG_I2C=y
41CONFIG_AGP=y
42CONFIG_VFAT_FS=y
43CONFIG_PM=y
44CONFIG_ACPI=y
45CONFIG_FB=y
46CONFIG_BACKLIGHT_LCD_SUPPORT=y
47CONFIG_BACKLIGHT_CLASS_DEVICE=y
48CONFIG_INPUT=y
49CONFIG_VIDEO_V4L2=y
50CONFIG_VIDEO_IVTV=y
51CONFIG_MEDIA_SUPPORT=y
52CONFIG_VIDEO_CAPTURE_DRIVERS=y
53CONFIG_VIDEO_DEV=y
54CONFIG_VIDEO_V4L2_COMMON=y
55CONFIG_I2C_ALGOBIT=y
56CONFIG_FB_CFB_COPYAREA=y
57CONFIG_FB_CFB_IMAGEBLIT=y
58CONFIG_FB_CFB_FILLRECT=y
59CONFIG_VIDEO_FB_IVTV=y
60
61# Needed for booting (and using) USB memory sticks
62CONFIG_USB_STORAGE=y
63CONFIG_BLK_DEV_RAM=y
64CONFIG_BLK_DEV_LOOP=y
65CONFIG_BLK_DEV_INITRD=y
66CONFIG_RD_GZIP=y
67CONFIG_NLS_CODEPAGE_437=y
68CONFIG_NLS_ISO8859_1=y
diff --git a/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend
new file mode 100644
index 0000000000..9fa2937d4f
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux-yocto-stable_git.bbappend
@@ -0,0 +1,3 @@
1FILESEXTRAPATHS := "${THISDIR}/${PN}"
2COMPATIBLE_MACHINE_emenlow = "emenlow"
3KMACHINE_emenlow = "emenlow"
diff --git a/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend b/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend
new file mode 100644
index 0000000000..fac0921401
--- /dev/null
+++ b/meta-emenlow/recipes-kernel/linux/linux_2.6.33.2.bbappend
@@ -0,0 +1,3 @@
1FILESPATH := "${FILESPATH}:${@os.path.dirname(bb.data.getVar('FILE', d, True))}"
2SRC_URI += "file://defconfig"
3COMPATIBLE_MACHINE_emenlow = "emenlow"