summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2010-12-20 12:24:36 -0600
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-23 14:20:50 +0000
commiteca21e63590c165c5aaf14cbd51c7f325b731aba (patch)
treee04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
parentab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff)
downloadpoky-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP standard layout as defined in the latestYocto BSP Developer's Guide. There's no change in functionality here - this simply moves things around, adds a README, and makes the SRCREVs local. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb')
-rw-r--r--meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb b/meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
new file mode 100644
index 0000000000..1ff92bbc61
--- /dev/null
+++ b/meta-emenlow/recipes-graphics/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "2D graphics driver for Poulsbo"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
4PR = "r2"
5
6inherit autotools
7
8SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/xserver-xorg-video-psb_0.36.0-0ubuntu3~1004um9.tar.gz \
9 file://xorg-x11-drv-psb-0.31.0-ignoreacpi.patch;patch=1 \
10 file://xorg-x11-drv-psb-0.31.0-xserver17.patch;patch=1 \
11 file://xserver-xorg-video-psb-0.31.0-assert.patch;patch=1 \
12 file://xserver-xorg-video-psb-0.31.0-comment_unused.patch;patch=1 \
13 file://xserver-xorg-video-psb-0.31.0-greedy.patch;patch=1 \
14 file://xserver-xorg-video-psb-0.31.0-loader.patch;patch=1 \
15 file://stubs.patch;patch=1 \
16 file://01_disable_lid_timer.patch;patch=1 \
17 file://psb_xvtempfix.patch;patch=1 \
18 file://psb_mixed.patch;patch=1 \
19 file://dri-h.patch \
20 file://libdrm-poulsbo.patch"
21
22export DRI_CFLAGS="-I${STAGING_INCDIR}/psb -I${STAGING_INCDIR}/psb/drm \
23 -I${STAGING_INCDIR}/X11/dri"
24
25export CFLAGS = "-fvisibility=default"
26export XORG_CFLAGS="-fvisibility=default -I${STAGING_INCDIR}/xorg \
27 -I${STAGING_INCDIR}/pixman-1"
28
29FILES_${PN} += "${libdir}/xorg/modules/drivers/libmm.so \
30 ${libdir}/xorg/modules/drivers/psb_drv.so"
31
32DEPENDS += "virtual/libgl virtual/xserver"
33
34COMPATIBLE_MACHINE = "emenlow"