diff options
author | Tom Zanussi <tom.zanussi@intel.com> | 2010-12-20 12:24:36 -0600 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-12-23 14:20:50 +0000 |
commit | eca21e63590c165c5aaf14cbd51c7f325b731aba (patch) | |
tree | e04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb | |
parent | ab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff) | |
download | poky-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz |
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP
standard layout as defined in the latestYocto BSP Developer's Guide.
There's no change in functionality here - this simply moves things
around, adds a README, and makes the SRCREVs local.
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb')
-rw-r--r-- | meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb new file mode 100644 index 0000000000..6ceb1cbe08 --- /dev/null +++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx_0.18.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration" | ||
2 | |||
3 | # There's a mesa implementation in this package, which is presumably | ||
4 | # not Intel proprietary, but it has no obvious license attached to it. | ||
5 | LICENSE = "Intel-binary-only" | ||
6 | LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8" | ||
7 | PR = "r6" | ||
8 | |||
9 | inherit autotools | ||
10 | |||
11 | PROVIDES = "virtual/libgl mesa-dri" | ||
12 | |||
13 | SRC_URI="https://launchpad.net/~gma500/+archive/ppa/+files/xpsb-glx_0.18-0ubuntu1netbook2~1004um1ubuntu1.tar.gz \ | ||
14 | file://cross-compile.patch \ | ||
15 | file://libdrmname.patch \ | ||
16 | file://native-matypes.patch" | ||
17 | |||
18 | do_configure () { | ||
19 | chmod +x autogen.sh && ./autogen.sh ${CONFIGUREOPTS} && make realclean | ||
20 | cd ${S}/src/mesa/x86/ | ||
21 | ${BUILD_CC} -I../../../include/GL -I../../../include -I.. -I../main -I../math -I../glapi -I../tnl -Wall -Wmissing-prototypes -std=c99 -ffast-math -fPIC -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_SVID_SOURCE -D_BSD_SOURCE -D_GNU_SOURCE -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DHAVE_POSIX_MEMALIGN -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -fno-strict-aliasing gen_matypes.c -o gen_matypes | ||
22 | } | ||
23 | |||
24 | do_install() { | ||
25 | make DESTDIR=${D} install | ||
26 | install -d -m 0755 ${D}/${libdir}/xorg/modules/dri \ | ||
27 | ${D}/${libdir}/xorg/modules/drivers | ||
28 | install -m 0644 ${WORKDIR}/${PN}-${PV}/dri/* \ | ||
29 | ${D}/${libdir}/xorg/modules/dri | ||
30 | install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \ | ||
31 | ${D}/${libdir}/xorg/modules/drivers | ||
32 | } | ||
33 | |||
34 | S = "${WORKDIR}/${PN}-${PV}/mesa" | ||
35 | |||
36 | EXTRA_OEMAKE = "linux-dri-x86" | ||
37 | |||
38 | DEPENDS += "libdrm-poulsbo libxxf86vm dri2proto libxmu libxi glproto makedepend-native" | ||
39 | |||
40 | FILES_${PN} = "${libdir}/* ${libdir}/xorg/modules/dri/* \ | ||
41 | ${libdir}/xorg/modules/drivers/*" | ||
42 | |||
43 | # Multiple virtual/gl providers being built breaks staging | ||
44 | EXCLUDE_FROM_WORLD = "1" | ||
45 | |||
46 | COMPATIBLE_MACHINE = "emenlow" | ||