diff options
author | Tom Zanussi <tom.zanussi@intel.com> | 2010-12-20 12:24:36 -0600 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-12-23 14:20:50 +0000 |
commit | eca21e63590c165c5aaf14cbd51c7f325b731aba (patch) | |
tree | e04b863b4a355e46a6ce526caf6dcc98713eb620 /meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch | |
parent | ab83f5f266ee7f66d14e3711ec84907750ea7e91 (diff) | |
download | poky-eca21e63590c165c5aaf14cbd51c7f325b731aba.tar.gz |
meta-emenlow: update to the new BSP layout
This modifies the meta-emenlow BSP layer to reflect the new BSP
standard layout as defined in the latestYocto BSP Developer's Guide.
There's no change in functionality here - this simply moves things
around, adds a README, and makes the SRCREVs local.
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch')
-rw-r--r-- | meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch new file mode 100644 index 0000000000..96b94ef2c8 --- /dev/null +++ b/meta-emenlow/recipes-graphics/xpsb-glx/xpsb-glx-0.18/libdrmname.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | Index: mesa/configure.ac | ||
2 | =================================================================== | ||
3 | --- mesa.orig/configure.ac 2010-05-13 13:20:26.000000000 +0100 | ||
4 | +++ mesa/configure.ac 2010-07-25 17:02:58.000000000 +0100 | ||
5 | @@ -524,10 +524,10 @@ | ||
6 | fi | ||
7 | |||
8 | # Check for libdrm | ||
9 | - PKG_CHECK_MODULES([LIBDRM], [libdrm-poulsbo >= $LIBDRM_REQUIRED]) | ||
10 | + PKG_CHECK_MODULES([LIBDRM], [libdrm_poulsbo >= $LIBDRM_REQUIRED]) | ||
11 | PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= $DRI2PROTO_REQUIRED]) | ||
12 | - GL_PC_REQ_PRIV="libdrm-poulsbo >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED" | ||
13 | - DRI_PC_REQ_PRIV="libdrm-poulsbo >= $LIBDRM_REQUIRED" | ||
14 | + GL_PC_REQ_PRIV="libdrm_poulsbo >= $LIBDRM_REQUIRED dri2proto >= $DRI2PROTO_REQUIRED" | ||
15 | + DRI_PC_REQ_PRIV="libdrm_poulsbo >= $LIBDRM_REQUIRED" | ||
16 | |||
17 | # find the DRI deps for libGL | ||
18 | if test "$x11_pkgconfig" = yes; then | ||
19 | Index: mesa/configs/linux-dri | ||
20 | =================================================================== | ||
21 | --- mesa.orig/configs/linux-dri 2010-07-25 17:08:01.000000000 +0100 | ||
22 | +++ mesa/configs/linux-dri 2010-07-25 17:08:17.000000000 +0100 | ||
23 | @@ -36,8 +36,8 @@ | ||
24 | |||
25 | ASM_SOURCES = | ||
26 | |||
27 | -LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo` | ||
28 | -LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo` | ||
29 | +LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo` | ||
30 | +LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo` | ||
31 | DRI_LIB_DEPS = $(EXTRA_LIB_PATH) -lm -lpthread -lexpat -ldl $(LIBDRM_LIB) | ||
32 | GL_LIB_DEPS = $(EXTRA_LIB_PATH) -lX11 -lXext -lXxf86vm -lXdamage -lXfixes \ | ||
33 | -lm -lpthread -ldl $(LIBDRM_LIB) | ||
34 | Index: mesa/configs/linux-dri-xcb | ||
35 | =================================================================== | ||
36 | --- mesa.orig/configs/linux-dri-xcb 2010-07-25 17:08:25.000000000 +0100 | ||
37 | +++ mesa/configs/linux-dri-xcb 2010-07-25 17:08:44.000000000 +0100 | ||
38 | @@ -41,8 +41,8 @@ | ||
39 | # Library/program dependencies | ||
40 | EXTRA_LIB_PATH=`pkg-config --libs-only-L x11` | ||
41 | |||
42 | -LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo` | ||
43 | -LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo` | ||
44 | +LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo` | ||
45 | +LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo` | ||
46 | DRI_LIB_DEPS = $(EXTRA_LIB_PATH) -lm -lpthread -lexpat -ldl $(LIBDRM_LIB) | ||
47 | GL_LIB_DEPS = $(EXTRA_LIB_PATH) -lX11 -lXext -lXxf86vm -lXdamage -lXfixes \ | ||
48 | -lm -lpthread -ldl $(LIBDRM_LIB) `pkg-config --libs xcb` \ | ||
49 | Index: mesa/configs/linux-solo | ||
50 | =================================================================== | ||
51 | --- mesa.orig/configs/linux-solo 2010-07-25 17:09:03.000000000 +0100 | ||
52 | +++ mesa/configs/linux-solo 2010-07-25 17:09:13.000000000 +0100 | ||
53 | @@ -16,8 +16,8 @@ | ||
54 | ARCH_FLAGS ?= | ||
55 | |||
56 | # DRM and pciaccess | ||
57 | -LIBDRM_CFLAGS = `pkg-config --cflags libdrm-poulsbo` | ||
58 | -LIBDRM_LIB = `pkg-config --libs libdrm-poulsbo` | ||
59 | +LIBDRM_CFLAGS = `pkg-config --cflags libdrm_poulsbo` | ||
60 | +LIBDRM_LIB = `pkg-config --libs libdrm_poulsbo` | ||
61 | PCIACCESS_CFLAGS = `pkg-config --cflags pciaccess` | ||
62 | PCIACCESS_LIB = `pkg-config --libs pciaccess` | ||
63 | |||