diff options
author | Jeff Dike <jdike@x86_64.user-mode-linux.org> | 2010-07-22 17:30:49 -0400 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-22 23:18:26 +0100 |
commit | 833390e533ee997600f37ec87192f05e49e26db3 (patch) | |
tree | 670a6ff928f75bfc5e74a753e45acb64d97f72f7 /meta-emenlow/packages | |
parent | b18f1216b0d3654f7b6fb3752eda1dd82a294f3d (diff) | |
download | poky-833390e533ee997600f37ec87192f05e49e26db3.tar.gz |
libdrm-poulsbo: Provide libdrm-poulsbo instead of libdrm
In order to allow this package to be build alongside the regular
libdrm, it was made to export libdrm-poulsbo and its users make to use
libdrm-poulsbo instead of libdrm. libva and xserver-psb were make to
build against libdrm-poulsbo. While I was in there, I changed a couple
of misspellings of COMPATIBLE and removed a bunch of ';patch=1'.
Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages')
6 files changed, 125 insertions, 33 deletions
diff --git a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch new file mode 100644 index 0000000000..e62188a7ac --- /dev/null +++ b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | # Make this package produce libdrm-poulsbo instead of libdrm so that the | ||
2 | # emenlow libdrm can coexist with the normal libdrm. | ||
3 | # jdike@linux.intel.com | ||
4 | |||
5 | Index: libdrm-poulsbo-2.3.0/configure.ac | ||
6 | =================================================================== | ||
7 | --- libdrm-poulsbo-2.3.0.orig/configure.ac | ||
8 | +++ libdrm-poulsbo-2.3.0/configure.ac | ||
9 | @@ -19,7 +19,7 @@ | ||
10 | # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. | ||
11 | |||
12 | AC_PREREQ(2.57) | ||
13 | -AC_INIT([libdrm], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm) | ||
14 | +AC_INIT([libdrm-poulsbo], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm-poulsbo) | ||
15 | AC_CONFIG_SRCDIR([Makefile.am]) | ||
16 | AM_INIT_AUTOMAKE([dist-bzip2]) | ||
17 | |||
18 | @@ -35,4 +35,4 @@ AC_SYS_LARGEFILE | ||
19 | pkgconfigdir=${libdir}/pkgconfig | ||
20 | AC_SUBST(pkgconfigdir) | ||
21 | |||
22 | -AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm.pc]) | ||
23 | +AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm-poulsbo.pc]) | ||
24 | Index: libdrm-poulsbo-2.3.0/Makefile.am | ||
25 | =================================================================== | ||
26 | --- libdrm-poulsbo-2.3.0.orig/Makefile.am | ||
27 | +++ libdrm-poulsbo-2.3.0/Makefile.am | ||
28 | @@ -25,6 +25,6 @@ AUTOMAKE_OPTIONS = foreign | ||
29 | SUBDIRS = libdrm shared-core | ||
30 | |||
31 | pkgconfigdir = @pkgconfigdir@ | ||
32 | -pkgconfig_DATA = libdrm.pc | ||
33 | +pkgconfig_DATA = libdrm-poulsbo.pc | ||
34 | |||
35 | -EXTRA_DIST = libdrm.pc.in | ||
36 | +EXTRA_DIST = libdrm-poulsbo.pc.in | ||
diff --git a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb index 8a06dce8cc..3541501e9c 100644 --- a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb +++ b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb | |||
@@ -1,14 +1,16 @@ | |||
1 | DESCRIPTION = "Userspace interface to kernel DRM services" | 1 | DESCRIPTION = "Userspace interface to kernel DRM services" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7" | 3 | LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7" |
4 | PR="r1" | 4 | PR="r2" |
5 | 5 | ||
6 | PROVIDES = "libdrm-poulsbo libdrm drm" | 6 | PROVIDES = "libdrm-poulsbo" |
7 | 7 | ||
8 | inherit autotools pkgconfig | 8 | inherit autotools pkgconfig |
9 | 9 | ||
10 | SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz" | 10 | SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz \ |
11 | file://libdrm-poulsbo.patch" | ||
11 | 12 | ||
12 | do_install_append() { | 13 | do_configure_prepend() { |
13 | cp ${D}/${libdir}/pkgconfig/libdrm.pc ${D}/${libdir}/pkgconfig/libdrm-poulsbo.pc | 14 | sed -e 's/-ldrm/-ldrm-poulsbo/' -e 's/libdrm/libdrm-poulsbo/' \ |
15 | < ${S}/libdrm.pc.in > ${S}/libdrm-poulsbo.pc.in | ||
14 | } | 16 | } |
diff --git a/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch b/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch new file mode 100644 index 0000000000..795ba62522 --- /dev/null +++ b/meta-emenlow/packages/libva/libva-0.31.0/libdrm-poulsbo.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | # Make the libva depend on libdrm-poulsbo instead of libdrm so that the | ||
2 | # emenlow libdrm can coexist with the normal libdrm. | ||
3 | # jdike@linux.intel.com | ||
4 | |||
5 | Index: libva-0.31.0/configure.ac | ||
6 | =================================================================== | ||
7 | --- libva-0.31.0.orig/configure.ac | ||
8 | +++ libva-0.31.0/configure.ac | ||
9 | @@ -99,14 +99,14 @@ AC_SYS_LARGEFILE | ||
10 | PKG_CHECK_MODULES([X11], [x11]) | ||
11 | PKG_CHECK_MODULES([XEXT],[xext]) | ||
12 | PKG_CHECK_MODULES([XFIXES], [xfixes]) | ||
13 | -PKG_CHECK_MODULES([DRM], [libdrm]) | ||
14 | +PKG_CHECK_MODULES([DRM], [libdrm-poulsbo]) | ||
15 | |||
16 | PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.0], [gen4asm=yes], [gen4asm=no]) | ||
17 | AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes) | ||
18 | |||
19 | # Check for libdrm >= 2.4 (needed for i965_drv_video.so) | ||
20 | -if test x$enable_i965_driver = xyes && ! $PKG_CONFIG --atleast-version=2.4 libdrm; then | ||
21 | - AC_MSG_WARN([libdrm < 2.4 found, disabling build of i965 video driver]) | ||
22 | +if test x$enable_i965_driver = xyes && ! $PKG_CONFIG --atleast-version=2.4 libdrm-poulsbo; then | ||
23 | + AC_MSG_WARN([libdrm-poulsbo < 2.4 found, disabling build of i965 video driver]) | ||
24 | enable_i965_driver=no | ||
25 | fi | ||
26 | AM_CONDITIONAL(BUILD_I965_DRIVER, test x$enable_i965_driver = xyes) | ||
diff --git a/meta-emenlow/packages/libva/libva_0.31.0.bb b/meta-emenlow/packages/libva/libva_0.31.0.bb index bd9f758b00..0bc782f9d6 100644 --- a/meta-emenlow/packages/libva/libva_0.31.0.bb +++ b/meta-emenlow/packages/libva/libva_0.31.0.bb | |||
@@ -1,32 +1,33 @@ | |||
1 | DESCRIPTION = "Video Acceleration (VA) API for Linux" | 1 | DESCRIPTION = "Video Acceleration (VA) API for Linux" |
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e" |
4 | PR = "r0" | 4 | PR = "r1" |
5 | 5 | ||
6 | inherit autotools | 6 | inherit autotools |
7 | 7 | ||
8 | SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \ | 8 | SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \ |
9 | file://033_g45_add_rgba_subpic.patch;patch=1 \ | 9 | file://033_g45_add_rgba_subpic.patch \ |
10 | file://034_g45_fix_return_for_unimpl.patch;patch=1 \ | 10 | file://034_g45_fix_return_for_unimpl.patch \ |
11 | file://035_g45_add_yv12_image_format.patch;patch=1 \ | 11 | file://035_g45_add_yv12_image_format.patch \ |
12 | file://036_g45_add_vaGetImage.patch;patch=1 \ | 12 | file://036_g45_add_vaGetImage.patch \ |
13 | file://037_g45_add_vaPutImage.patch;patch=1 \ | 13 | file://037_g45_add_vaPutImage.patch \ |
14 | file://038_g45_vaPutSurface_cliprects.patch;patch=1 \ | 14 | file://038_g45_vaPutSurface_cliprects.patch \ |
15 | file://102_attribute_visibility.patch;patch=1 \ | 15 | file://102_attribute_visibility.patch \ |
16 | file://103_fix_vainfo_deps.patch;patch=1 \ | 16 | file://103_fix_vainfo_deps.patch \ |
17 | file://104_fix_libva_pkgconfig_deps.patch;patch=1 \ | 17 | file://104_fix_libva_pkgconfig_deps.patch \ |
18 | file://105_dont_search_LIBGL_DRIVERS_PATH.patch;patch=1 \ | 18 | file://105_dont_search_LIBGL_DRIVERS_PATH.patch \ |
19 | file://108_drivers_path.patch;patch=1 \ | 19 | file://108_drivers_path.patch \ |
20 | file://203_fix_fglrx_detection.patch;patch=1 \ | 20 | file://203_fix_fglrx_detection.patch \ |
21 | file://204_check_ATIFGLEXTENSION.patch;patch=1 \ | 21 | file://204_check_ATIFGLEXTENSION.patch \ |
22 | file://300_sds_version.patch;patch=1 \ | 22 | file://300_sds_version.patch \ |
23 | file://301_vdpau_mpeg4.patch;patch=1 \ | 23 | file://301_vdpau_mpeg4.patch \ |
24 | file://320_move_vaPutSurface_flags_def.patch;patch=1 \ | 24 | file://320_move_vaPutSurface_flags_def.patch \ |
25 | file://321_libva_glx.base.patch;patch=1 \ | 25 | file://321_libva_glx.base.patch \ |
26 | file://322_libva_glx.patch;patch=1 \ | 26 | file://322_libva_glx.patch \ |
27 | file://390_compat.base.patch;patch=1 \ | 27 | file://390_compat.base.patch \ |
28 | file://391_compat.patch;patch=1 \ | 28 | file://391_compat.patch \ |
29 | file://392_compat.dso.patch;patch=1" | 29 | file://392_compat.dso.patch \ |
30 | file://libdrm-poulsbo.patch" | ||
30 | 31 | ||
31 | export LDFLAGS="-Wl,-z,defs" | 32 | export LDFLAGS="-Wl,-z,defs" |
32 | 33 | ||
@@ -34,5 +35,5 @@ EXTRA_OECONF = "--disable-i965-driver" | |||
34 | 35 | ||
35 | FILES_${PN} += "${libdir}/va/drivers/*" | 36 | FILES_${PN} += "${libdir}/va/drivers/*" |
36 | 37 | ||
37 | COMAPTIBLE_MACHINE = "emenlow" | 38 | COMPATIBLE_MACHINE = "emenlow" |
38 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 39 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/meta-emenlow/packages/xorg-xserver/files/libdrm-poulsbo.patch b/meta-emenlow/packages/xorg-xserver/files/libdrm-poulsbo.patch new file mode 100644 index 0000000000..2f036f1baa --- /dev/null +++ b/meta-emenlow/packages/xorg-xserver/files/libdrm-poulsbo.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | # Make the server depend on libdrm-poulsbo instead of libdrm so that the | ||
2 | # emenlow libdrm can coexist with the normal libdrm. | ||
3 | # jdike@linux.intel.com | ||
4 | |||
5 | Index: xorg-server-1.7.99.2/configure.ac | ||
6 | =================================================================== | ||
7 | --- xorg-server-1.7.99.2.orig/configure.ac | ||
8 | +++ xorg-server-1.7.99.2/configure.ac | ||
9 | @@ -763,7 +763,7 @@ dnl List of libraries that require a spe | ||
10 | LIBAPPLEWM="applewm >= 1.4" | ||
11 | LIBDMX="dmx >= 1.0.99.1" | ||
12 | LIBDRI="dri >= 7.1.0" | ||
13 | -LIBDRM="libdrm >= 2.3.0" | ||
14 | +LIBDRM="libdrm-poulsbo >= 2.3.0" | ||
15 | LIBGL="gl >= 7.1.0" | ||
16 | LIBXEXT="xext >= 1.0.99.4" | ||
17 | LIBXI="xi >= 1.2.99.1" | ||
18 | @@ -2002,7 +2002,7 @@ if test "$KDRIVE" = yes; then | ||
19 | XEPHYR_REQUIRED_LIBS="$XEPHYR_REQUIRED_LIBS xv" | ||
20 | fi | ||
21 | if test "x$DRI" = xyes && test "x$GLX" = xyes; then | ||
22 | - XEPHYR_REQUIRED_LIBS="$XEPHYR_REQUIRED_LIBS $LIBGL libdrm" | ||
23 | + XEPHYR_REQUIRED_LIBS="$XEPHYR_REQUIRED_LIBS $LIBGL libdrm-poulsbo" | ||
24 | fi | ||
25 | |||
26 | PKG_CHECK_MODULES(XEPHYR, $XEPHYR_REQUIRED_LIBS, [xephyr="yes"], [xephyr="no"]) | ||
diff --git a/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb b/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb index a732f089f9..60906919ca 100644 --- a/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb +++ b/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb | |||
@@ -1,19 +1,20 @@ | |||
1 | require ../meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc | 1 | require ../meta/packages/xorg-xserver/xserver-xf86-dri-lite.inc |
2 | 2 | ||
3 | PR = "r1" | 3 | PR = "r2" |
4 | 4 | ||
5 | PROTO_DEPS += "xf86driproto dri2proto" | 5 | PROTO_DEPS += "xf86driproto dri2proto" |
6 | 6 | ||
7 | DEPENDS += "font-util" | 7 | DEPENDS += "font-util" |
8 | 8 | ||
9 | SRC_URI += "file://nodolt.patch;patch=1 \ | 9 | SRC_URI += "file://nodolt.patch \ |
10 | file://crosscompile.patch;patch=1" | 10 | file://crosscompile.patch \ |
11 | file://libdrm-poulsbo.patch" | ||
11 | 12 | ||
12 | # Misc build failure for master HEAD | 13 | # Misc build failure for master HEAD |
13 | SRC_URI += "file://fix_open_max_preprocessor_error.patch;patch=1" | 14 | SRC_URI += "file://fix_open_max_preprocessor_error.patch" |
14 | 15 | ||
15 | EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga --enable-glx" | 16 | EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga --enable-glx" |
16 | 17 | ||
17 | DEPENDS += "psb-firmware xpsb-glx psb-kernel-source libdrm-poulsbo libva" | 18 | DEPENDS += "psb-firmware xpsb-glx psb-kernel-source libdrm-poulsbo libva" |
18 | 19 | ||
19 | COMPATBILE_MACHINE = "emenlow" | 20 | COMPATIBLE_MACHINE = "emenlow" |