summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-21 17:31:45 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 22:39:43 +0100
commite8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304 (patch)
treec8ed16e490e2e30de292c8a10eedb084d5abdea8 /meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
parent0c3b1aa0a5461c9b5f3833feb091f7c8a459ca9b (diff)
downloadpoky-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.gz
meta-emenlow: Layer for eMenlow-based systems.
This layer provides a kernel suitable for booting on eMenlow-based systems, plus support for Poulsbo graphics. The Poulsbo support includes a kernel patch for the graphics driver, a couple of libraries, the 2D and 3D X drivers, and a properly configured X server. The closed portions of this support are in the 3D driver, xpsb-glx. This package contains the binaries for the libraries that communicate with the kernel driver and a mesa library which uses those libraries. There is a README in meta-emenlow/ describing how to enable this layer. Where possible, the recipes use bitbake's new .bbappend facility in order to avoid copying recipes from meta/. There are checksums and license information for all of the new packages. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb')
-rw-r--r--meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
new file mode 100644
index 0000000000..41b15890fa
--- /dev/null
+++ b/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "X11 drivers for Poulsbo (psb) 3D acceleration"
2
3# There's a mesa implementation in this package, which is presumably
4# not Intel proprietary, but it has no obvious license attached to it.
5LICENSE = "Intel-binary-only"
6LIC_FILES_CHKSUM = "file://${WORKDIR}/${PN}-${PV}/COPYING;md5=02c597a2f082b4581596065bb5a521a8"
7PR = "r1"
8
9inherit autotools
10
11PROVIDES = "virtual/libgl mesa-dri"
12
13SRC_URI="https://launchpad.net/~gma500/+archive/ppa/+files/xpsb-glx_0.18-0ubuntu1netbook2~1004um1ubuntu1.tar.gz \
14 file://cross-compile.patch;patch=1"
15
16do_configure () {
17 chmod +x autogen.sh && ./autogen.sh && make realclean
18}
19
20do_install() {
21 make DESTDIR=${D} install
22 install -d -m 0755 ${D}/${libdir}/xorg/modules/dri \
23 ${D}/${libdir}/xorg/modules/drivers
24 install -m 0644 ${WORKDIR}/${PN}-${PV}/dri/* \
25 ${D}/${libdir}/xorg/modules/dri
26 install -m 0644 ${WORKDIR}/${PN}-${PV}/drivers/* \
27 ${D}/${libdir}/xorg/modules/drivers
28}
29
30S = "${WORKDIR}/${PN}-${PV}/mesa"
31
32EXTRA_OEMAKE = "linux-dri-x86"
33
34DEPENDS += "libdrm-poulsbo libxxf86vm dri2proto libxmu libxi glproto"
35
36FILES_${PN} = "${libdir}/* ${libdir}/xorg/modules/dri/* \
37 ${libdir}/xorg/modules/drivers/*"
38
39# Multiple virtual/gl providers being built breaks staging
40EXCLUDE_FROM_WORLD = "1"