summaryrefslogtreecommitdiffstats
path: root/meta-demoapps
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-26 16:30:04 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 10:45:48 +0100
commite51bd9b600d5e625e36f3df5af4aa8b76e648524 (patch)
treed9ae56bf40089a67e2374cc08d36ac8f6339c52d /meta-demoapps
parentaa7ec171103d5e8fa26ad875bf209e373f295d7a (diff)
downloadpoky-e51bd9b600d5e625e36f3df5af4aa8b76e648524.tar.gz
tidy: move old clutter demo to meta-demoapps
(From OE-Core rev: 6f8c5dbf3cbe33d5d5c037a9078291da1b7e56e8) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-demoapps')
-rw-r--r--meta-demoapps/recipes-graphics/clutter/tidy.inc20
-rw-r--r--meta-demoapps/recipes-graphics/clutter/tidy/autofoo.patch11
-rw-r--r--meta-demoapps/recipes-graphics/clutter/tidy/tidy-enable-tests.patch20
-rw-r--r--meta-demoapps/recipes-graphics/clutter/tidy_git.bb13
4 files changed, 64 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-graphics/clutter/tidy.inc b/meta-demoapps/recipes-graphics/clutter/tidy.inc
new file mode 100644
index 0000000000..13d6fc7686
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/tidy.inc
@@ -0,0 +1,20 @@
1DESCRIPTION = "Tidy library"
2HOMEPAGE = "http://www.clutter-project.org/"
3LICENSE = "LGPLv2.1+"
4
5STDDEPENDS = "clutter-1.4"
6BASE_CONF = "--disable-gtk-doc"
7
8DEPENDS = "${STDDEPENDS}"
9EXTRA_OECONF = "${BASE_CONF}"
10
11inherit autotools pkgconfig
12
13PACKAGES =+ "tidy-examples"
14FILES_tidy-examples = "${bindir}/test-*"
15
16do_configure_prepend() {
17 touch ${S}/gtk-doc.make
18 sed -i s:docs/reference/Makefile::g ${S}/configure.ac
19 sed -i s:docs::g ${S}/Makefile.am
20}
diff --git a/meta-demoapps/recipes-graphics/clutter/tidy/autofoo.patch b/meta-demoapps/recipes-graphics/clutter/tidy/autofoo.patch
new file mode 100644
index 0000000000..7f54a3372a
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/tidy/autofoo.patch
@@ -0,0 +1,11 @@
1Index: tidy/doc/reference/Makefile.am
2===================================================================
3--- tidy.orig/doc/reference/Makefile.am 2007-11-06 19:36:56.000000000 +0000
4+++ tidy/doc/reference/Makefile.am 2007-11-06 19:37:02.000000000 +0000
5@@ -77,4 +77,4 @@ include $(top_srcdir)/gtk-doc.make
6
7 # Other files to distribute
8 # e.g. EXTRA_DIST += version.xml.in
9-EXTRA_DIST += version.xml.in
10+EXTRA_DIST = version.xml.in
11
diff --git a/meta-demoapps/recipes-graphics/clutter/tidy/tidy-enable-tests.patch b/meta-demoapps/recipes-graphics/clutter/tidy/tidy-enable-tests.patch
new file mode 100644
index 0000000000..c5e1660c54
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/tidy/tidy-enable-tests.patch
@@ -0,0 +1,20 @@
1Index: trunk/tests/Makefile.am
2===================================================================
3--- trunk.orig/tests/Makefile.am 2008-03-04 12:22:10.000000000 +0000
4+++ trunk/tests/Makefile.am 2008-03-04 12:23:46.000000000 +0000
5@@ -1,4 +1,4 @@
6-noinst_PROGRAMS = \
7+bin_PROGRAMS = \
8 test-button \
9 test-finger-scroll \
10 test-list-view \
11@@ -14,6 +14,9 @@
12 test-grow \
13 test-viewport
14
15+test_texture_framedir = $(pkgdatadir)
16+test_texture_frame_DATA = frame.png
17+
18 INCLUDES = -I$(top_srcdir)
19 LDADD = $(top_builddir)/tidy/libtidy-1.0.la
20
diff --git a/meta-demoapps/recipes-graphics/clutter/tidy_git.bb b/meta-demoapps/recipes-graphics/clutter/tidy_git.bb
new file mode 100644
index 0000000000..222ac6e9d1
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/tidy_git.bb
@@ -0,0 +1,13 @@
1require tidy.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
4 file://tidy/tidy.h;endline=21;md5=ac342e7aac55849bf0755d79967fa3e8"
5
6PV = "0.1.0+git${SRCPV}"
7PR = "r7"
8
9SRC_URI = "git://git.clutter-project.org/tidy.git;protocol=git \
10 file://tidy-enable-tests.patch;patch=1"
11
12S = "${WORKDIR}/git"
13