summaryrefslogtreecommitdiffstats
path: root/meta-demoapps
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-26 16:29:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-28 10:45:48 +0100
commitaa7ec171103d5e8fa26ad875bf209e373f295d7a (patch)
tree8430e2c3b3704ea673a5687679dfa959f52d0354 /meta-demoapps
parent777f1a3f85c40f45ebbe53183358a38dec50c73b (diff)
downloadpoky-aa7ec171103d5e8fa26ad875bf209e373f295d7a.tar.gz
table: move old clutter demo to meta-demoapps
(From OE-Core rev: 36ec158df1ed6db4dc917d16fa7adb0f34fec0b4) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-demoapps')
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table.inc13
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table/fixes.patch14
-rw-r--r--meta-demoapps/recipes-graphics/clutter/table_git.bb14
3 files changed, 41 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-graphics/clutter/table.inc b/meta-demoapps/recipes-graphics/clutter/table.inc
new file mode 100644
index 0000000000..937ad56b9c
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "Table Clutter Demo"
2HOMEPAGE = "http://www.clutter-project.org/"
3LICENSE = "LGPLv2.1 & GPLv2"
4
5DEPENDS = "clutter-gst-1.4 gnome-vfs"
6
7inherit autotools pkgconfig
8
9do_install() {
10 install -d ${D}${bindir}
11 install -m 0755 ${S}/table ${D}${bindir}/table
12}
13
diff --git a/meta-demoapps/recipes-graphics/clutter/table/fixes.patch b/meta-demoapps/recipes-graphics/clutter/table/fixes.patch
new file mode 100644
index 0000000000..a7cdc43713
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table/fixes.patch
@@ -0,0 +1,14 @@
1Index: table/Makefile
2===================================================================
3--- table.orig/Makefile 2007-07-10 13:24:18.000000000 +0100
4+++ table/Makefile 2007-07-10 13:28:10.000000000 +0100
5@@ -8,7 +8,7 @@ all: table
6
7
8 table: table.o clutter-dominatrix.o clutter-video-player.o
9- $(CC) -g -Wall $(CFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
10+ $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS)
11
12 clean:
13 rm -fr *.o table
14\ No newline at end of file
diff --git a/meta-demoapps/recipes-graphics/clutter/table_git.bb b/meta-demoapps/recipes-graphics/clutter/table_git.bb
new file mode 100644
index 0000000000..5a5091cc1d
--- /dev/null
+++ b/meta-demoapps/recipes-graphics/clutter/table_git.bb
@@ -0,0 +1,14 @@
1require table.inc
2
3LIC_FILES_CHKSUM = "file://fluttr/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
4 file://script-viewer/COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
5
6PV = "0.3.0+git${SRCPV}"
7PR = "r1"
8
9SRC_URI = "git://git.clutter-project.org/toys.git;protocol=git \
10 file://fixes.patch;patch=1"
11
12S = "${WORKDIR}/git/table"
13
14