summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-support
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-support')
-rw-r--r--meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb14
-rw-r--r--meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch11
-rw-r--r--meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb24
-rw-r--r--meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch16
-rw-r--r--meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch13
-rw-r--r--meta-demoapps/recipes-support/openobex/openobex_1.5.bb23
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb16
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler-fpu.inc6
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler.inc18
-rw-r--r--meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb2
10 files changed, 143 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb b/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb
new file mode 100644
index 0000000000..23d025f4d2
--- /dev/null
+++ b/meta-demoapps/recipes-support/iso-codes/iso-codes_3.3.bb
@@ -0,0 +1,14 @@
1SECTION = "libs"
2DESCRIPTION = "ISO language, territory, currency, script codes and their translations"
3PRIORITY = "optional"
4LICENSE = "LGPL"
5SECTION = "libs"
6PACKAGE_ARCH = "all"
7
8SRC_URI = "ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/iso-codes-${PV}.tar.gz"
9
10inherit autotools
11
12FILES_${PN}-dev="${datadir}/pkgconfig/iso-codes.pc"
13FILES_${PN}="${datadir}/xml/iso-codes/ \
14 ${datadir}/iso-codes/"
diff --git a/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch b/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch
new file mode 100644
index 0000000000..c7031008fd
--- /dev/null
+++ b/meta-demoapps/recipes-support/libfribidi/files/libtool-update.patch
@@ -0,0 +1,11 @@
1--- fribidi-0.10.4/configure.in~ 2002-05-19 11:06:48.000000000 +0100
2+++ fribidi-0.10.4/configure.in 2004-08-03 17:42:28.000000000 +0100
3@@ -50,7 +50,7 @@
4 AC_PROG_INSTALL
5 AC_PROG_LN_S
6 AC_PROG_MAKE_SET
7-AC_PROG_RANLIB
8+#AC_PROG_RANLIB
9 AC_PATH_PROG(SED, sed, $PATH)
10
11
diff --git a/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb b/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb
new file mode 100644
index 0000000000..d60a190cbd
--- /dev/null
+++ b/meta-demoapps/recipes-support/libfribidi/libfribidi_0.10.4.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Fribidi library for bidirectional text"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "GPL"
5
6inherit autotools pkgconfig
7
8PR = "r0"
9
10S = "${WORKDIR}/fribidi-${PV}"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/fribidi/fribidi-${PV}.tar.bz2 \
13 file://libtool-update.patch;patch=1"
14
15#PACKAGES += " ${PN}-bin"
16FILES_${PN} = "${libdir}/lib*.so.*"
17#FILES_${PN}-bin = "${libdir}/uu*"
18
19do_configure_prepend () {
20# this version of libtool is old - we have to nobble this file to get it to litoolize
21 rm ltconfig
22 rm aclocal.m4
23 rm acinclude.m4
24}
diff --git a/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch b/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch
new file mode 100644
index 0000000000..95b636dd8f
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/files/disable-cable-test.patch
@@ -0,0 +1,16 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- openobex-1.2/apps/Makefile.am~disable-cable-test
7+++ openobex-1.2/apps/Makefile.am
8@@ -6,7 +6,7 @@
9 obex_io.c obex_io.h \
10 obex_put_common.c obex_put_common.h
11
12-bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test
13+bin_PROGRAMS = irxfer obex_tcp irobex_palm3
14
15 obex_test_SOURCES = \
16 obex_test.c obex_test.h \
diff --git a/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch b/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..20ac70bd1e
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/files/libusb_crosscompile_check.patch
@@ -0,0 +1,13 @@
1Index: openobex-1.5/acinclude.m4
2===================================================================
3--- openobex-1.5.orig/acinclude.m4 2009-02-08 18:30:22.000000000 +0000
4+++ openobex-1.5/acinclude.m4 2009-07-31 09:55:46.000000000 +0100
5@@ -158,7 +158,7 @@
6 ;;
7 *)
8 PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
9- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
10+ REQUIRES="libusb"
11 ;;
12 esac
13 AC_SUBST(USB_CFLAGS)
diff --git a/meta-demoapps/recipes-support/openobex/openobex_1.5.bb b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
new file mode 100644
index 0000000000..dc07ae1353
--- /dev/null
+++ b/meta-demoapps/recipes-support/openobex/openobex_1.5.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5PROVIDES = "openobex-apps"
6DEPENDS = "libusb bluez4"
7LICENSE = "GPL"
8PR = "r4"
9
10SRC_URI = "${KERNELORG_MIRROR}/pub/linux/bluetooth/openobex-${PV}.tar.gz \
11 file://disable-cable-test.patch;patch=1 \
12 file://libusb_crosscompile_check.patch;patch=1"
13
14inherit autotools binconfig pkgconfig
15
16EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
17 --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
18
19# how to stop shlibrename from renaming -apps?
20PACKAGES += "openobex-apps"
21FILES_${PN} = "${libdir}/lib*.so.*"
22FILES_${PN}-dev += "${bindir}/openobex-config"
23FILES_${PN}-apps = "${bindir}/*"
diff --git a/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb
new file mode 100644
index 0000000000..ca22e4dba0
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
2LICENSE = "Adobe"
3PR = "r0"
4
5SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
6
7do_compile() {
8}
9
10do_install() {
11 oe_runmake install DESTDIR=${D}
12}
13
14FILES_${PN} += "${datadir}"
15PACKAGE_ARCH = "all"
16
diff --git a/meta-demoapps/recipes-support/poppler/poppler-fpu.inc b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc
new file mode 100644
index 0000000000..a26273020a
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc
@@ -0,0 +1,6 @@
1
2def get_poppler_fpu_setting(bb, d):
3 if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
4 return "--enable-fixedpoint"
5 return ""
6
diff --git a/meta-demoapps/recipes-support/poppler/poppler.inc b/meta-demoapps/recipes-support/poppler/poppler.inc
new file mode 100644
index 0000000000..645e734e8b
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler.inc
@@ -0,0 +1,18 @@
1DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base."
2DEPENDS = "fontconfig jpeg zlib gtk+ cairo"
3LICENSE = "GPL"
4PR = "r1"
5
6SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz"
7
8inherit autotools pkgconfig
9
10EXTRA_OECONF = " --enable-xpdf-headers \
11 --disable-gtk-test \
12 --disable-poppler-qt --disable-poppler-qt4 \
13 --enable-zlib \
14 "
15
16#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
17require poppler-fpu.inc
18EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}"
diff --git a/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb
new file mode 100644
index 0000000000..92c25bc0ac
--- /dev/null
+++ b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb
@@ -0,0 +1,2 @@
1require poppler.inc
2PR = "r2"