diff options
author | Saul Wold <Saul.Wold@intel.com> | 2010-11-22 13:57:13 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-11-22 13:57:13 +0000 |
commit | cfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch) | |
tree | 7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-support/poppler | |
parent | 762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff) | |
download | poky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz |
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage
many recipes where moved to a new meta-demoapps layer since this
is more appropriate for demo usage then the core. Additional some
recipes were moved to meta-extras to indicate they may be depercated
at a future time.
A number of recipes were modified since dependencies need to be
corrected.
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-support/poppler')
4 files changed, 42 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb new file mode 100644 index 0000000000..ca22e4dba0 --- /dev/null +++ b/meta-demoapps/recipes-support/poppler/poppler-data_0.1.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base." | ||
2 | LICENSE = "Adobe" | ||
3 | PR = "r0" | ||
4 | |||
5 | SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" | ||
6 | |||
7 | do_compile() { | ||
8 | } | ||
9 | |||
10 | do_install() { | ||
11 | oe_runmake install DESTDIR=${D} | ||
12 | } | ||
13 | |||
14 | FILES_${PN} += "${datadir}" | ||
15 | PACKAGE_ARCH = "all" | ||
16 | |||
diff --git a/meta-demoapps/recipes-support/poppler/poppler-fpu.inc b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc new file mode 100644 index 0000000000..a26273020a --- /dev/null +++ b/meta-demoapps/recipes-support/poppler/poppler-fpu.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | |||
2 | def get_poppler_fpu_setting(bb, d): | ||
3 | if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]: | ||
4 | return "--enable-fixedpoint" | ||
5 | return "" | ||
6 | |||
diff --git a/meta-demoapps/recipes-support/poppler/poppler.inc b/meta-demoapps/recipes-support/poppler/poppler.inc new file mode 100644 index 0000000000..645e734e8b --- /dev/null +++ b/meta-demoapps/recipes-support/poppler/poppler.inc | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "Poppler is a PDF rendering library based on the xpdf-3.0 code base." | ||
2 | DEPENDS = "fontconfig jpeg zlib gtk+ cairo" | ||
3 | LICENSE = "GPL" | ||
4 | PR = "r1" | ||
5 | |||
6 | SRC_URI = "http://poppler.freedesktop.org/${PN}-${PV}.tar.gz" | ||
7 | |||
8 | inherit autotools pkgconfig | ||
9 | |||
10 | EXTRA_OECONF = " --enable-xpdf-headers \ | ||
11 | --disable-gtk-test \ | ||
12 | --disable-poppler-qt --disable-poppler-qt4 \ | ||
13 | --enable-zlib \ | ||
14 | " | ||
15 | |||
16 | #check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | ||
17 | require poppler-fpu.inc | ||
18 | EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}" | ||
diff --git a/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb new file mode 100644 index 0000000000..92c25bc0ac --- /dev/null +++ b/meta-demoapps/recipes-support/poppler/poppler_0.9.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require poppler.inc | ||
2 | PR = "r2" | ||