summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb')
-rw-r--r--meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb b/meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb
new file mode 100644
index 0000000000..82dd1d047f
--- /dev/null
+++ b/meta-demoapps/recipes-sato/clipboard-manager/clipboard-manager_0.6.4.bb
@@ -0,0 +1,33 @@
1LICENSE = "GPL"
2DESCRIPTION = "clipboard manager"
3DEPENDS = "virtual/libx11"
4
5SRC_URI = "svn://stage.maemo.org/svn/maemo/projects/haf/tags/clipboard-manager/;module=${PV};proto=https \
6 file://makefile.patch;patch=1 \
7 file://script.patch;patch=1 \
8 file://daemonize.patch;patch=1 \
9 "
10
11S = "${WORKDIR}/${PV}"
12
13inherit autotools pkgconfig
14
15do_install_append () {
16 mv ${D}/${sysconfdir}/X11/Xsession.d/clipboard.sh ${D}/${sysconfdir}/X11/Xsession.d/70clipboard
17 chmod u+x ${D}/${sysconfdir}/X11/Xsession.d/70clipboard
18}
19
20pkg_postinst_clipboard-manager () {
21#!/bin/sh -e
22if [ x"$D" = "x" ]; then
23 {
24 if [ x$(pidof clipboard-manager) != x ]; then
25 kill -TERM $(pidof clipboard-manager)
26 fi
27
28 ${sysconfdir}/X11/Xsession.d/70clipboard
29 } > /dev/null
30else
31 exit 1
32fi
33}