diff options
author | Saul Wold <Saul.Wold@intel.com> | 2010-11-22 13:57:13 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-11-22 13:57:13 +0000 |
commit | cfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch) | |
tree | 7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-gnome/libgtkstylus | |
parent | 762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff) | |
download | poky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz |
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage
many recipes where moved to a new meta-demoapps layer since this
is more appropriate for demo usage then the core. Additional some
recipes were moved to meta-extras to indicate they may be depercated
at a future time.
A number of recipes were modified since dependencies need to be
corrected.
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-gnome/libgtkstylus')
-rw-r--r-- | meta-demoapps/recipes-gnome/libgtkstylus/files/gtkstylus.sh | 5 | ||||
-rw-r--r-- | meta-demoapps/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb | 24 |
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-gnome/libgtkstylus/files/gtkstylus.sh b/meta-demoapps/recipes-gnome/libgtkstylus/files/gtkstylus.sh new file mode 100644 index 0000000000..b1302ede0e --- /dev/null +++ b/meta-demoapps/recipes-gnome/libgtkstylus/files/gtkstylus.sh | |||
@@ -0,0 +1,5 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | GTK_MODULES=libgtkstylus.so | ||
4 | |||
5 | export GTK_MODULES | ||
diff --git a/meta-demoapps/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb b/meta-demoapps/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb new file mode 100644 index 0000000000..f614048a16 --- /dev/null +++ b/meta-demoapps/recipes-gnome/libgtkstylus/libgtkstylus_0.5.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "GTK plugin for stylus based systems" | ||
2 | SECTION = "libs" | ||
3 | DEPENDS = "gtk+" | ||
4 | LICENSE = "LGPL" | ||
5 | PR = "r2" | ||
6 | |||
7 | inherit autotools | ||
8 | |||
9 | SRC_URI = "http://burtonini.com/temp/${PN}-${PV}.tar.gz \ | ||
10 | file://gtkstylus.sh" | ||
11 | |||
12 | do_install_append() { | ||
13 | install -d ${D}/${sysconfdir}/X11/Xsession.d | ||
14 | install -m 755 ${WORKDIR}/gtkstylus.sh ${D}/${sysconfdir}/X11/Xsession.d/45gtkstylus | ||
15 | } | ||
16 | |||
17 | # Horrible but rpm falls over if you use '*' | ||
18 | GTKVER = "2.10.0" | ||
19 | |||
20 | FILES_${PN} = "${sysconfdir} \ | ||
21 | ${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.so.*" | ||
22 | FILES_${PN}-dbg += "${libdir}/gtk-2.0/${GTKVER}/modules/.debug" | ||
23 | FILES_${PN}-dev += "${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.so \ | ||
24 | ${libdir}/gtk-2.0/${GTKVER}/modules/libgtkstylus.*a" | ||