summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch')
-rw-r--r--meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch b/meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch
new file mode 100644
index 0000000000..e6da2eaa5f
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/openswan/openswan-2.4.7/installflags.patch
@@ -0,0 +1,13 @@
1Index: openswan-2.4.7/Makefile.inc
2===================================================================
3--- openswan-2.4.7.orig/Makefile.inc 2006-12-25 18:05:40.608503250 +0100
4+++ openswan-2.4.7/Makefile.inc 2006-12-25 18:06:39.028154250 +0100
5@@ -158,7 +158,7 @@
6 # how backup names are composed.
7 # Note that the install procedures will never overwrite an existing config
8 # file, which is why -b is not specified for them.
9-INSTBINFLAGS=-b --suffix=.old
10+INSTBINFLAGS=
11 INSTSUIDFLAGS=--mode=u+rxs,g+rx,o+rx --group=root -b --suffix=.old
12 INSTMANFLAGS=
13 INSTCONFFLAGS=