summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/libetpan
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/libetpan
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/libetpan')
-rw-r--r--meta-demoapps/recipes-connectivity/libetpan/files/cxx-is-here.patch18
-rw-r--r--meta-demoapps/recipes-connectivity/libetpan/libetpan_0.54.bb20
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/libetpan/files/cxx-is-here.patch b/meta-demoapps/recipes-connectivity/libetpan/files/cxx-is-here.patch
new file mode 100644
index 0000000000..d910daab17
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/libetpan/files/cxx-is-here.patch
@@ -0,0 +1,18 @@
1---
2 configure.ac | 1 +
3 1 file changed, 1 insertion(+)
4
5--- libetpan-0.54.orig/configure.ac
6+++ libetpan-0.54/configure.ac
7@@ -104,10 +104,11 @@ if test "$have_w32_system" = yes; then
8 fi
9 AM_CONDITIONAL(HAVE_MINGW32_SYSTEM, test "$have_w32_system" = yes)
10
11 # Check the C compiler.
12 AC_PROG_CC
13+AC_PROG_CXX
14
15 # Compiler flags.
16 AC_ARG_ENABLE(debug, [ --enable-debug setup flags (gcc) for debugging (default=no)],
17 if test "x$GCC" = xyes; then
18 CFLAGS="$CFLAGS -O2 -g"
diff --git a/meta-demoapps/recipes-connectivity/libetpan/libetpan_0.54.bb b/meta-demoapps/recipes-connectivity/libetpan/libetpan_0.54.bb
new file mode 100644
index 0000000000..9b69471753
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/libetpan/libetpan_0.54.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Library for communicating with mail and news services"
2DESCRIPTION = "libetpan is a library for communicating with mail and news servers. \
3It supports the protocols SMTP, POP3, IMAP and NNTP."
4HOMEPAGE = "http://www.etpan.org"
5SECTION = "libs"
6DEPENDS = "curl expat gnutls"
7LICENSE = "BSD"
8PR = "r1"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/libetpan/libetpan-${PV}.tar.gz \
11 file://cxx-is-here.patch;patch=1"
12
13inherit autotools pkgconfig gettext binconfig
14
15EXTRA_OECONF = "--without-openssl --with-gnutls --disable-db"
16
17PARALLEL_MAKE = ""
18
19FILES_${PN} = "${libdir}/lib*.so.*"
20FILES_${PN}-dev = "${bindir} ${includedir} ${libdir}/lib*.so ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"