summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-connectivity/farsight
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta-demoapps/recipes-connectivity/farsight
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-demoapps/recipes-connectivity/farsight')
-rw-r--r--meta-demoapps/recipes-connectivity/farsight/farsight2_0.0.9.bb24
-rw-r--r--meta-demoapps/recipes-connectivity/farsight/libnice_0.0.6.bb24
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-demoapps/recipes-connectivity/farsight/farsight2_0.0.9.bb b/meta-demoapps/recipes-connectivity/farsight/farsight2_0.0.9.bb
new file mode 100644
index 0000000000..e20ec33d64
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/farsight/farsight2_0.0.9.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
2HOMEPAGE = "http://farsight.sf.net"
3SRC_URI = "http://farsight.freedesktop.org/releases/farsight2/${P}.tar.gz"
4LICENSE = "GPLv2.1"
5DEPENDS = "libnice glib-2.0 libxml2 zlib dbus gstreamer gst-plugins-base"
6
7inherit autotools
8AUTOTOOLS_STAGE_PKGCONFIG = "1"
9
10PR = "r1"
11
12EXTRA_OECONF = " \
13 --disable-debug \
14 --disable-gtk-doc \
15 --disable-python \
16"
17
18FILES_${PN} += "${libdir}/*/*.so"
19FILES_${PN}-dev += "${libdir}/f*/*a ${libdir}/g*/*a"
20FILES_${PN}-dbg += "${libdir}/*/.debug"
21
22
23
24
diff --git a/meta-demoapps/recipes-connectivity/farsight/libnice_0.0.6.bb b/meta-demoapps/recipes-connectivity/farsight/libnice_0.0.6.bb
new file mode 100644
index 0000000000..a837cadee0
--- /dev/null
+++ b/meta-demoapps/recipes-connectivity/farsight/libnice_0.0.6.bb
@@ -0,0 +1,24 @@
1SUMMARY = "IETF draft Interactice Connectivity Establishment standard"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
4SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
5
6LICENSE = "LGPL/MPL"
7DEPENDS = "glib-2.0 gstreamer"
8
9inherit autotools
10AUTOTOOLS_STAGE_PKGCONFIG = "1"
11
12FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
13FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*a"
14FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
15
16do_compile_append() {
17 for i in $(find ${S} -name "*.pc") ; do
18 sed -i -e s:${STAGING_DIR_TARGET}::g \
19 -e s:/${TARGET_SYS}::g \
20 $i
21 done
22}
23
24