summaryrefslogtreecommitdiffstats
path: root/handbook/poky-doc-tools/configure.ac
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
committerRichard Purdie <richard@openedhand.com>2008-02-26 11:31:34 +0000
commit882e9cd2affb773eec8b1d387ab4e3b5cbdc0994 (patch)
treef023b2ce9abf3b894a81986e0a00e23d77b55e66 /handbook/poky-doc-tools/configure.ac
parent7197110f46511492a48cd359b3ddf75b60ea47c8 (diff)
downloadpoky-882e9cd2affb773eec8b1d387ab4e3b5cbdc0994.tar.gz
Add Poky handbook
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3865 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'handbook/poky-doc-tools/configure.ac')
-rw-r--r--handbook/poky-doc-tools/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/handbook/poky-doc-tools/configure.ac b/handbook/poky-doc-tools/configure.ac
new file mode 100644
index 0000000000..0d15c8198c
--- /dev/null
+++ b/handbook/poky-doc-tools/configure.ac
@@ -0,0 +1,27 @@
1AC_PREREQ(2.53)
2AC_INIT(poky-doc-tools, 0.1, http://o-hand.com)
3AM_INIT_AUTOMAKE()
4
5AC_PATH_PROG(HAVE_XSLTPROC, xsltproc, no)
6if test x$HAVE_XSLTPROC = xno; then
7 AC_MSG_ERROR([Required xsltproc program not found])
8fi
9
10AC_PATH_PROG(HAVE_FOP, fop, no)
11if test x$HAVE_FOP = xno; then
12 AC_MSG_ERROR([Required fop program not found])
13fi
14
15AC_CHECK_FILE([/usr/share/xml/docbook/stylesheet/nwalsh/template/titlepage.xsl],HAVE_NWALSH="yes", HAVE_NWALSH="no")
16if test x$HAVE_FOP = xno; then
17 AC_MSG_ERROR([Required 'nwalsh' docbook stylesheets not found])
18fi
19
20AC_OUTPUT([
21Makefile
22common/Makefile
23])
24
25echo "
26 == poky-doc-tools $VERSION configured successfully. ==
27" \ No newline at end of file