summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-14 18:13:14 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-09 09:43:46 (GMT)
commitc1b081b226506301f45c93fad3e2ae41ed19728c (patch)
treeeb9fae8f2e0e5d063b6621584d16222f930daadf
parent94eada52a7dde3bbf7c8c5c4d030689fa6f337f6 (diff)
downloadpoky-c1b081b226506301f45c93fad3e2ae41ed19728c.tar.gz
populate_sdk_ext: We now require python3, not python
We no longer expect a "python" binary in PATH so update the eSDK's expectations to match. This was the only failure on autobuilder test systems with python missing. (From OE-Core rev: 946ce21b10dcad506edcaadb4e4242c049e4c316) (From OE-Core rev: 775336424bcc7c083e2ac6ccd3db0b16e87dc29a) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/populate_sdk_ext.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/populate_sdk_ext.bbclass b/meta/classes/populate_sdk_ext.bbclass
index 40b0375..8245361 100644
--- a/meta/classes/populate_sdk_ext.bbclass
+++ b/meta/classes/populate_sdk_ext.bbclass
@@ -574,8 +574,8 @@ sdk_ext_preinst() {
574 exit 1 574 exit 1
575 fi 575 fi
576 # The relocation script used by buildtools installer requires python 576 # The relocation script used by buildtools installer requires python
577 if ! command -v python > /dev/null; then 577 if ! command -v python3 > /dev/null; then
578 echo "ERROR: The installer requires python, please install it first" 578 echo "ERROR: The installer requires python3, please install it first"
579 exit 1 579 exit 1
580 fi 580 fi
581 missing_utils="" 581 missing_utils=""