summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-xlnx-dev.bb2
-rw-r--r--recipes-kernel/linux/linux-xlnx.inc42
-rw-r--r--recipes-kernel/linux/linux-xlnx_3.8.bb5
3 files changed, 41 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-xlnx-dev.bb b/recipes-kernel/linux/linux-xlnx-dev.bb
index d27f506e..95e8af68 100644
--- a/recipes-kernel/linux/linux-xlnx-dev.bb
+++ b/recipes-kernel/linux/linux-xlnx-dev.bb
@@ -25,7 +25,7 @@ KBRANCH_DEFAULT = "master"
25 25
26include linux-xlnx.inc 26include linux-xlnx.inc
27 27
28SRC_URI = "git://github.com/Xilinx/linux-xlnx.git;protocol=git;nocheckout=1;branch=${KBRANCH}" 28SRC_URI = "git://github.com/Xilinx/linux-xlnx.git;protocol=git;branch=${KBRANCH}"
29 29
30# Set default SRCREVs. SRCREVs statically set to prevent network access during 30# Set default SRCREVs. SRCREVs statically set to prevent network access during
31# parsing. If linux-xlnx-dev is the preferred provider, they will be overridden 31# parsing. If linux-xlnx-dev is the preferred provider, they will be overridden
diff --git a/recipes-kernel/linux/linux-xlnx.inc b/recipes-kernel/linux/linux-xlnx.inc
index e405b379..7d2952c6 100644
--- a/recipes-kernel/linux/linux-xlnx.inc
+++ b/recipes-kernel/linux/linux-xlnx.inc
@@ -1,16 +1,24 @@
1inherit kernel 1DESCRIPTION = "Xilinx Kernel"
2SECTION = "kernel"
3LICENSE = "GPLv2"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
2 6
3# This version extension should match CONFIG_LOCALVERSION in defconfig 7# This version extension should match CONFIG_LOCALVERSION in defconfig
4LINUX_VERSION_EXTENSION ?= "-xilinx" 8LINUX_VERSION_EXTENSION ?= "-xilinx"
9PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCREV}"
5 10
6require recipes-kernel/linux/linux-yocto.inc 11# Sources
7require linux-machine-common.inc 12SRC_URI = "git://github.com/Xilinx/linux-xlnx;protocol=git"
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/files:" 13FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
10FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:" 14FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:"
11SRC_URI = "git://github.com/Xilinx/linux-xlnx;protocol=git;nocheckout=1"
12 15
13PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCREV}" 16# Source Directory
17S = "${WORKDIR}/git"
18
19# Inherit/include base functionality
20inherit kernel
21require linux-machine-common.inc
14 22
15# Override COMPATIBLE_MACHINE to include your machine in a bbappend file. 23# Override COMPATIBLE_MACHINE to include your machine in a bbappend file.
16COMPATIBLE_MACHINE = "qemumicroblaze|qemuzynq|microblaze|zynq" 24COMPATIBLE_MACHINE = "qemumicroblaze|qemuzynq|microblaze|zynq"
@@ -22,3 +30,25 @@ MACHINE_KCONFIG_append_microblaze += "common/microblaze_defconfig_${LINUX_VERSIO
22 30
23# Add the modules directory to the 'kernel-base' files list 31# Add the modules directory to the 'kernel-base' files list
24FILES_kernel-base_append = " /lib/modules/${KERNEL_VERSION}/kernel" 32FILES_kernel-base_append = " /lib/modules/${KERNEL_VERSION}/kernel"
33
34# returns all the elements from the src uri that are .cfg files
35def find_config_fragments(d):
36 sources=src_patches(d, True)
37 sources_list=[]
38 for s in sources:
39 if s.endswith('.cfg'):
40 sources_list.append(s)
41 return sources_list
42
43kernel_do_configure_prepend() {
44 # Find all ".cfg" files and cat them together into a .config
45 CFG_FILES="${@" ".join(find_config_fragments(d))}"
46 if [ ! -z "$CFG_FILES" ]; then
47 echo "# Generated by linux-xlnx recipe in meta-xilinx" > "${B}/.config"
48 for i in $CFG_FILES; do
49 echo "Joining configuration file $i"
50 echo "# $i" >> "${B}/.config"
51 cat $i >> "${B}/.config"
52 done
53 fi
54}
diff --git a/recipes-kernel/linux/linux-xlnx_3.8.bb b/recipes-kernel/linux/linux-xlnx_3.8.bb
index ce54dc9b..24cf7d4e 100644
--- a/recipes-kernel/linux/linux-xlnx_3.8.bb
+++ b/recipes-kernel/linux/linux-xlnx_3.8.bb
@@ -9,5 +9,8 @@ SRCREV = "6a0bedad60e2bca8d9b50bf81b9895e29e31a6d7"
9 9
10# MicroBlaze patches 10# MicroBlaze patches
11SRC_URI_append_microblaze = " \ 11SRC_URI_append_microblaze = " \
12 file://microblaze-patches_v3.8.scc \ 12 file://microblaze_Do_not_use_r6_in_head.S.patch \
13 file://microblaze_Fix_free_init_pages_function.patch \
14 file://microblaze_Fix_initrd_support.patch \
15 file://arch_microblaze_Add_linux.bin.ub_target.patch \
13 " 16 "