summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch')
-rw-r--r--recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch87
1 files changed, 0 insertions, 87 deletions
diff --git a/recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch b/recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch
deleted file mode 100644
index 4c7d05aa..00000000
--- a/recipes-devtools/qemu/qemu-zynqmp-mainline/0012-arm-Add-xlnx-ep108-machine.patch
+++ /dev/null
@@ -1,87 +0,0 @@
1From 0b9dbaa31007d9d7ef8bafcdcb756ffdcc591e03 Mon Sep 17 00:00:00 2001
2From: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
3Date: Mon, 23 Mar 2015 04:05:17 -0700
4Subject: [PATCH 12/15] arm: Add xlnx-ep108 machine
5
6Add a machine model for the Xilinx ZynqMP SoC EP108 board.
7
8Signed-off-by: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
9Reviewed-by: Alistair Francis <alistair.francis@xilinx.com>
10---
11 hw/arm/Makefile.objs | 2 +-
12 hw/arm/xlnx-ep108.c | 53 ++++++++++++++++++++++++++++++++++++++++++++++++++
13 2 files changed, 54 insertions(+), 1 deletion(-)
14 create mode 100644 hw/arm/xlnx-ep108.c
15
16diff --git a/hw/arm/Makefile.objs b/hw/arm/Makefile.objs
17index d7cd5f4..a75a182 100644
18--- a/hw/arm/Makefile.objs
19+++ b/hw/arm/Makefile.objs
20@@ -10,4 +10,4 @@ obj-$(CONFIG_DIGIC) += digic.o
21 obj-y += omap1.o omap2.o strongarm.o
22 obj-$(CONFIG_ALLWINNER_A10) += allwinner-a10.o cubieboard.o
23 obj-$(CONFIG_STM32F205_SOC) += stm32f205_soc.o
24-obj-$(CONFIG_XLNX_ZYNQMP) += xlnx-zynqmp.o
25+obj-$(CONFIG_XLNX_ZYNQMP) += xlnx-zynqmp.o xlnx-ep108.o
26diff --git a/hw/arm/xlnx-ep108.c b/hw/arm/xlnx-ep108.c
27new file mode 100644
28index 0000000..81704bb
29--- /dev/null
30+++ b/hw/arm/xlnx-ep108.c
31@@ -0,0 +1,53 @@
32+/*
33+ * Xilinx ZynqMP EP108 board
34+ *
35+ * Copyright (C) 2015 Xilinx Inc
36+ * Written by Peter Crosthwaite <peter.crosthwaite@xilinx.com>
37+ *
38+ * This program is free software; you can redistribute it and/or modify it
39+ * under the terms of the GNU General Public License as published by the
40+ * Free Software Foundation; either version 2 of the License, or
41+ * (at your option) any later version.
42+ *
43+ * This program is distributed in the hope that it will be useful, but WITHOUT
44+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
45+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
46+ * for more details.
47+ */
48+
49+#include "hw/arm/xlnx-zynqmp.h"
50+#include "hw/boards.h"
51+#include "qemu/error-report.h"
52+
53+typedef struct XlnxEP108 {
54+ XlnxZynqMPState soc;
55+} XlnxEP108;
56+
57+static void xlnx_ep108_init(MachineState *machine)
58+{
59+ XlnxEP108 *s = g_new0(XlnxEP108, 1);
60+ Error *err = NULL;
61+
62+ object_initialize(&s->soc, sizeof(s->soc), TYPE_XLNX_ZYNQMP);
63+ object_property_add_child(OBJECT(machine), "soc", OBJECT(&s->soc),
64+ &error_abort);
65+
66+ object_property_set_bool(OBJECT(&s->soc), true, "realized", &err);
67+ if (err) {
68+ error_report("%s", error_get_pretty(err));
69+ exit(1);
70+ }
71+}
72+
73+static QEMUMachine xlnx_ep108_machine = {
74+ .name = "xlnx-ep108",
75+ .desc = "Xilinx ZynqMP EP108 board",
76+ .init = xlnx_ep108_init,
77+};
78+
79+static void xlnx_ep108_machine_init(void)
80+{
81+ qemu_register_machine(&xlnx_ep108_machine);
82+}
83+
84+machine_init(xlnx_ep108_machine_init);
85--
861.7.10.4
87