summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb')
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb b/recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb
new file mode 100644
index 00000000..db23c204
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-devicetrees_2.6.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Xilinx's hardware device trees required for QEMU"
2HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
3LICENSE = "BSD"
4DEPENDS += "dtc-native"
5
6inherit deploy
7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9
10XILINX_RELEASE_VERSION = "v2016.4"
11SRCREV = "1085e32a9ddc232963512923332094a58a05d1af"
12SRC_URI = "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https;nobranch=1"
13
14S = "${WORKDIR}/git"
15
16PV = "2.6.0-xilinx-${XILINX_RELEASE_VERSION}+git+${SRCPV}"
17
18# Don't need to do anything
19do_install() {
20 :
21}
22
23do_deploy() {
24 for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
25 if [ ! -f ${DTS_FILE} ]; then
26 bbwarn "${DTS_FILE} is not available!"
27 continue
28 fi
29 DTS_NAME=`basename -s .dtb ${DTS_FILE}`
30 install -d ${DEPLOYDIR}
31 install -d ${DEPLOYDIR}/qemu-hw-devicetrees
32 install -m 0644 ${S}/LATEST/SINGLE_ARCH/${DTS_NAME}.dtb ${DEPLOYDIR}/qemu-hw-devicetrees/${DTS_NAME}.dtb
33 done
34}
35
36addtask deploy after do_install