summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb b/recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb
new file mode 100644
index 00000000..052a65d4
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-spl-xlnx_2015.04.bb
@@ -0,0 +1,37 @@
1include u-boot-xlnx.inc
2include u-boot-xlnx-2015.04.inc
3
4COMPATIBLE_MACHINE = "zynq"
5
6PROVIDES = "virtual/boot-bin"
7
8SPL_BINARY = "boot.bin"
9UBOOT_MAKE_TARGET ?= "boot.bin"
10
11inherit zynq7-platform-paths
12
13DEPENDS += "virtual/zynq7-platform-init"
14
15do_configure_prepend() {
16 [ -e ${PLATFORM_INIT_STAGE_DIR}/ps7_init_gpl.h ] && \
17 cp ${PLATFORM_INIT_STAGE_DIR}/ps7_init_gpl.h ${S}/board/xilinx/zynq/
18 [ -e ${PLATFORM_INIT_STAGE_DIR}/ps7_init_gpl.c ] && \
19 cp ${PLATFORM_INIT_STAGE_DIR}/ps7_init_gpl.c ${S}/board/xilinx/zynq/
20}
21
22do_install () {
23 if [ "x${SPL_BINARY}" != "x" ]; then
24 install -d ${D}/boot
25 install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
26 ln -sf ${SPL_IMAGE} ${D}/boot/${SPL_BINARY}
27 fi
28}
29
30do_deploy () {
31 if [ "x${SPL_BINARY}" != "x" ]; then
32 install ${S}/${SPL_BINARY} ${DEPLOYDIR}/${SPL_IMAGE}
33 rm -f ${DEPLOYDIR}/${SPL_BINARY} ${DEPLOYDIR}/${SPL_SYMLINK}
34 ln -sf ${SPL_IMAGE} ${DEPLOYDIR}/${SPL_BINARY}
35 ln -sf ${SPL_IMAGE} ${DEPLOYDIR}/${SPL_SYMLINK}
36 fi
37}