summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend')
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend15
1 files changed, 12 insertions, 3 deletions
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
index d63529ff..49c897e1 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
@@ -3,7 +3,11 @@ PLMFW_INC = "${@bb.utils.contains('BBMULTICONFIG', 'versal-fw', 'versal-fw-cfg.i
3require ${PLMFW_INC} 3require ${PLMFW_INC}
4 4
5def check_plm_vars(d): 5def check_plm_vars(d):
6 if not d.getVar('PLM_DEPENDS') and not d.getVar('PLM_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'versal-fw' in d.getVar('BBMULTICONFIG').split()): 6 # If both are blank, the user MUST pass in the path to the firmware!
7 if not d.getVar('PLM_DEPENDS') and not d.getVar('PLM_MCDEPENDS'):
8 # Don't cache this, as the items on disk can change!
9 d.setVar('BB_DONT_CACHE', '1')
10
7 msg = "" 11 msg = ""
8 fail = False 12 fail = False
9 if not os.path.exists(d.getVar('PLM_FILE') + ".elf"): 13 if not os.path.exists(d.getVar('PLM_FILE') + ".elf"):
@@ -13,5 +17,10 @@ def check_plm_vars(d):
13 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE') 17 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE')
14 fail = True 18 fail = True
15 if fail: 19 if fail:
16 d.setVar('BB_DONT_CACHE', '1') 20 if not d.getVar('WITHIN_EXT_SDK'):
17 raise bb.parse.SkipRecipe("%s\nEither specify PLM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg) 21 raise bb.parse.SkipRecipe("%s\nEither specify PLM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg)
22 else:
23 # We found the file, so be sure to track it
24 d.setVar('SRC_URI', 'file://${PLM_FILE}.elf file://${PLM_FILE}.bin')
25 d.setVarFlag('do_install', 'file-checksums', '${PLM_FILE}.elf:True')
26 d.setVarFlag('do_deploy', 'file-checksums', '${PLM_FILE}.elf:True ${PLM_FILE}.bin:True')