summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend')
-rw-r--r--meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend b/meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend
new file mode 100644
index 00000000..d40f3cdb
--- /dev/null
+++ b/meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/fsbl-firmware_2024.2.bbappend
@@ -0,0 +1,66 @@
1# We WANT to default to this version when available
2DEFAULT_PREFERENCE = "100"
3
4# Reset this
5SRC_URI = "${EMBEDDEDSW_SRCURI}"
6
7inherit esw
8
9# Not compatible with Zynq
10COMPATIBLE_MACHINE:zynq = "none"
11COMPATIBLE_MACHINE:microblaze = "none"
12
13ESW_COMPONENT_SRC = "/lib/sw_apps/undefined/src"
14ESW_COMPONENT_SRC:zynq = "/lib/sw_apps/zynq_fsbl/src"
15ESW_COMPONENT_SRC:zynqmp = "/lib/sw_apps/zynqmp_fsbl/src"
16
17DEPENDS += "xilstandalone xiltimer xilffs xilsecure xilpm"
18
19python() {
20 psu_init_path = d.getVar('PSU_INIT_PATH')
21 if not psu_init_path:
22 psu_init_path = os.path.dirname(d.getVar('SYSTEM_DTFILE'))
23
24 psu_init_c = os.path.join(psu_init_path, 'psu_init.c')
25 psu_init_h = os.path.join(psu_init_path, 'psu_init.h')
26
27 add_path = False
28 if os.path.exists(psu_init_c):
29 d.appendVar('SRC_URI', ' file://psu_init.c')
30 add_path = True
31
32 if os.path.exists(psu_init_h):
33 d.appendVar('SRC_URI', ' file://psu_init.h')
34 add_path = True
35
36 if add_path:
37 d.prependVar('FILESEXTRAPATHS', '%s:' % psu_init_path)
38}
39
40do_configure:prepend() {
41 if [ -e ${WORKDIR}/psu_init.c ]; then
42 install -m 0644 ${WORKDIR}/psu_init.c ${S}/${ESW_COMPONENT_SRC}
43 else
44 bbwarn "Using the default psu_init.c, this may not work correctly."
45 fi
46
47 if [ -e ${WORKDIR}/psu_init.h ]; then
48 install -m 0644 ${WORKDIR}/psu_init.h ${S}/${ESW_COMPONENT_SRC}
49 else
50 bbwarn "Using the default psu_init.h, this may not work correctly."
51 fi
52 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
53}
54
55do_install() {
56 :
57}
58
59addtask deploy before do_build after do_package
60
61ESW_COMPONENT = "undefined"
62ESW_COMPONENT:zynq = "zynq_fsbl.elf"
63ESW_COMPONENT:zynqmp = "zynqmp_fsbl.elf"
64
65CFLAGS:append:aarch64 = " -DARMA53_64"
66CFLAGS:append:armv7r = " -DARMR5"