summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb b/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
index 0891fb86..1dcd8404 100644
--- a/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-drivers/dmaps_git.bb
@@ -1,3 +1,18 @@
1inherit esw_examples 1inherit features_check
2 2
3ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/dmaps/examples/" 3REQUIRED_MACHINE_FEATURES = "dmaps"
4
5inherit esw python3native
6
7DEPENDS += "xilstandalone "
8
9ESW_COMPONENT_SRC = "/XilinxProcessorIPLib/drivers/dmaps/src/"
10ESW_COMPONENT_NAME = "libdmaps.a"
11
12addtask do_generate_driver_data before do_configure after do_prepare_recipe_sysroot
13do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
14
15do_configure:prepend() {
16 LOPPER_DTC_FLAGS="-b 0 -@" lopper ${DTS_FILE} -- baremetal_xparameters_xlnx.py ${ESW_MACHINE} ${S}
17 install -m 0755 xparameters.h ${S}/${ESW_COMPONENT_SRC}/
18}