summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core')
-rw-r--r--meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend43
-rw-r--r--meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend11
2 files changed, 11 insertions, 43 deletions
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend
deleted file mode 100644
index 51c3f79e..00000000
--- a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper.bbappend
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "Device Tree Lopper"
2DESCRIPTION = "Tool for manipulation of system device tree files"
3LICENSE = "BSD-3-Clause"
4SECTION = "bootloader"
5
6FILESEXTRAPATHS:append := ":${THISDIR}/lopper"
7
8SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=v0.2022.x;protocol=https"
9SRCREV = "cdb1a7b55c375f5237683a512257e0fc573063a2"
10S = "${WORKDIR}/git"
11
12PV="v1.0.2+git${SRCPV}"
13
14LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619"
15
16RDEPENDS:${PN} = " \
17 python3-core \
18 python3-dtc \
19 python3-humanfriendly \
20 python3-ruamel-yaml \
21 python3-anytree \
22 python3-six \
23 python3-pyyaml \
24 "
25
26inherit setuptools3
27
28INHIBIT_PACKAGE_STRIP = "1"
29
30do_install() {
31 distutils3_do_install
32
33 # we have to remove the vendor'd libfdt, since an attempt to strip it
34 # will be made, and it will fail in a cross environment.
35 rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}/${BPN}/vendor
36}
37
38BBCLASSEXTEND = "native nativesdk"
39
40python() {
41 d.delVarFlag('do_configure', 'noexec')
42 d.delVarFlag('do_compile', 'noexec')
43}
diff --git a/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend
new file mode 100644
index 00000000..db4f4820
--- /dev/null
+++ b/meta-xilinx-core/dynamic-layers/virtualization-layer/recipes-kernel/lopper/lopper_git.bbappend
@@ -0,0 +1,11 @@
1SRC_URI = "git://github.com/devicetree-org/lopper.git;branch=v0.2022.x;protocol=https"
2SRCREV = "cdb1a7b55c375f5237683a512257e0fc573063a2"
3
4BASEVERSION = "1.1.0"
5
6RDEPENDS:${PN} += " \
7 python3-ruamel-yaml \
8 python3-anytree \
9 python3-six \
10 python3-pyyaml \
11 "