summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
new file mode 100644
index 00000000..6b98c6a9
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
@@ -0,0 +1,37 @@
1require qemu-system-native-alt.inc
2require qemu-xilinx-2022.1.inc
3require qemu-xilinx-native-7.1.inc
4
5PROVIDES = "qemu-system-native"
6
7# Latest poky has changed the defaults, restore them to something compatible
8# with this QEMU. When we update to QEMU 8.x this won't be necessary.
9EXTRA_OECONF:remove = "--disable-download"
10EXTRA_OECONF:remove = "--disable-docs"
11
12EXTRA_OECONF:append = "\
13 --with-git=/bin/false \
14 --with-git-submodules=ignore \
15 --meson=meson \
16"
17
18EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
19
20PACKAGECONFIG ??= "fdt alsa kvm gcrypt pie slirp"
21
22PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
23
24DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
25DEPENDS += "qemu-xilinx-multiarch-helper-native"
26
27do_install:append() {
28 # The following is also installed by qemu-native
29 rm -f ${D}${datadir}/qemu/trace-events-all
30 rm -rf ${D}${datadir}/qemu/keymaps
31 rm -rf ${D}${datadir}/icons
32 rm -rf ${D}${includedir}/qemu-plugin.h
33
34 # Install qmp.py to be used with testimage
35 install -d ${D}${libdir}/qemu-python/qmp/
36 install -D ${S}/python/qemu/qmp/* ${D}${libdir}/qemu-python/qmp/
37}