summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch')
-rw-r--r--meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch102
1 files changed, 59 insertions, 43 deletions
diff --git a/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
index 3bf75d32..75e0300b 100644
--- a/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
+++ b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
@@ -1,12 +1,24 @@
1Add microblaze syscalls to systemd 1From 2bd273c3a474b04b60c08c98fb7859fce28eac6d Mon Sep 17 00:00:00 2001
2From: Mark Hatle <mark.hatle@amd.com>
3Date: Fri, 22 Sep 2023 10:26:47 -0600
4Subject: [PATCH] syscalls-microblaze.txt: Add microblaze syscalls to systemd
2 5
3Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> 6Upstream-Status: Pending
4 7
5Index: git/src/basic/meson.build 8Signed-off-by: Mark Hatle <mark.hatle@amd.com>
6=================================================================== 9---
7--- git.orig/src/basic/meson.build 10 src/basic/meson.build | 1 +
8+++ git/src/basic/meson.build 11 src/basic/missing_syscall_def.h | 33 ++
9@@ -347,6 +347,7 @@ arch_list = [ 12 src/basic/missing_syscalls.py | 2 +
13 src/basic/syscalls-microblaze.txt | 598 ++++++++++++++++++++++++++++++
14 4 files changed, 634 insertions(+)
15 create mode 100644 src/basic/syscalls-microblaze.txt
16
17diff --git a/src/basic/meson.build b/src/basic/meson.build
18index 3af013b014..e77f7cef16 100644
19--- a/src/basic/meson.build
20+++ b/src/basic/meson.build
21@@ -190,6 +190,7 @@ arch_list = [
10 'ia64', 22 'ia64',
11 'loongarch64', 23 'loongarch64',
12 'm68k', 24 'm68k',
@@ -14,10 +26,10 @@ Index: git/src/basic/meson.build
14 'mips64', 26 'mips64',
15 'mips64n32', 27 'mips64n32',
16 'mipso32', 28 'mipso32',
17Index: git/src/basic/missing_syscall_def.h 29diff --git a/src/basic/missing_syscall_def.h b/src/basic/missing_syscall_def.h
18=================================================================== 30index 402fdd00dc..94f41c1522 100644
19--- git.orig/src/basic/missing_syscall_def.h 31--- a/src/basic/missing_syscall_def.h
20+++ git/src/basic/missing_syscall_def.h 32+++ b/src/basic/missing_syscall_def.h
21@@ -16,6 +16,7 @@ 33@@ -16,6 +16,7 @@
22 # elif defined(__ia64__) 34 # elif defined(__ia64__)
23 # elif defined(__loongarch64) 35 # elif defined(__loongarch64)
@@ -26,7 +38,7 @@ Index: git/src/basic/missing_syscall_def.h
26 # elif defined(_MIPS_SIM) 38 # elif defined(_MIPS_SIM)
27 # if _MIPS_SIM == _MIPS_SIM_ABI32 39 # if _MIPS_SIM == _MIPS_SIM_ABI32
28 # elif _MIPS_SIM == _MIPS_SIM_NABI32 40 # elif _MIPS_SIM == _MIPS_SIM_NABI32
29@@ -58,6 +59,8 @@ 41@@ -59,6 +60,8 @@
30 # define systemd_NR_bpf 280 42 # define systemd_NR_bpf 280
31 # elif defined(__m68k__) 43 # elif defined(__m68k__)
32 # define systemd_NR_bpf 354 44 # define systemd_NR_bpf 354
@@ -35,7 +47,7 @@ Index: git/src/basic/missing_syscall_def.h
35 # elif defined(_MIPS_SIM) 47 # elif defined(_MIPS_SIM)
36 # if _MIPS_SIM == _MIPS_SIM_ABI32 48 # if _MIPS_SIM == _MIPS_SIM_ABI32
37 # define systemd_NR_bpf 4355 49 # define systemd_NR_bpf 4355
38@@ -124,6 +127,8 @@ assert_cc(__NR_bpf == systemd_NR_bpf); 50@@ -127,6 +130,8 @@ assert_cc(__NR_bpf == systemd_NR_bpf);
39 # define systemd_NR_close_range 436 51 # define systemd_NR_close_range 436
40 # elif defined(__m68k__) 52 # elif defined(__m68k__)
41 # define systemd_NR_close_range 436 53 # define systemd_NR_close_range 436
@@ -44,7 +56,7 @@ Index: git/src/basic/missing_syscall_def.h
44 # elif defined(_MIPS_SIM) 56 # elif defined(_MIPS_SIM)
45 # if _MIPS_SIM == _MIPS_SIM_ABI32 57 # if _MIPS_SIM == _MIPS_SIM_ABI32
46 # define systemd_NR_close_range 4436 58 # define systemd_NR_close_range 4436
47@@ -190,6 +195,8 @@ assert_cc(__NR_close_range == systemd_NR 59@@ -195,6 +200,8 @@ assert_cc(__NR_close_range == systemd_NR_close_range);
48 # define systemd_NR_copy_file_range 285 60 # define systemd_NR_copy_file_range 285
49 # elif defined(__m68k__) 61 # elif defined(__m68k__)
50 # define systemd_NR_copy_file_range 376 62 # define systemd_NR_copy_file_range 376
@@ -53,16 +65,7 @@ Index: git/src/basic/missing_syscall_def.h
53 # elif defined(_MIPS_SIM) 65 # elif defined(_MIPS_SIM)
54 # if _MIPS_SIM == _MIPS_SIM_ABI32 66 # if _MIPS_SIM == _MIPS_SIM_ABI32
55 # define systemd_NR_copy_file_range 4360 67 # define systemd_NR_copy_file_range 4360
56@@ -256,6 +263,8 @@ assert_cc(__NR_copy_file_range == system 68@@ -263,6 +270,8 @@ assert_cc(__NR_copy_file_range == systemd_NR_copy_file_range);
57 # define systemd_NR_epoll_pwait2 441
58 # elif defined(__m68k__)
59 # define systemd_NR_epoll_pwait2 441
60+# elif defined(__microblaze__)
61+# define systemd_NR_epoll_pwait2 441
62 # elif defined(_MIPS_SIM)
63 # if _MIPS_SIM == _MIPS_SIM_ABI32
64 # define systemd_NR_epoll_pwait2 4441
65@@ -322,6 +331,8 @@ assert_cc(__NR_epoll_pwait2 == systemd_N
66 # define systemd_NR_getrandom 278 69 # define systemd_NR_getrandom 278
67 # elif defined(__m68k__) 70 # elif defined(__m68k__)
68 # define systemd_NR_getrandom 352 71 # define systemd_NR_getrandom 352
@@ -71,7 +74,7 @@ Index: git/src/basic/missing_syscall_def.h
71 # elif defined(_MIPS_SIM) 74 # elif defined(_MIPS_SIM)
72 # if _MIPS_SIM == _MIPS_SIM_ABI32 75 # if _MIPS_SIM == _MIPS_SIM_ABI32
73 # define systemd_NR_getrandom 4353 76 # define systemd_NR_getrandom 4353
74@@ -388,6 +399,8 @@ assert_cc(__NR_getrandom == systemd_NR_g 77@@ -331,6 +340,8 @@ assert_cc(__NR_getrandom == systemd_NR_getrandom);
75 # define systemd_NR_memfd_create 279 78 # define systemd_NR_memfd_create 279
76 # elif defined(__m68k__) 79 # elif defined(__m68k__)
77 # define systemd_NR_memfd_create 353 80 # define systemd_NR_memfd_create 353
@@ -80,7 +83,7 @@ Index: git/src/basic/missing_syscall_def.h
80 # elif defined(_MIPS_SIM) 83 # elif defined(_MIPS_SIM)
81 # if _MIPS_SIM == _MIPS_SIM_ABI32 84 # if _MIPS_SIM == _MIPS_SIM_ABI32
82 # define systemd_NR_memfd_create 4354 85 # define systemd_NR_memfd_create 4354
83@@ -454,6 +467,8 @@ assert_cc(__NR_memfd_create == systemd_N 86@@ -399,6 +410,8 @@ assert_cc(__NR_memfd_create == systemd_NR_memfd_create);
84 # define systemd_NR_mount_setattr 442 87 # define systemd_NR_mount_setattr 442
85 # elif defined(__m68k__) 88 # elif defined(__m68k__)
86 # define systemd_NR_mount_setattr 442 89 # define systemd_NR_mount_setattr 442
@@ -89,7 +92,7 @@ Index: git/src/basic/missing_syscall_def.h
89 # elif defined(_MIPS_SIM) 92 # elif defined(_MIPS_SIM)
90 # if _MIPS_SIM == _MIPS_SIM_ABI32 93 # if _MIPS_SIM == _MIPS_SIM_ABI32
91 # define systemd_NR_mount_setattr 4442 94 # define systemd_NR_mount_setattr 4442
92@@ -520,6 +535,8 @@ assert_cc(__NR_mount_setattr == systemd_ 95@@ -467,6 +480,8 @@ assert_cc(__NR_mount_setattr == systemd_NR_mount_setattr);
93 # define systemd_NR_move_mount 429 96 # define systemd_NR_move_mount 429
94 # elif defined(__m68k__) 97 # elif defined(__m68k__)
95 # define systemd_NR_move_mount 429 98 # define systemd_NR_move_mount 429
@@ -98,7 +101,7 @@ Index: git/src/basic/missing_syscall_def.h
98 # elif defined(_MIPS_SIM) 101 # elif defined(_MIPS_SIM)
99 # if _MIPS_SIM == _MIPS_SIM_ABI32 102 # if _MIPS_SIM == _MIPS_SIM_ABI32
100 # define systemd_NR_move_mount 4429 103 # define systemd_NR_move_mount 4429
101@@ -586,6 +603,8 @@ assert_cc(__NR_move_mount == systemd_NR_ 104@@ -535,6 +550,8 @@ assert_cc(__NR_move_mount == systemd_NR_move_mount);
102 # define systemd_NR_name_to_handle_at 264 105 # define systemd_NR_name_to_handle_at 264
103 # elif defined(__m68k__) 106 # elif defined(__m68k__)
104 # define systemd_NR_name_to_handle_at 340 107 # define systemd_NR_name_to_handle_at 340
@@ -107,7 +110,7 @@ Index: git/src/basic/missing_syscall_def.h
107 # elif defined(_MIPS_SIM) 110 # elif defined(_MIPS_SIM)
108 # if _MIPS_SIM == _MIPS_SIM_ABI32 111 # if _MIPS_SIM == _MIPS_SIM_ABI32
109 # define systemd_NR_name_to_handle_at 4339 112 # define systemd_NR_name_to_handle_at 4339
110@@ -652,6 +671,8 @@ assert_cc(__NR_name_to_handle_at == syst 113@@ -603,6 +620,8 @@ assert_cc(__NR_name_to_handle_at == systemd_NR_name_to_handle_at);
111 # define systemd_NR_open_tree 428 114 # define systemd_NR_open_tree 428
112 # elif defined(__m68k__) 115 # elif defined(__m68k__)
113 # define systemd_NR_open_tree 428 116 # define systemd_NR_open_tree 428
@@ -116,7 +119,16 @@ Index: git/src/basic/missing_syscall_def.h
116 # elif defined(_MIPS_SIM) 119 # elif defined(_MIPS_SIM)
117 # if _MIPS_SIM == _MIPS_SIM_ABI32 120 # if _MIPS_SIM == _MIPS_SIM_ABI32
118 # define systemd_NR_open_tree 4428 121 # define systemd_NR_open_tree 4428
119@@ -784,6 +805,8 @@ assert_cc(__NR_openat2 == systemd_NR_ope 122@@ -671,6 +690,8 @@ assert_cc(__NR_open_tree == systemd_NR_open_tree);
123 # define systemd_NR_openat2 437
124 # elif defined(__m68k__)
125 # define systemd_NR_openat2 437
126+# elif defined(__microblaze__)
127+# define systemd_NR_openat2 437
128 # elif defined(_MIPS_SIM)
129 # if _MIPS_SIM == _MIPS_SIM_ABI32
130 # define systemd_NR_openat2 4437
131@@ -739,6 +760,8 @@ assert_cc(__NR_openat2 == systemd_NR_openat2);
120 # define systemd_NR_pidfd_open 434 132 # define systemd_NR_pidfd_open 434
121 # elif defined(__m68k__) 133 # elif defined(__m68k__)
122 # define systemd_NR_pidfd_open 434 134 # define systemd_NR_pidfd_open 434
@@ -125,7 +137,7 @@ Index: git/src/basic/missing_syscall_def.h
125 # elif defined(_MIPS_SIM) 137 # elif defined(_MIPS_SIM)
126 # if _MIPS_SIM == _MIPS_SIM_ABI32 138 # if _MIPS_SIM == _MIPS_SIM_ABI32
127 # define systemd_NR_pidfd_open 4434 139 # define systemd_NR_pidfd_open 4434
128@@ -850,6 +873,8 @@ assert_cc(__NR_pidfd_open == systemd_NR_ 140@@ -807,6 +830,8 @@ assert_cc(__NR_pidfd_open == systemd_NR_pidfd_open);
129 # define systemd_NR_pidfd_send_signal 424 141 # define systemd_NR_pidfd_send_signal 424
130 # elif defined(__m68k__) 142 # elif defined(__m68k__)
131 # define systemd_NR_pidfd_send_signal 424 143 # define systemd_NR_pidfd_send_signal 424
@@ -134,7 +146,7 @@ Index: git/src/basic/missing_syscall_def.h
134 # elif defined(_MIPS_SIM) 146 # elif defined(_MIPS_SIM)
135 # if _MIPS_SIM == _MIPS_SIM_ABI32 147 # if _MIPS_SIM == _MIPS_SIM_ABI32
136 # define systemd_NR_pidfd_send_signal 4424 148 # define systemd_NR_pidfd_send_signal 4424
137@@ -916,6 +941,8 @@ assert_cc(__NR_pidfd_send_signal == syst 149@@ -875,6 +900,8 @@ assert_cc(__NR_pidfd_send_signal == systemd_NR_pidfd_send_signal);
138 # define systemd_NR_pkey_mprotect 288 150 # define systemd_NR_pkey_mprotect 288
139 # elif defined(__m68k__) 151 # elif defined(__m68k__)
140 # define systemd_NR_pkey_mprotect 381 152 # define systemd_NR_pkey_mprotect 381
@@ -143,7 +155,7 @@ Index: git/src/basic/missing_syscall_def.h
143 # elif defined(_MIPS_SIM) 155 # elif defined(_MIPS_SIM)
144 # if _MIPS_SIM == _MIPS_SIM_ABI32 156 # if _MIPS_SIM == _MIPS_SIM_ABI32
145 # define systemd_NR_pkey_mprotect 4363 157 # define systemd_NR_pkey_mprotect 4363
146@@ -982,6 +1009,8 @@ assert_cc(__NR_pkey_mprotect == systemd_ 158@@ -943,6 +970,8 @@ assert_cc(__NR_pkey_mprotect == systemd_NR_pkey_mprotect);
147 # define systemd_NR_renameat2 276 159 # define systemd_NR_renameat2 276
148 # elif defined(__m68k__) 160 # elif defined(__m68k__)
149 # define systemd_NR_renameat2 351 161 # define systemd_NR_renameat2 351
@@ -152,7 +164,7 @@ Index: git/src/basic/missing_syscall_def.h
152 # elif defined(_MIPS_SIM) 164 # elif defined(_MIPS_SIM)
153 # if _MIPS_SIM == _MIPS_SIM_ABI32 165 # if _MIPS_SIM == _MIPS_SIM_ABI32
154 # define systemd_NR_renameat2 4351 166 # define systemd_NR_renameat2 4351
155@@ -1048,6 +1077,8 @@ assert_cc(__NR_renameat2 == systemd_NR_r 167@@ -1011,6 +1040,8 @@ assert_cc(__NR_renameat2 == systemd_NR_renameat2);
156 # define systemd_NR_setns 268 168 # define systemd_NR_setns 268
157 # elif defined(__m68k__) 169 # elif defined(__m68k__)
158 # define systemd_NR_setns 344 170 # define systemd_NR_setns 344
@@ -161,7 +173,7 @@ Index: git/src/basic/missing_syscall_def.h
161 # elif defined(_MIPS_SIM) 173 # elif defined(_MIPS_SIM)
162 # if _MIPS_SIM == _MIPS_SIM_ABI32 174 # if _MIPS_SIM == _MIPS_SIM_ABI32
163 # define systemd_NR_setns 4344 175 # define systemd_NR_setns 4344
164@@ -1114,6 +1145,8 @@ assert_cc(__NR_setns == systemd_NR_setns 176@@ -1079,6 +1110,8 @@ assert_cc(__NR_setns == systemd_NR_setns);
165 # define systemd_NR_statx 291 177 # define systemd_NR_statx 291
166 # elif defined(__m68k__) 178 # elif defined(__m68k__)
167 # define systemd_NR_statx 379 179 # define systemd_NR_statx 379
@@ -170,11 +182,11 @@ Index: git/src/basic/missing_syscall_def.h
170 # elif defined(_MIPS_SIM) 182 # elif defined(_MIPS_SIM)
171 # if _MIPS_SIM == _MIPS_SIM_ABI32 183 # if _MIPS_SIM == _MIPS_SIM_ABI32
172 # define systemd_NR_statx 4366 184 # define systemd_NR_statx 4366
173Index: git/src/basic/missing_syscalls.py 185diff --git a/src/basic/missing_syscalls.py b/src/basic/missing_syscalls.py
174=================================================================== 186index 5ccf02adec..e09023abe1 100644
175--- git.orig/src/basic/missing_syscalls.py 187--- a/src/basic/missing_syscalls.py
176+++ git/src/basic/missing_syscalls.py 188+++ b/src/basic/missing_syscalls.py
177@@ -64,6 +64,8 @@ DEF_TEMPLATE_B = '''\ 189@@ -63,6 +63,8 @@ DEF_TEMPLATE_B = '''\
178 # define systemd_NR_{syscall} {nr_loongarch64} 190 # define systemd_NR_{syscall} {nr_loongarch64}
179 # elif defined(__m68k__) 191 # elif defined(__m68k__)
180 # define systemd_NR_{syscall} {nr_m68k} 192 # define systemd_NR_{syscall} {nr_m68k}
@@ -183,10 +195,11 @@ Index: git/src/basic/missing_syscalls.py
183 # elif defined(_MIPS_SIM) 195 # elif defined(_MIPS_SIM)
184 # if _MIPS_SIM == _MIPS_SIM_ABI32 196 # if _MIPS_SIM == _MIPS_SIM_ABI32
185 # define systemd_NR_{syscall} {nr_mipso32} 197 # define systemd_NR_{syscall} {nr_mipso32}
186Index: git/src/basic/syscalls-microblaze.txt 198diff --git a/src/basic/syscalls-microblaze.txt b/src/basic/syscalls-microblaze.txt
187=================================================================== 199new file mode 100644
200index 0000000000..3fc4cd6aef
188--- /dev/null 201--- /dev/null
189+++ git/src/basic/syscalls-microblaze.txt 202+++ b/src/basic/syscalls-microblaze.txt
190@@ -0,0 +1,598 @@ 203@@ -0,0 +1,598 @@
191+_llseek 140 204+_llseek 140
192+_newselect 142 205+_newselect 142
@@ -786,3 +799,6 @@ Index: git/src/basic/syscalls-microblaze.txt
786+waitpid 7 799+waitpid 7
787+write 4 800+write 4
788+writev 146 801+writev 146
802--
8032.34.1
804