summaryrefslogtreecommitdiffstats
path: root/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb')
-rw-r--r--meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb71
1 files changed, 0 insertions, 71 deletions
diff --git a/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb b/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb
deleted file mode 100644
index abce8d16..00000000
--- a/meta-dpdk/recipes-extended/dpdk/dpdk_22.11.0.bb
+++ /dev/null
@@ -1,71 +0,0 @@
1include dpdk.inc
2
3SRC_URI = "git://github.com/Xilinx-CNS/cns-dpdk-next-sfc.git;branch=${BRANCH};protocol=https"
4
5BRANCH = "cdx_22.11"
6SRCREV = "92339d519b50996915e7dbb5b8246b34febcba93"
7S = "${WORKDIR}/git"
8
9# kernel module is provide by dpdk-module recipe, so disable here
10EXTRA_OEMESON = " \
11 -Denable_kmods=false \
12 -Dexamples=cdma_demo,cdx_test \
13"
14
15COMPATIBLE_MACHINE = "null"
16COMPATIBLE_MACHINE:versal-net = "${MACHINE}"
17COMPATIBLE_HOST:libc-musl:class-target = "null"
18COMPATIBLE_HOST:linux-gnux32 = "null"
19
20PACKAGECONFIG ??= " "
21PACKAGECONFIG[afxdp] = ",,libbpf xdp-tools"
22PACKAGECONFIG[libvirt] = ",,libvirt"
23
24RDEPENDS:${PN} += "pciutils python3-core"
25RDEPENDS:${PN}-examples += "bash"
26DEPENDS = "numactl python3-pyelftools-native"
27
28inherit meson pkgconfig
29
30INSTALL_PATH = "${prefix}/share/dpdk"
31
32do_write_config:append(){
33 sed -i "/\[properties\]/a platform = \'cdx\'" ${WORKDIR}/meson.cross
34}
35
36do_install:append(){
37 # remove source files
38 rm -rf ${D}/${INSTALL_PATH}/examples/*
39
40 # Install examples
41 install -m 0755 -d ${D}/${INSTALL_PATH}/examples/
42 for dirname in ${B}/examples/dpdk-*
43 do
44 if [ ! -d ${dirname} ] && [ -x ${dirname} ]; then
45 install -m 0755 ${dirname} ${D}/${INSTALL_PATH}/examples/
46 fi
47 done
48
49}
50
51PACKAGES =+ "${PN}-examples ${PN}-tools"
52
53FILES:${PN} += " ${bindir}/dpdk-testpmd \
54 ${bindir}/dpdk-proc-info \
55 ${libdir}/*.so* \
56 ${libdir}/dpdk/pmds-22.0/*.so* \
57 "
58FILES:${PN}-examples = " \
59 ${INSTALL_PATH}/examples/* \
60 "
61
62FILES:${PN}-tools = " \
63 ${bindir}/dpdk-pdump \
64 ${bindir}/dpdk-test \
65 ${bindir}/dpdk-test-* \
66 ${bindir}/dpdk-*.py \
67 "
68
69CVE_PRODUCT = "data_plane_development_kit"
70
71INSANE_SKIP:${PN} = "dev-so"