summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb8
-rw-r--r--meta-xilinx-core/recipes-bsp/embeddedsw/fsbl.bb3
-rw-r--r--meta-xilinx-core/recipes-bsp/embeddedsw/plmfw.bb3
-rw-r--r--meta-xilinx-core/recipes-bsp/embeddedsw/pmufw.bb3
-rw-r--r--meta-xilinx-core/recipes-bsp/embeddedsw/psmfw.bb3
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl.bbappend15
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend15
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/pmufw.bbappend15
-rw-r--r--meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend16
9 files changed, 62 insertions, 19 deletions
diff --git a/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb b/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
index 9bc81c41..ddae03f5 100644
--- a/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
+++ b/meta-xilinx-core/recipes-bsp/device-tree/device-tree.bb
@@ -62,13 +62,15 @@ devicetree_do_deploy:append() {
62} 62}
63 63
64def check_devicetree_variables(d): 64def check_devicetree_variables(d):
65 # Don't cache this, as the items on disk can change!
66 d.setVar('BB_DONT_CACHE', '1')
67
65 if not d.getVar('CONFIG_DTFILE'): 68 if not d.getVar('CONFIG_DTFILE'):
66 d.setVar('BB_DONT_CACHE', '1')
67 raise bb.parse.SkipRecipe("CONFIG_DTFILE or SYSTEM_DTFILE is not defined.") 69 raise bb.parse.SkipRecipe("CONFIG_DTFILE or SYSTEM_DTFILE is not defined.")
68 else: 70 else:
69 if not os.path.exists(d.getVar('CONFIG_DTFILE')): 71 if not os.path.exists(d.getVar('CONFIG_DTFILE')):
70 d.setVar('BB_DONT_CACHE', '1') 72 if not d.getVar('WITHIN_EXT_SDK'):
71 raise bb.parse.SkipRecipe("The device tree %s is not available." % d.getVar('CONFIG_DTFILE')) 73 raise bb.parse.SkipRecipe("The device tree %s is not available." % d.getVar('CONFIG_DTFILE'))
72 else: 74 else:
73 d.appendVar('SRC_URI', ' file://${CONFIG_DTFILE}') 75 d.appendVar('SRC_URI', ' file://${CONFIG_DTFILE}')
74 d.setVarFlag('do_install', 'file-checksums', '${CONFIG_DTFILE}:True') 76 d.setVarFlag('do_install', 'file-checksums', '${CONFIG_DTFILE}:True')
diff --git a/meta-xilinx-core/recipes-bsp/embeddedsw/fsbl.bb b/meta-xilinx-core/recipes-bsp/embeddedsw/fsbl.bb
index f8679f0e..68cfeb22 100644
--- a/meta-xilinx-core/recipes-bsp/embeddedsw/fsbl.bb
+++ b/meta-xilinx-core/recipes-bsp/embeddedsw/fsbl.bb
@@ -66,7 +66,8 @@ def check_fsbl_variables(d):
66 d.setVar('BB_DONT_CACHE', '1') 66 d.setVar('BB_DONT_CACHE', '1')
67 67
68 if not os.path.exists(d.getVar('FSBL_FILE') + ".elf"): 68 if not os.path.exists(d.getVar('FSBL_FILE') + ".elf"):
69 raise bb.parse.SkipRecipe("The expect file %s.elf is not available.\nSet FSBL_FILE to the path with a precompiled FSBL binary. See the meta-xilinx-core README for more information." % d.getVar('FSBL_FILE')) 69 if not d.getVar('WITHIN_EXT_SDK'):
70 raise bb.parse.SkipRecipe("The expect file %s.elf is not available.\nSet FSBL_FILE to the path with a precompiled FSBL binary. See the meta-xilinx-core README for more information." % d.getVar('FSBL_FILE'))
70 else: 71 else:
71 # We found the file, so be sure to track it 72 # We found the file, so be sure to track it
72 d.setVar('SRC_URI', 'file://${FSBL_FILE}.elf') 73 d.setVar('SRC_URI', 'file://${FSBL_FILE}.elf')
diff --git a/meta-xilinx-core/recipes-bsp/embeddedsw/plmfw.bb b/meta-xilinx-core/recipes-bsp/embeddedsw/plmfw.bb
index 0306ef46..3ab694e6 100644
--- a/meta-xilinx-core/recipes-bsp/embeddedsw/plmfw.bb
+++ b/meta-xilinx-core/recipes-bsp/embeddedsw/plmfw.bb
@@ -75,7 +75,8 @@ def check_plm_vars(d):
75 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE') 75 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE')
76 fail = True 76 fail = True
77 if fail: 77 if fail:
78 raise bb.parse.SkipRecipe("%s\nSee the meta-xilinx-core README." % msg) 78 if not d.getVar('WITHIN_EXT_SDK'):
79 raise bb.parse.SkipRecipe("%s\nSee the meta-xilinx-core README." % msg)
79 else: 80 else:
80 # We found the file, so be sure to track it 81 # We found the file, so be sure to track it
81 d.setVar('SRC_URI', 'file://${PLM_FILE}.elf file://${PLM_FILE}.bin') 82 d.setVar('SRC_URI', 'file://${PLM_FILE}.elf file://${PLM_FILE}.bin')
diff --git a/meta-xilinx-core/recipes-bsp/embeddedsw/pmufw.bb b/meta-xilinx-core/recipes-bsp/embeddedsw/pmufw.bb
index b3f9664e..80eade19 100644
--- a/meta-xilinx-core/recipes-bsp/embeddedsw/pmufw.bb
+++ b/meta-xilinx-core/recipes-bsp/embeddedsw/pmufw.bb
@@ -73,7 +73,8 @@ def check_pmu_vars(d):
73 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PMU_FILE') 73 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PMU_FILE')
74 fail = True 74 fail = True
75 if fail: 75 if fail:
76 raise bb.parse.SkipRecipe("%s See the meta-xilinx-core README." % msg) 76 if not d.getVar('WITHIN_EXT_SDK'):
77 raise bb.parse.SkipRecipe("%s See the meta-xilinx-core README." % msg)
77 else: 78 else:
78 # We found the file, so be sure to track it 79 # We found the file, so be sure to track it
79 d.setVar('SRC_URI', 'file://${PMU_FILE}.elf file://${PMU_FILE}.bin') 80 d.setVar('SRC_URI', 'file://${PMU_FILE}.elf file://${PMU_FILE}.bin')
diff --git a/meta-xilinx-core/recipes-bsp/embeddedsw/psmfw.bb b/meta-xilinx-core/recipes-bsp/embeddedsw/psmfw.bb
index 46124591..5a7695de 100644
--- a/meta-xilinx-core/recipes-bsp/embeddedsw/psmfw.bb
+++ b/meta-xilinx-core/recipes-bsp/embeddedsw/psmfw.bb
@@ -76,7 +76,8 @@ def check_psm_vars(d):
76 fail = True 76 fail = True
77 77
78 if fail: 78 if fail:
79 raise bb.parse.SkipRecipe("%s\nSee the meta-xilinx-core README." % msg) 79 if not d.getVar('WITHIN_EXT_SDK'):
80 raise bb.parse.SkipRecipe("%s\nSee the meta-xilinx-core README." % msg)
80 else: 81 else:
81 # We found the file, so be sure to track it 82 # We found the file, so be sure to track it
82 d.setVar('SRC_URI', 'file://${PSM_FILE}.elf file://${PSM_FILE}.bin') 83 d.setVar('SRC_URI', 'file://${PSM_FILE}.elf file://${PSM_FILE}.bin')
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl.bbappend
index 5b02e3de..4507a0c7 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl.bbappend
@@ -3,7 +3,16 @@ FSBL_INC = "${@bb.utils.contains('BBMULTICONFIG', 'fsbl-fw', 'fsbl-fw-cfg.inc',
3require ${FSBL_INC} 3require ${FSBL_INC}
4 4
5def check_fsbl_variables(d): 5def check_fsbl_variables(d):
6 if not d.getVar('FSBL_DEPENDS') and not d.getVar('FSBL_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'fsbl-fw' in d.getVar('BBMULTICONFIG').split()): 6 # If both are blank, the user MUST pass in the path to the firmware!
7 if not d.getVar('FSBL_DEPENDS') and not d.getVar('FSBL_MCDEPENDS'):
8 # Don't cache this, as the items on disk can change!
9 d.setVar('BB_DONT_CACHE', '1')
10
7 if not os.path.exists(d.getVar('FSBL_FILE') + ".elf"): 11 if not os.path.exists(d.getVar('FSBL_FILE') + ".elf"):
8 d.setVar('BB_DONT_CACHE', '1') 12 if not d.getVar('WITHIN_EXT_SDK'):
9 raise bb.parse.SkipRecipe("The expect file %s.elf is not available.\nEither specify FSBL_FILE, or you may need to enable BBMULTICONFIG += 'fsbl-fw' to generate it." % d.getVar('FSBL_FILE')) 13 raise bb.parse.SkipRecipe("The expect file %s.elf is not available.\nSet FSBL_FILE to the path with a precompiled FSBL binary or you may need to enable BBMULTICONFIG += 'fsbl-fw' to generate it." % d.getVar('FSBL_FILE'))
14 else:
15 # We found the file, so be sure to track it
16 d.setVar('SRC_URI', 'file://${FSBL_FILE}.elf')
17 d.setVarFlag('do_install', 'file-checksums', '${FSBL_FILE}.elf:True')
18 d.setVarFlag('do_deploy', 'file-checksums', '${FSBL_FILE}.elf:True')
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
index d63529ff..49c897e1 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/plmfw.bbappend
@@ -3,7 +3,11 @@ PLMFW_INC = "${@bb.utils.contains('BBMULTICONFIG', 'versal-fw', 'versal-fw-cfg.i
3require ${PLMFW_INC} 3require ${PLMFW_INC}
4 4
5def check_plm_vars(d): 5def check_plm_vars(d):
6 if not d.getVar('PLM_DEPENDS') and not d.getVar('PLM_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'versal-fw' in d.getVar('BBMULTICONFIG').split()): 6 # If both are blank, the user MUST pass in the path to the firmware!
7 if not d.getVar('PLM_DEPENDS') and not d.getVar('PLM_MCDEPENDS'):
8 # Don't cache this, as the items on disk can change!
9 d.setVar('BB_DONT_CACHE', '1')
10
7 msg = "" 11 msg = ""
8 fail = False 12 fail = False
9 if not os.path.exists(d.getVar('PLM_FILE') + ".elf"): 13 if not os.path.exists(d.getVar('PLM_FILE') + ".elf"):
@@ -13,5 +17,10 @@ def check_plm_vars(d):
13 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE') 17 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PLM_FILE')
14 fail = True 18 fail = True
15 if fail: 19 if fail:
16 d.setVar('BB_DONT_CACHE', '1') 20 if not d.getVar('WITHIN_EXT_SDK'):
17 raise bb.parse.SkipRecipe("%s\nEither specify PLM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg) 21 raise bb.parse.SkipRecipe("%s\nEither specify PLM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg)
22 else:
23 # We found the file, so be sure to track it
24 d.setVar('SRC_URI', 'file://${PLM_FILE}.elf file://${PLM_FILE}.bin')
25 d.setVarFlag('do_install', 'file-checksums', '${PLM_FILE}.elf:True')
26 d.setVarFlag('do_deploy', 'file-checksums', '${PLM_FILE}.elf:True ${PLM_FILE}.bin:True')
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmufw.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmufw.bbappend
index 947408a1..663134c4 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmufw.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/pmufw.bbappend
@@ -3,7 +3,11 @@ PMUFW_INC = "${@bb.utils.contains('BBMULTICONFIG', 'zynqmp-pmufw', 'zynqmp-pmufw
3require ${PMUFW_INC} 3require ${PMUFW_INC}
4 4
5def check_pmu_vars(d): 5def check_pmu_vars(d):
6 if not d.getVar('PMU_DEPENDS') and not d.getVar('PMU_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'zynqmp-pmufw' in d.getVar('BBMULTICONFIG').split()): 6 # If both are blank, the user MUST pass in the path to the firmware!
7 if not d.getVar('PMU_FIRMWARE_DEPENDS') and not d.getVar('PMU_FIRMWARE_MCDEPENDS'):
8 # Don't cache this, as the items on disk can change!
9 d.setVar('BB_DONT_CACHE', '1')
10
7 msg = "" 11 msg = ""
8 fail = False 12 fail = False
9 if not os.path.exists(d.getVar('PMU_FILE') + ".elf"): 13 if not os.path.exists(d.getVar('PMU_FILE') + ".elf"):
@@ -13,5 +17,10 @@ def check_pmu_vars(d):
13 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PMU_FILE') 17 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PMU_FILE')
14 fail = True 18 fail = True
15 if fail: 19 if fail:
16 d.setVar('BB_DONT_CACHE', '1') 20 if not d.getVar('WITHIN_EXT_SDK'):
17 raise bb.parse.SkipRecipe("%s\nEither specify PMU_FILE, or you may need to enable BBMULTICONFIG += 'zynqmp-pmufw' to generate it." % msg) 21 raise bb.parse.SkipRecipe("%s\nEither specify PMU_FILE, or you may need to enable BBMULTICONFIG += 'zynqmp-pmufw' to generate it." % msg)
22 else:
23 # We found the file, so be sure to track it
24 d.setVar('SRC_URI', 'file://${PMU_FILE}.elf file://${PMU_FILE}.bin')
25 d.setVarFlag('do_install', 'file-checksums', '${PMU_FILE}.elf:True')
26 d.setVarFlag('do_deploy', 'file-checksums', '${PMU_FILE}.elf:True ${PMU_FILE}.bin:True')
diff --git a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend
index 8944152d..dc7c6df6 100644
--- a/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend
+++ b/meta-xilinx-standalone/recipes-bsp/embeddedsw/psmfw.bbappend
@@ -3,7 +3,11 @@ PSMFW_INC = "${@bb.utils.contains('BBMULTICONFIG', 'versal-fw', 'versal-fw-cfg.i
3require ${PSMFW_INC} 3require ${PSMFW_INC}
4 4
5def check_psm_vars(d): 5def check_psm_vars(d):
6 if not d.getVar('PSM_DEPENDS') and not d.getVar('PSM_MCDEPENDS') and not (d.getVar('BBMULTICONFIG') and 'versal-fw' in d.getVar('BBMULTICONFIG').split()): 6 # If both are blank, the user MUST pass in the path to the firmware!
7 if not d.getVar('PSM_DEPENDS') and not d.getVar('PSM_MCDEPENDS'):
8 # Don't cache this, as the items on disk can change!
9 d.setVar('BB_DONT_CACHE', '1')
10
7 msg = "" 11 msg = ""
8 fail = False 12 fail = False
9 if not os.path.exists(d.getVar('PSM_FILE') + ".elf"): 13 if not os.path.exists(d.getVar('PSM_FILE') + ".elf"):
@@ -12,6 +16,12 @@ def check_psm_vars(d):
12 if not os.path.exists(d.getVar('PSM_FILE') + ".bin"): 16 if not os.path.exists(d.getVar('PSM_FILE') + ".bin"):
13 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PSM_FILE') 17 msg = msg + "The expected file %s.bin is not available. " % d.getVar('PSM_FILE')
14 fail = True 18 fail = True
19
15 if fail: 20 if fail:
16 d.setVar('BB_DONT_CACHE', '1') 21 if not d.getVar('WITHIN_EXT_SDK'):
17 raise bb.parse.SkipRecipe("%s\nEither specify PSM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg) 22 raise bb.parse.SkipRecipe("%s\nEither specify PSM_FILE, or you may need to enable BBMULTICONFIG += 'versal-fw' to generate it." % msg)
23 else:
24 # We found the file, so be sure to track it
25 d.setVar('SRC_URI', 'file://${PSM_FILE}.elf file://${PSM_FILE}.bin')
26 d.setVarFlag('do_install', 'file-checksums', '${PSM_FILE}.elf:True')
27 d.setVarFlag('do_deploy', 'file-checksums', '${PSM_FILE}.elf:True ${PSM_FILE}.bin:True')