summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees_2.2.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-devicetrees_2.2.5.bb b/recipes-devtools/qemu/qemu-devicetrees_2.2.5.bb
new file mode 100644
index 00000000..b4c914ba
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-devicetrees_2.2.5.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Xilinx's hardware device trees required for QEMU"
2HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
3LICENSE = "BSD"
4DEPENDS += "dtc-native"
5
6inherit deploy
7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9
10SRCREV = "46faf58cd14cdfd06cae7c076cb486af8565ab6a"
11SRC_URI = "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https;nobranch=1"
12
13S = "${WORKDIR}/git"
14
15# Don't need to do anything
16do_install() {
17 :
18}
19
20do_deploy() {
21 for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
22 if [ ! -f ${DTS_FILE} ]; then
23 bbwarn "${DTS_FILE} is not available!"
24 continue
25 fi
26 DTS_NAME=`basename -s .dtb ${DTS_FILE}`
27 install -d ${DEPLOYDIR}
28 install -d ${DEPLOYDIR}/qemu-hw-devicetrees
29 install -m 0644 ${S}/LATEST/SINGLE_ARCH/${DTS_NAME}.dtb ${DEPLOYDIR}/qemu-hw-devicetrees/${DTS_NAME}.dtb
30 done
31}
32
33addtask deploy after do_install