summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/images/core-image-tiny.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/images/core-image-tiny.bb b/recipes-core/images/core-image-tiny.bb
new file mode 100644
index 00000000..ed0994ed
--- /dev/null
+++ b/recipes-core/images/core-image-tiny.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "A tiny image just capable of allowing a device to boot."
2
3IMAGE_INSTALL = "base-files \
4 base-passwd \
5 busybox \
6 busybox-mdev \
7 initscripts \
8 modutils-initscripts \
9 netbase \
10 tinylogin \
11 sysvinit \
12 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
13 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
14 ${CORE_IMAGE_EXTRA_INSTALL}"
15
16IMAGE_LINGUAS = " "
17
18LICENSE = "MIT"
19
20inherit core-image
21
22IMAGE_ROOTFS_SIZE = "8192"
23
24# remove not needed ipkg informations
25ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "