diff options
author | Nathan Rossi <nathan.rossi@xilinx.com> | 2013-09-17 18:32:25 +1000 |
---|---|---|
committer | Nathan Rossi <nathan.rossi@xilinx.com> | 2013-09-17 18:32:25 +1000 |
commit | a16dfa56e5b9d17efb3f1ec1e26145eadc5c809c (patch) | |
tree | d52835c538db7dc0ec9e15bb37bdfd937ff92306 /recipes-kernel | |
parent | 02a46d1a252cda6fb3ba990f2260d6438b6a7921 (diff) | |
download | meta-xilinx-a16dfa56e5b9d17efb3f1ec1e26145eadc5c809c.tar.gz |
linux-xlnx.inc: Remove use of "linux-yocto"
* Remove the dependence on the linux-yocto.inc and linux-yocto classes.
* This change is made to make linux-xlnx less dependent on features that
are provided by the linux-yocto recipes, and in turn make the
linux-xlnx recipe more portable.
* Fix-up the individual .bb files where required.
Signed-off-by: Nathan Rossi <nathan.rossi@xilinx.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-xlnx-dev.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-xlnx.inc | 42 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-xlnx_3.8.bb | 5 |
3 files changed, 41 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-xlnx-dev.bb b/recipes-kernel/linux/linux-xlnx-dev.bb index d27f506e..95e8af68 100644 --- a/recipes-kernel/linux/linux-xlnx-dev.bb +++ b/recipes-kernel/linux/linux-xlnx-dev.bb | |||
@@ -25,7 +25,7 @@ KBRANCH_DEFAULT = "master" | |||
25 | 25 | ||
26 | include linux-xlnx.inc | 26 | include linux-xlnx.inc |
27 | 27 | ||
28 | SRC_URI = "git://github.com/Xilinx/linux-xlnx.git;protocol=git;nocheckout=1;branch=${KBRANCH}" | 28 | SRC_URI = "git://github.com/Xilinx/linux-xlnx.git;protocol=git;branch=${KBRANCH}" |
29 | 29 | ||
30 | # Set default SRCREVs. SRCREVs statically set to prevent network access during | 30 | # Set default SRCREVs. SRCREVs statically set to prevent network access during |
31 | # parsing. If linux-xlnx-dev is the preferred provider, they will be overridden | 31 | # parsing. If linux-xlnx-dev is the preferred provider, they will be overridden |
diff --git a/recipes-kernel/linux/linux-xlnx.inc b/recipes-kernel/linux/linux-xlnx.inc index e405b379..7d2952c6 100644 --- a/recipes-kernel/linux/linux-xlnx.inc +++ b/recipes-kernel/linux/linux-xlnx.inc | |||
@@ -1,16 +1,24 @@ | |||
1 | inherit kernel | 1 | DESCRIPTION = "Xilinx Kernel" |
2 | SECTION = "kernel" | ||
3 | LICENSE = "GPLv2" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
2 | 6 | ||
3 | # This version extension should match CONFIG_LOCALVERSION in defconfig | 7 | # This version extension should match CONFIG_LOCALVERSION in defconfig |
4 | LINUX_VERSION_EXTENSION ?= "-xilinx" | 8 | LINUX_VERSION_EXTENSION ?= "-xilinx" |
9 | PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCREV}" | ||
5 | 10 | ||
6 | require recipes-kernel/linux/linux-yocto.inc | 11 | # Sources |
7 | require linux-machine-common.inc | 12 | SRC_URI = "git://github.com/Xilinx/linux-xlnx;protocol=git" |
8 | |||
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" | 13 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
10 | FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:" | 14 | FILESEXTRAPATHS_prepend := "${THISDIR}/linux-xlnx:" |
11 | SRC_URI = "git://github.com/Xilinx/linux-xlnx;protocol=git;nocheckout=1" | ||
12 | 15 | ||
13 | PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCREV}" | 16 | # Source Directory |
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | # Inherit/include base functionality | ||
20 | inherit kernel | ||
21 | require linux-machine-common.inc | ||
14 | 22 | ||
15 | # Override COMPATIBLE_MACHINE to include your machine in a bbappend file. | 23 | # Override COMPATIBLE_MACHINE to include your machine in a bbappend file. |
16 | COMPATIBLE_MACHINE = "qemumicroblaze|qemuzynq|microblaze|zynq" | 24 | COMPATIBLE_MACHINE = "qemumicroblaze|qemuzynq|microblaze|zynq" |
@@ -22,3 +30,25 @@ MACHINE_KCONFIG_append_microblaze += "common/microblaze_defconfig_${LINUX_VERSIO | |||
22 | 30 | ||
23 | # Add the modules directory to the 'kernel-base' files list | 31 | # Add the modules directory to the 'kernel-base' files list |
24 | FILES_kernel-base_append = " /lib/modules/${KERNEL_VERSION}/kernel" | 32 | FILES_kernel-base_append = " /lib/modules/${KERNEL_VERSION}/kernel" |
33 | |||
34 | # returns all the elements from the src uri that are .cfg files | ||
35 | def find_config_fragments(d): | ||
36 | sources=src_patches(d, True) | ||
37 | sources_list=[] | ||
38 | for s in sources: | ||
39 | if s.endswith('.cfg'): | ||
40 | sources_list.append(s) | ||
41 | return sources_list | ||
42 | |||
43 | kernel_do_configure_prepend() { | ||
44 | # Find all ".cfg" files and cat them together into a .config | ||
45 | CFG_FILES="${@" ".join(find_config_fragments(d))}" | ||
46 | if [ ! -z "$CFG_FILES" ]; then | ||
47 | echo "# Generated by linux-xlnx recipe in meta-xilinx" > "${B}/.config" | ||
48 | for i in $CFG_FILES; do | ||
49 | echo "Joining configuration file $i" | ||
50 | echo "# $i" >> "${B}/.config" | ||
51 | cat $i >> "${B}/.config" | ||
52 | done | ||
53 | fi | ||
54 | } | ||
diff --git a/recipes-kernel/linux/linux-xlnx_3.8.bb b/recipes-kernel/linux/linux-xlnx_3.8.bb index ce54dc9b..24cf7d4e 100644 --- a/recipes-kernel/linux/linux-xlnx_3.8.bb +++ b/recipes-kernel/linux/linux-xlnx_3.8.bb | |||
@@ -9,5 +9,8 @@ SRCREV = "6a0bedad60e2bca8d9b50bf81b9895e29e31a6d7" | |||
9 | 9 | ||
10 | # MicroBlaze patches | 10 | # MicroBlaze patches |
11 | SRC_URI_append_microblaze = " \ | 11 | SRC_URI_append_microblaze = " \ |
12 | file://microblaze-patches_v3.8.scc \ | 12 | file://microblaze_Do_not_use_r6_in_head.S.patch \ |
13 | file://microblaze_Fix_free_init_pages_function.patch \ | ||
14 | file://microblaze_Fix_initrd_support.patch \ | ||
15 | file://arch_microblaze_Add_linux.bin.ub_target.patch \ | ||
13 | " | 16 | " |