summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental
diff options
context:
space:
mode:
authorAppana Durga Kedareswara rao <appana.durga.rao@xilinx.com>2021-07-09 10:09:03 +0530
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:36:42 -0700
commit4a0fea880554aaf188fc5944e2fc8922f766e810 (patch)
tree9c70b59e0fe910b59b836693baa31d1d118d3085 /meta-xilinx-standalone-experimental
parentc448a2f3c614e76801353a3ba542315b508ab7b5 (diff)
downloadmeta-xilinx-4a0fea880554aaf188fc5944e2fc8922f766e810.tar.gz
meta-xilinx-standalone-experimental: recipes-applications: peripheral-tests: Update deploy task to sync with other application recipe
Update the peripheral test deploy taks to sync with other esw application recipes. Signed-off-by: Appana Durga Kedareswara rao <appana.durga.rao@xilinx.com> Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-applications/peripheral-tests/peripheral-tests_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-applications/peripheral-tests/peripheral-tests_git.bb b/meta-xilinx-standalone-experimental/recipes-applications/peripheral-tests/peripheral-tests_git.bb
index 22bf3d64..49c12693 100644
--- a/meta-xilinx-standalone-experimental/recipes-applications/peripheral-tests/peripheral-tests_git.bb
+++ b/meta-xilinx-standalone-experimental/recipes-applications/peripheral-tests/peripheral-tests_git.bb
@@ -38,7 +38,7 @@ python do_generate_app_data() {
38addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot 38addtask do_generate_app_data before do_configure after do_prepare_recipe_sysroot
39do_prepare_recipe_sysroot[rdeptask] = "do_unpack" 39do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
40 40
41PERIPHERAL_TEST_APP_IMAGE_NAME ??= "peripheral-tests" 41PERIPHERAL_TEST_APP_IMAGE_NAME ??= "${BPN}"
42 42
43inherit image-artifact-names 43inherit image-artifact-names
44 44
@@ -56,8 +56,8 @@ do_install() {
56 56
57do_deploy() { 57do_deploy() {
58 install -Dm 0644 ${B}/${ESW_COMPONENT} ${DEPLOYDIR}/${PERIPHERAL_TEST_BASE_NAME}.elf 58 install -Dm 0644 ${B}/${ESW_COMPONENT} ${DEPLOYDIR}/${PERIPHERAL_TEST_BASE_NAME}.elf
59 ln -sf ${PERIPHERAL_TEST_BASE_NAME}.elf ${DEPLOYDIR}/${PERIPHERAL_TEST_APP_IMAGE_NAME}.elf 59 ln -sf ${PERIPHERAL_TEST_BASE_NAME}.elf ${DEPLOYDIR}/${BPN}-${MACHINE}.elf
60 install -m 0644 ${B}/executable.bin ${DEPLOYDIR}/${PERIPHERAL_TEST_BASE_NAME}.bin 60 install -m 0644 ${B}/executable.bin ${DEPLOYDIR}/${PERIPHERAL_TEST_BASE_NAME}.bin
61 ln -sf ${PERIPHERAL_TEST_BASE_NAME}.bin ${DEPLOYDIR}/${PERIPHERAL_TEST_APP_IMAGE_NAME}.bin 61 ln -sf ${PERIPHERAL_TEST_BASE_NAME}.bin ${DEPLOYDIR}/${BPN}-${MACHINE}.bin
62} 62}
63addtask deploy before do_build after do_install 63addtask deploy before do_build after do_install