summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-06-07 18:10:15 -0700
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2021-09-27 21:34:01 -0700
commit0680a8adbdec9a88b374d93f11371831bee33d31 (patch)
treea83094f1c8fe13a4b00a54b75e161ab99ea7abdd /meta-xilinx-standalone-experimental
parent49150ef028dbf0d459d887ce78d4f1d7d350946c (diff)
downloadmeta-xilinx-0680a8adbdec9a88b374d93f11371831bee33d31.tar.gz
psm/pmu/plm-firmware: Fix .bin generation
The .bin name should follow the same format as the regular component name. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-xilinx-standalone-experimental')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
index 75a77d37..b7bea591 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
@@ -11,7 +11,7 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/versal_plm/src/"
11ESW_COMPONENT = "versal_plm.elf" 11ESW_COMPONENT = "versal_plm.elf"
12 12
13do_compile_append() { 13do_compile_append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/plm.bin 14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 15}
16 16
17do_install() { 17do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
index 7f23f6ce..2016cc5c 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
@@ -11,7 +11,7 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/zynqmp_pmufw/src"
11ESW_COMPONENT = "pmufw.elf" 11ESW_COMPONENT = "pmufw.elf"
12 12
13do_compile_append() { 13do_compile_append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/executable.bin 14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 15}
16 16
17do_install() { 17do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
index a34a49e8..b4382477 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
@@ -11,7 +11,7 @@ ESW_COMPONENT_SRC = "/lib/sw_apps/versal_psmfw/src/"
11ESW_COMPONENT = "versal_psmfw.elf" 11ESW_COMPONENT = "versal_psmfw.elf"
12 12
13do_compile_append() { 13do_compile_append() {
14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/psmfw.bin 14 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
15} 15}
16 16
17do_install() { 17do_install() {