summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-xrt/xrt
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@amd.com>2023-02-21 17:10:30 -0800
committerMark Hatle <mark.hatle@amd.com>2023-02-22 07:35:15 -0600
commit0e471db25311caf15b412e68eed4087eb7c664d3 (patch)
tree31701e2bc75d85ac01fda7addca8437c3598833c /meta-xilinx-core/recipes-xrt/xrt
parent6ad9836940fa9c3541b5339c84d6d86e36734e24 (diff)
downloadmeta-xilinx-0e471db25311caf15b412e68eed4087eb7c664d3.tar.gz
xrt: Move AIE settings to meta-xilinx-tools
AIE components are only provided by meta-xilinx-tools layer, so the configuration and dependencies need to be in the same layer. Signed-off-by: Mark Hatle <mark.hatle@amd.com>
Diffstat (limited to 'meta-xilinx-core/recipes-xrt/xrt')
-rw-r--r--meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb14
1 files changed, 0 insertions, 14 deletions
diff --git a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
index 429a1631..39a9d9a3 100644
--- a/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
+++ b/meta-xilinx-core/recipes-xrt/xrt/xrt_git.bb
@@ -29,20 +29,6 @@ EXTRA_OECMAKE += " \
29 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \ 29 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
30 " 30 "
31 31
32# For vck190 kind of devices
33PACKAGE_ARCH:versal-ai-core = "${SOC_VARIANT_ARCH}"
34EXTRA_OECMAKE:append:versal-ai-core = " -DXRT_AIE_BUILD=true"
35TARGET_CXXFLAGS:append:versal-ai-core = " -DXRT_ENABLE_AIE"
36DEPENDS:append:versal-ai-core = " libmetal libxaiengine aiefal"
37RDEPENDS:${PN}:append:versal-ai-core = " libxaiengine aiefal"
38
39# For vek280 kind of devices
40PACKAGE_ARCH:versal-ai-edge = "${SOC_VARIANT_ARCH}"
41EXTRA_OECMAKE:append:versal-ai-edge = " -DXRT_AIE_BUILD=true"
42TARGET_CXXFLAGS:append:versal-ai-edge = " -DXRT_ENABLE_AIE"
43DEPENDS:append:versal-ai-edge = " libmetal libxaiengine aiefal"
44RDEPENDS:${PN}:append:versal-ai-edge = " libxaiengine aiefal"
45
46EXTRA_OECMAKE:append:versal = " -DXRT_LIBDFX=true" 32EXTRA_OECMAKE:append:versal = " -DXRT_LIBDFX=true"
47EXTRA_OECMAKE:append:zynqmp = " -DXRT_LIBDFX=true" 33EXTRA_OECMAKE:append:zynqmp = " -DXRT_LIBDFX=true"
48DEPENDS:append:versal = " libdfx" 34DEPENDS:append:versal = " libdfx"