summaryrefslogtreecommitdiffstats
path: root/meta-microblaze/recipes-core
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@xilinx.com>2021-12-02 04:44:18 -0800
committerMark Hatle <mark.hatle@xilinx.com>2022-01-14 11:21:55 -0800
commit7d42747340f4c1037df03fd1d21b36ae5459cd56 (patch)
tree3560f451cd149ef804b7ce49777c7de7c1cb4b42 /meta-microblaze/recipes-core
parentfdeec55408c77b06c725f8828da0de7be7503830 (diff)
downloadmeta-xilinx-7d42747340f4c1037df03fd1d21b36ae5459cd56.tar.gz
microblaze systemd: Add additional missing architecture support
Rename a mispelled patch name Add a patch that defines the microblaze syscalls. Disable stack-protection, as it is not supported on Microblaze at this time. Add a patch to resolve an undefined gcc internal, that is not enabled on microblaze. Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
Diffstat (limited to 'meta-microblaze/recipes-core')
-rw-r--r--meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Microblaze-architecture-to-systemd-.patch (renamed from meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Micorblaze-architecture-to-systemd-.patch)0
-rw-r--r--meta-microblaze/recipes-core/systemd/files/microblaze-disable-stack-protector.patch28
-rw-r--r--meta-microblaze/recipes-core/systemd/files/microblaze-once-macro.patch44
-rw-r--r--meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch789
-rw-r--r--meta-microblaze/recipes-core/systemd/systemd_%.bbappend5
5 files changed, 865 insertions, 1 deletions
diff --git a/meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Micorblaze-architecture-to-systemd-.patch b/meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Microblaze-architecture-to-systemd-.patch
index 8b4f6dc8..8b4f6dc8 100644
--- a/meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Micorblaze-architecture-to-systemd-.patch
+++ b/meta-microblaze/recipes-core/systemd/files/0001-architecture-Add-Microblaze-architecture-to-systemd-.patch
diff --git a/meta-microblaze/recipes-core/systemd/files/microblaze-disable-stack-protector.patch b/meta-microblaze/recipes-core/systemd/files/microblaze-disable-stack-protector.patch
new file mode 100644
index 00000000..535f864a
--- /dev/null
+++ b/meta-microblaze/recipes-core/systemd/files/microblaze-disable-stack-protector.patch
@@ -0,0 +1,28 @@
1Microblaze does not support stack-protector:
2
3| cc1: warning: '-fstack-protector' not supported for this target
4| ninja: build stopped: subcommand failed.
5
6Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
7
8diff --git a/meson.build b/meson.build
9index 738879eb21..06ea3e389a 100644
10--- a/meson.build
11+++ b/meson.build
12@@ -371,7 +371,6 @@ endif
13 possible_link_flags = [
14 '-Wl,-z,relro',
15 '-Wl,-z,now',
16- '-fstack-protector',
17 ]
18
19 if cc.get_id() == 'clang'
20@@ -388,8 +387,6 @@ possible_cc_flags = possible_common_cc_flags + [
21 '-ffast-math',
22 '-fno-common',
23 '-fno-strict-aliasing',
24- '-fstack-protector',
25- '-fstack-protector-strong',
26 '-fvisibility=hidden',
27 '--param=ssp-buffer-size=4',
28 ]
diff --git a/meta-microblaze/recipes-core/systemd/files/microblaze-once-macro.patch b/meta-microblaze/recipes-core/systemd/files/microblaze-once-macro.patch
new file mode 100644
index 00000000..ae43692a
--- /dev/null
+++ b/meta-microblaze/recipes-core/systemd/files/microblaze-once-macro.patch
@@ -0,0 +1,44 @@
1For microblaze, replace the ONCE macro
2
3For some reason the systemd developers decided that needed to hardcode
4the usage of __sync_bool_compare_and_swap, however not all architectures
5define this. Microblaze is one such architecture, so we fall back to
6a less 'safe' way of doing the work. However a quick inspection of
7the ONCE users shows that even if we end up with a race condition the
8worst expected behavior could be multiple log messages.
9
10Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
11
12diff --git a/src/fundamental/macro-fundamental.h b/src/fundamental/macro-fundamental.h
13index 967518600d..44785e516b 100644
14--- a/src/fundamental/macro-fundamental.h
15+++ b/src/fundamental/macro-fundamental.h
16@@ -55,11 +55,28 @@
17 * on this macro will run concurrently to all other code conditionalized
18 * the same way, there's no ordering or completion enforced. */
19 #define ONCE __ONCE(UNIQ_T(_once_, UNIQ))
20+#if !defined (__microblaze__)
21 #define __ONCE(o) \
22 ({ \
23 static bool (o) = false; \
24 __sync_bool_compare_and_swap(&(o), false, true); \
25 })
26+#else
27+ /* Microblaze does not contain __sync_bool_compare_and_swap, so we do it
28+ * the old fashioned way. Note, it's possible that ONCE may run more
29+ * then ONCE due to possible races, however it is not expected to cause
30+ * an issue. */
31+#define __ONCE(o) \
32+ ({ \
33+ static bool (o) = false; \
34+ bool rc = false; \
35+ if ((o) == false) { \
36+ (o) = true; \
37+ rc = true; \
38+ } \
39+ rc; \
40+ })
41+#endif
42
43 #undef MAX
44 #define MAX(a, b) __MAX(UNIQ, (a), UNIQ, (b))
diff --git a/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
new file mode 100644
index 00000000..9a1a8bd2
--- /dev/null
+++ b/meta-microblaze/recipes-core/systemd/files/microblaze-syscalls.patch
@@ -0,0 +1,789 @@
1Add microblaze syscalls to systemd
2
3Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
4
5diff --git a/src/basic/meson.build b/src/basic/meson.build
6index 9b016ce5e8..a896e3c464 100644
7--- a/src/basic/meson.build
8+++ b/src/basic/meson.build
9@@ -332,6 +332,7 @@ arch_list = [
10 'i386',
11 'ia64',
12 'm68k',
13+ 'microblaze',
14 'mips64',
15 'mips64n32',
16 'mipso32',
17diff --git a/src/basic/missing_syscall_def.h b/src/basic/missing_syscall_def.h
18index 6a48c2a0c5..ed7df7c07d 100644
19--- a/src/basic/missing_syscall_def.h
20+++ b/src/basic/missing_syscall_def.h
21@@ -14,6 +14,7 @@
22 # elif defined(__i386__)
23 # elif defined(__ia64__)
24 # elif defined(__m68k__)
25+# elif defined(__microblaze__)
26 # elif defined(_MIPS_SIM)
27 # if _MIPS_SIM == _MIPS_SIM_ABI32
28 # elif _MIPS_SIM == _MIPS_SIM_NABI32
29@@ -54,6 +55,8 @@
30 # define systemd_NR_bpf 1341
31 # elif defined(__m68k__)
32 # define systemd_NR_bpf 354
33+# elif defined(__microblaze__)
34+# define systemd_NR_bpf 387
35 # elif defined(_MIPS_SIM)
36 # if _MIPS_SIM == _MIPS_SIM_ABI32
37 # define systemd_NR_bpf 4355
38@@ -118,6 +121,8 @@ assert_cc(__NR_bpf == systemd_NR_bpf);
39 # define systemd_NR_close_range 1460
40 # elif defined(__m68k__)
41 # define systemd_NR_close_range 436
42+# elif defined(__microblaze__)
43+# define systemd_NR_close_range 436
44 # elif defined(_MIPS_SIM)
45 # if _MIPS_SIM == _MIPS_SIM_ABI32
46 # define systemd_NR_close_range 4436
47@@ -182,6 +187,8 @@ assert_cc(__NR_close_range == systemd_NR_close_range);
48 # define systemd_NR_copy_file_range 1347
49 # elif defined(__m68k__)
50 # define systemd_NR_copy_file_range 376
51+# elif defined(__microblaze__)
52+# define systemd_NR_copy_file_range 392
53 # elif defined(_MIPS_SIM)
54 # if _MIPS_SIM == _MIPS_SIM_ABI32
55 # define systemd_NR_copy_file_range 4360
56@@ -246,6 +253,8 @@ assert_cc(__NR_copy_file_range == systemd_NR_copy_file_range);
57 # define systemd_NR_epoll_pwait2 1465
58 # elif defined(__m68k__)
59 # define systemd_NR_epoll_pwait2 441
60+# elif defined(__microblaze__)
61+# define systemd_NR_epoll_pwait2 441
62 # elif defined(_MIPS_SIM)
63 # if _MIPS_SIM == _MIPS_SIM_ABI32
64 # define systemd_NR_epoll_pwait2 4441
65@@ -310,6 +319,8 @@ assert_cc(__NR_epoll_pwait2 == systemd_NR_epoll_pwait2);
66 # define systemd_NR_getrandom 1339
67 # elif defined(__m68k__)
68 # define systemd_NR_getrandom 352
69+# elif defined(__microblaze__)
70+# define systemd_NR_getrandom 385
71 # elif defined(_MIPS_SIM)
72 # if _MIPS_SIM == _MIPS_SIM_ABI32
73 # define systemd_NR_getrandom 4353
74@@ -374,6 +385,8 @@ assert_cc(__NR_getrandom == systemd_NR_getrandom);
75 # define systemd_NR_memfd_create 1340
76 # elif defined(__m68k__)
77 # define systemd_NR_memfd_create 353
78+# elif defined(__microblaze__)
79+# define systemd_NR_memfd_create 386
80 # elif defined(_MIPS_SIM)
81 # if _MIPS_SIM == _MIPS_SIM_ABI32
82 # define systemd_NR_memfd_create 4354
83@@ -438,6 +451,8 @@ assert_cc(__NR_memfd_create == systemd_NR_memfd_create);
84 # define systemd_NR_mount_setattr 1466
85 # elif defined(__m68k__)
86 # define systemd_NR_mount_setattr 442
87+# elif defined(__microblaze__)
88+# define systemd_NR_mount_setattr 442
89 # elif defined(_MIPS_SIM)
90 # if _MIPS_SIM == _MIPS_SIM_ABI32
91 # define systemd_NR_mount_setattr 4442
92@@ -502,6 +517,8 @@ assert_cc(__NR_mount_setattr == systemd_NR_mount_setattr);
93 # define systemd_NR_move_mount 1453
94 # elif defined(__m68k__)
95 # define systemd_NR_move_mount 429
96+# elif defined(__microblaze__)
97+# define systemd_NR_move_mount 429
98 # elif defined(_MIPS_SIM)
99 # if _MIPS_SIM == _MIPS_SIM_ABI32
100 # define systemd_NR_move_mount 4429
101@@ -566,6 +583,8 @@ assert_cc(__NR_move_mount == systemd_NR_move_mount);
102 # define systemd_NR_name_to_handle_at 1326
103 # elif defined(__m68k__)
104 # define systemd_NR_name_to_handle_at 340
105+# elif defined(__microblaze__)
106+# define systemd_NR_name_to_handle_at 371
107 # elif defined(_MIPS_SIM)
108 # if _MIPS_SIM == _MIPS_SIM_ABI32
109 # define systemd_NR_name_to_handle_at 4339
110@@ -630,6 +649,8 @@ assert_cc(__NR_name_to_handle_at == systemd_NR_name_to_handle_at);
111 # define systemd_NR_open_tree 1452
112 # elif defined(__m68k__)
113 # define systemd_NR_open_tree 428
114+# elif defined(__microblaze__)
115+# define systemd_NR_open_tree 428
116 # elif defined(_MIPS_SIM)
117 # if _MIPS_SIM == _MIPS_SIM_ABI32
118 # define systemd_NR_open_tree 4428
119@@ -694,6 +715,8 @@ assert_cc(__NR_open_tree == systemd_NR_open_tree);
120 # define systemd_NR_pidfd_open 1458
121 # elif defined(__m68k__)
122 # define systemd_NR_pidfd_open 434
123+# elif defined(__microblaze__)
124+# define systemd_NR_pidfd_open 434
125 # elif defined(_MIPS_SIM)
126 # if _MIPS_SIM == _MIPS_SIM_ABI32
127 # define systemd_NR_pidfd_open 4434
128@@ -758,6 +781,8 @@ assert_cc(__NR_pidfd_open == systemd_NR_pidfd_open);
129 # define systemd_NR_pidfd_send_signal 1448
130 # elif defined(__m68k__)
131 # define systemd_NR_pidfd_send_signal 424
132+# elif defined(__microblaze__)
133+# define systemd_NR_pidfd_send_signal 424
134 # elif defined(_MIPS_SIM)
135 # if _MIPS_SIM == _MIPS_SIM_ABI32
136 # define systemd_NR_pidfd_send_signal 4424
137@@ -822,6 +847,8 @@ assert_cc(__NR_pidfd_send_signal == systemd_NR_pidfd_send_signal);
138 # define systemd_NR_pkey_mprotect 1354
139 # elif defined(__m68k__)
140 # define systemd_NR_pkey_mprotect 381
141+# elif defined(__microblaze__)
142+# define systemd_NR_pkey_mprotect 395
143 # elif defined(_MIPS_SIM)
144 # if _MIPS_SIM == _MIPS_SIM_ABI32
145 # define systemd_NR_pkey_mprotect 4363
146@@ -886,6 +913,8 @@ assert_cc(__NR_pkey_mprotect == systemd_NR_pkey_mprotect);
147 # define systemd_NR_renameat2 1338
148 # elif defined(__m68k__)
149 # define systemd_NR_renameat2 351
150+# elif defined(__microblaze__)
151+# define systemd_NR_renameat2 383
152 # elif defined(_MIPS_SIM)
153 # if _MIPS_SIM == _MIPS_SIM_ABI32
154 # define systemd_NR_renameat2 4351
155@@ -950,6 +979,8 @@ assert_cc(__NR_renameat2 == systemd_NR_renameat2);
156 # define systemd_NR_setns 1330
157 # elif defined(__m68k__)
158 # define systemd_NR_setns 344
159+# elif defined(__microblaze__)
160+# define systemd_NR_setns 375
161 # elif defined(_MIPS_SIM)
162 # if _MIPS_SIM == _MIPS_SIM_ABI32
163 # define systemd_NR_setns 4344
164@@ -1014,6 +1045,8 @@ assert_cc(__NR_setns == systemd_NR_setns);
165 # define systemd_NR_statx 1350
166 # elif defined(__m68k__)
167 # define systemd_NR_statx 379
168+# elif defined(__microblaze__)
169+# define systemd_NR_statx 398
170 # elif defined(_MIPS_SIM)
171 # if _MIPS_SIM == _MIPS_SIM_ABI32
172 # define systemd_NR_statx 4366
173diff --git a/src/basic/missing_syscalls.py b/src/basic/missing_syscalls.py
174index 19f9726d4e..66fd7615b4 100644
175--- a/src/basic/missing_syscalls.py
176+++ b/src/basic/missing_syscalls.py
177@@ -61,6 +61,8 @@ DEF_TEMPLATE_B = '''\
178 # define systemd_NR_{syscall} {nr_ia64}
179 # elif defined(__m68k__)
180 # define systemd_NR_{syscall} {nr_m68k}
181+# elif defined(__microblaze__)
182+# define systemd_NR_{syscall} {nr_microblaze}
183 # elif defined(_MIPS_SIM)
184 # if _MIPS_SIM == _MIPS_SIM_ABI32
185 # define systemd_NR_{syscall} {nr_mipso32}
186diff --git a/src/basic/syscalls-microblaze.txt b/src/basic/syscalls-microblaze.txt
187new file mode 100644
188index 0000000000..3fc4cd6aef
189--- /dev/null
190+++ b/src/basic/syscalls-microblaze.txt
191@@ -0,0 +1,598 @@
192+_llseek 140
193+_newselect 142
194+_sysctl 149
195+accept 349
196+accept4 362
197+access 33
198+acct 51
199+add_key 286
200+adjtimex 124
201+alarm 27
202+arc_gettls
203+arc_settls
204+arc_usr_cmpxchg
205+arch_prctl
206+arm_fadvise64_64
207+atomic_barrier
208+atomic_cmpxchg_32
209+bdflush 134
210+bind 347
211+bpf 387
212+brk 45
213+cachectl
214+cacheflush
215+capget 184
216+capset 185
217+chdir 12
218+chmod 15
219+chown 182
220+chown32 212
221+chroot 61
222+clock_adjtime 373
223+clock_adjtime64 405
224+clock_getres 266
225+clock_getres_time64 406
226+clock_gettime 265
227+clock_gettime64 403
228+clock_nanosleep 267
229+clock_nanosleep_time64 407
230+clock_settime 264
231+clock_settime64 404
232+clone 120
233+clone2
234+clone3 435
235+close 6
236+close_range 436
237+connect 350
238+copy_file_range 392
239+creat 8
240+create_module 127
241+delete_module 129
242+dipc
243+dup 41
244+dup2 63
245+dup3 342
246+epoll_create 254
247+epoll_create1 341
248+epoll_ctl 255
249+epoll_ctl_old
250+epoll_pwait 319
251+epoll_pwait2 441
252+epoll_wait 256
253+epoll_wait_old
254+eventfd 323
255+eventfd2 340
256+exec_with_loader
257+execv
258+execve 11
259+execveat 388
260+exit 1
261+exit_group 252
262+faccessat 307
263+faccessat2 439
264+fadvise64 250
265+fadvise64_64 272
266+fallocate 324
267+fanotify_init 368
268+fanotify_mark 369
269+fchdir 133
270+fchmod 94
271+fchmodat 306
272+fchown 95
273+fchown32 207
274+fchownat 298
275+fcntl 55
276+fcntl64 221
277+fdatasync 148
278+fgetxattr 231
279+finit_module 380
280+flistxattr 234
281+flock 143
282+fork 2
283+fp_udfiex_crtl
284+fremovexattr 237
285+fsconfig 431
286+fsetxattr 228
287+fsmount 432
288+fsopen 430
289+fspick 433
290+fstat 108
291+fstat64 197
292+fstatat64 300
293+fstatfs 100
294+fstatfs64 269
295+fsync 118
296+ftruncate 93
297+ftruncate64 194
298+futex 240
299+futex_time64 422
300+futimesat 299
301+get_kernel_syms 130
302+get_mempolicy 275
303+get_robust_list 312
304+get_thread_area 244
305+getcpu 318
306+getcwd 183
307+getdents 141
308+getdents64 220
309+getdomainname
310+getdtablesize
311+getegid 50
312+getegid32 202
313+geteuid 49
314+geteuid32 201
315+getgid 47
316+getgid32 200
317+getgroups 80
318+getgroups32 205
319+gethostname
320+getitimer 105
321+getpagesize
322+getpeername 352
323+getpgid 132
324+getpgrp 65
325+getpid 20
326+getpmsg 188
327+getppid 64
328+getpriority 96
329+getrandom 385
330+getresgid 171
331+getresgid32 211
332+getresuid 165
333+getresuid32 209
334+getrlimit 76
335+getrusage 77
336+getsid 147
337+getsockname 351
338+getsockopt 358
339+gettid 224
340+gettimeofday 78
341+getuid 24
342+getuid32 199
343+getunwind
344+getxattr 229
345+getxgid
346+getxpid
347+getxuid
348+idle 112
349+init_module 128
350+inotify_add_watch 292
351+inotify_init 291
352+inotify_init1 344
353+inotify_rm_watch 293
354+io_cancel 249
355+io_destroy 246
356+io_getevents 247
357+io_pgetevents 399
358+io_pgetevents_time64 416
359+io_setup 245
360+io_submit 248
361+io_uring_enter 426
362+io_uring_register 427
363+io_uring_setup 425
364+ioctl 54
365+ioperm 101
366+iopl 110
367+ioprio_get 290
368+ioprio_set 289
369+ipc 117
370+kcmp 379
371+kern_features
372+kexec_file_load
373+kexec_load 283
374+keyctl 288
375+kill 37
376+landlock_add_rule 445
377+landlock_create_ruleset 444
378+landlock_restrict_self 446
379+lchown 16
380+lchown32 198
381+lgetxattr 230
382+link 9
383+linkat 303
384+listen 348
385+listxattr 232
386+llistxattr 233
387+lookup_dcookie 253
388+lremovexattr 236
389+lseek 19
390+lsetxattr 227
391+lstat 107
392+lstat64 196
393+madvise 219
394+mbind 274
395+membarrier 390
396+memfd_create 386
397+memory_ordering
398+migrate_pages 294
399+mincore 218
400+mkdir 39
401+mkdirat 296
402+mknod 14
403+mknodat 297
404+mlock 150
405+mlock2 391
406+mlockall 152
407+mmap 90
408+mmap2 192
409+modify_ldt 123
410+mount 21
411+mount_setattr 442
412+move_mount 429
413+move_pages 317
414+mprotect 125
415+mq_getsetattr 282
416+mq_notify 281
417+mq_open 277
418+mq_timedreceive 280
419+mq_timedreceive_time64 419
420+mq_timedsend 279
421+mq_timedsend_time64 418
422+mq_unlink 278
423+mremap 163
424+msgctl 331
425+msgget 332
426+msgrcv 333
427+msgsnd 334
428+msync 144
429+multiplexer
430+munlock 151
431+munlockall 153
432+munmap 91
433+name_to_handle_at 371
434+nanosleep 162
435+newfstatat
436+nfsservctl 169
437+nice 34
438+old_adjtimex
439+old_getpagesize
440+oldfstat 28
441+oldlstat 84
442+oldolduname 59
443+oldstat 18
444+oldumount
445+olduname 109
446+open 5
447+open_by_handle_at 372
448+open_tree 428
449+openat 295
450+openat2 437
451+or1k_atomic
452+osf_adjtime
453+osf_afs_syscall
454+osf_alt_plock
455+osf_alt_setsid
456+osf_alt_sigpending
457+osf_asynch_daemon
458+osf_audcntl
459+osf_audgen
460+osf_chflags
461+osf_execve
462+osf_exportfs
463+osf_fchflags
464+osf_fdatasync
465+osf_fpathconf
466+osf_fstat
467+osf_fstatfs
468+osf_fstatfs64
469+osf_fuser
470+osf_getaddressconf
471+osf_getdirentries
472+osf_getdomainname
473+osf_getfh
474+osf_getfsstat
475+osf_gethostid
476+osf_getitimer
477+osf_getlogin
478+osf_getmnt
479+osf_getrusage
480+osf_getsysinfo
481+osf_gettimeofday
482+osf_kloadcall
483+osf_kmodcall
484+osf_lstat
485+osf_memcntl
486+osf_mincore
487+osf_mount
488+osf_mremap
489+osf_msfs_syscall
490+osf_msleep
491+osf_mvalid
492+osf_mwakeup
493+osf_naccept
494+osf_nfssvc
495+osf_ngetpeername
496+osf_ngetsockname
497+osf_nrecvfrom
498+osf_nrecvmsg
499+osf_nsendmsg
500+osf_ntp_adjtime
501+osf_ntp_gettime
502+osf_old_creat
503+osf_old_fstat
504+osf_old_getpgrp
505+osf_old_killpg
506+osf_old_lstat
507+osf_old_open
508+osf_old_sigaction
509+osf_old_sigblock
510+osf_old_sigreturn
511+osf_old_sigsetmask
512+osf_old_sigvec
513+osf_old_stat
514+osf_old_vadvise
515+osf_old_vtrace
516+osf_old_wait
517+osf_oldquota
518+osf_pathconf
519+osf_pid_block
520+osf_pid_unblock
521+osf_plock
522+osf_priocntlset
523+osf_profil
524+osf_proplist_syscall
525+osf_reboot
526+osf_revoke
527+osf_sbrk
528+osf_security
529+osf_select
530+osf_set_program_attributes
531+osf_set_speculative
532+osf_sethostid
533+osf_setitimer
534+osf_setlogin
535+osf_setsysinfo
536+osf_settimeofday
537+osf_shmat
538+osf_signal
539+osf_sigprocmask
540+osf_sigsendset
541+osf_sigstack
542+osf_sigwaitprim
543+osf_sstk
544+osf_stat
545+osf_statfs
546+osf_statfs64
547+osf_subsys_info
548+osf_swapctl
549+osf_swapon
550+osf_syscall
551+osf_sysinfo
552+osf_table
553+osf_uadmin
554+osf_usleep_thread
555+osf_uswitch
556+osf_utc_adjtime
557+osf_utc_gettime
558+osf_utimes
559+osf_utsname
560+osf_wait4
561+osf_waitid
562+pause 29
563+pciconfig_iobase
564+pciconfig_read
565+pciconfig_write
566+perf_event_open 366
567+perfctr
568+perfmonctl
569+personality 136
570+pidfd_getfd 438
571+pidfd_open 434
572+pidfd_send_signal 424
573+pipe 42
574+pipe2 343
575+pivot_root 217
576+pkey_alloc 396
577+pkey_free 397
578+pkey_mprotect 395
579+poll 168
580+ppoll 309
581+ppoll_time64 414
582+prctl 172
583+pread64 180
584+preadv 363
585+preadv2 393
586+prlimit64 370
587+process_madvise 440
588+process_vm_readv 377
589+process_vm_writev 378
590+pselect6 308
591+pselect6_time64 413
592+ptrace 26
593+pwrite64 181
594+pwritev 364
595+pwritev2 394
596+query_module 167
597+quotactl 131
598+quotactl_path
599+read 3
600+readahead 225
601+readdir 89
602+readlink 85
603+readlinkat 305
604+readv 145
605+reboot 88
606+recv 356
607+recvfrom 355
608+recvmmsg 367
609+recvmmsg_time64 417
610+recvmsg 361
611+remap_file_pages 257
612+removexattr 235
613+rename 38
614+renameat 302
615+renameat2 383
616+request_key 287
617+restart_syscall 0
618+riscv_flush_icache
619+rmdir 40
620+rseq 400
621+rt_sigaction 174
622+rt_sigpending 176
623+rt_sigprocmask 175
624+rt_sigqueueinfo 178
625+rt_sigreturn 173
626+rt_sigsuspend 179
627+rt_sigtimedwait 177
628+rt_sigtimedwait_time64 421
629+rt_tgsigqueueinfo 365
630+rtas
631+s390_guarded_storage
632+s390_pci_mmio_read
633+s390_pci_mmio_write
634+s390_runtime_instr
635+s390_sthyi
636+sched_get_affinity
637+sched_get_priority_max 159
638+sched_get_priority_min 160
639+sched_getaffinity 242
640+sched_getattr 382
641+sched_getparam 155
642+sched_getscheduler 157
643+sched_rr_get_interval 161
644+sched_rr_get_interval_time64 423
645+sched_set_affinity
646+sched_setaffinity 241
647+sched_setattr 381
648+sched_setparam 154
649+sched_setscheduler 156
650+sched_yield 158
651+seccomp 384
652+select 82
653+semctl 328
654+semget 329
655+semop 330
656+semtimedop 325
657+semtimedop_time64 420
658+send 354
659+sendfile 187
660+sendfile64 239
661+sendmmsg 376
662+sendmsg 360
663+sendto 353
664+set_mempolicy 276
665+set_robust_list 311
666+set_thread_area 243
667+set_tid_address 258
668+setdomainname 121
669+setfsgid 139
670+setfsgid32 216
671+setfsuid 138
672+setfsuid32 215
673+setgid 46
674+setgid32 214
675+setgroups 81
676+setgroups32 206
677+sethae
678+sethostname 74
679+setitimer 104
680+setns 375
681+setpgid 57
682+setpgrp
683+setpriority 97
684+setregid 71
685+setregid32 204
686+setresgid 170
687+setresgid32 210
688+setresuid 164
689+setresuid32 208
690+setreuid 70
691+setreuid32 203
692+setrlimit 75
693+setsid 66
694+setsockopt 357
695+settimeofday 79
696+setuid 23
697+setuid32 213
698+setxattr 226
699+sgetmask 68
700+shmat 335
701+shmctl 336
702+shmdt 337
703+shmget 338
704+shutdown 359
705+sigaction 67
706+sigaltstack 186
707+signal 48
708+signalfd 321
709+signalfd4 339
710+sigpending 73
711+sigprocmask 126
712+sigreturn 119
713+sigsuspend 72
714+socket 345
715+socketcall 102
716+socketpair 346
717+splice 313
718+spu_create
719+spu_run
720+ssetmask 69
721+stat 106
722+stat64 195
723+statfs 99
724+statfs64 268
725+statx 398
726+stime 25
727+subpage_prot
728+swapcontext
729+swapoff 115
730+swapon 87
731+switch_endian
732+symlink 83
733+symlinkat 304
734+sync 36
735+sync_file_range 314
736+sync_file_range2
737+syncfs 374
738+sys_debug_setcontext
739+syscall
740+sysfs 135
741+sysinfo 116
742+syslog 103
743+sysmips
744+tee 315
745+tgkill 270
746+time 13
747+timer_create 259
748+timer_delete 263
749+timer_getoverrun 262
750+timer_gettime 261
751+timer_gettime64 408
752+timer_settime 260
753+timer_settime64 409
754+timerfd
755+timerfd_create 322
756+timerfd_gettime 327
757+timerfd_gettime64 410
758+timerfd_settime 326
759+timerfd_settime64 411
760+times 43
761+tkill 238
762+truncate 92
763+truncate64 193
764+ugetrlimit 191
765+umask 60
766+umount 22
767+umount2 52
768+uname 122
769+unlink 10
770+unlinkat 301
771+unshare 310
772+uselib 86
773+userfaultfd 389
774+ustat 62
775+utime 30
776+utimensat 320
777+utimensat_time64 412
778+utimes 271
779+utrap_install
780+vfork 190
781+vhangup 111
782+vm86 166
783+vm86old 113
784+vmsplice 316
785+wait4 114
786+waitid 284
787+waitpid 7
788+write 4
789+writev 146
diff --git a/meta-microblaze/recipes-core/systemd/systemd_%.bbappend b/meta-microblaze/recipes-core/systemd/systemd_%.bbappend
index 7a063c6e..0d31eb8f 100644
--- a/meta-microblaze/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-microblaze/recipes-core/systemd/systemd_%.bbappend
@@ -1,4 +1,7 @@
1FILESEXTRAPATHS:append:microblaze := ":${THISDIR}/files" 1FILESEXTRAPATHS:append:microblaze := ":${THISDIR}/files"
2SRC_URI:append:microblaze = " \ 2SRC_URI:append:microblaze = " \
3 file://0001-architecture-Add-Micorblaze-architecture-to-systemd-.patch \ 3 file://0001-architecture-Add-Microblaze-architecture-to-systemd-.patch \
4 file://microblaze-syscalls.patch \
5 file://microblaze-disable-stack-protector.patch \
6 file://microblaze-once-macro.patch \
4" 7"