summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwagath Gadde <swagath.gadde@xilinx.com>2019-07-10 18:13:10 +0530
committerSai Hari Chandana Kalluri <chandana.kalluri@xilinx.com>2019-12-13 13:27:17 -0800
commitfa0b52831c74db07ad22f00f78df3e7a26b5aff8 (patch)
tree9b7b668a54f408937966c39ca2514c23e3935677
parente2c57136b9bb06b65fec06ea12d80791e7412cd4 (diff)
downloadmeta-xilinx-fa0b52831c74db07ad22f00f78df3e7a26b5aff8.tar.gz
u-boot-zynq-scr: Add pxeboot support in u-boot-scr
This patch adds pxeboot support for versal platform by adding default config file in pxelinux.cfg directory with below minimal mandatory information forbooting. label <name> - begin a label definition. labels continue until a command not recognized as a label command is seen, or EOF is reached. kernel <path> - if this label is chosen, use tftp to retrieve the kernel at <path>. it will be stored at the address indicated in the kernel_addr_r environment variable, and that address will be passed to bootm to boot this kernel. fdt <path> - if this label is chosen, it will load dtb at fdt_addr and that location of a fdt_addr will be passed to bootm when booting a kernel. Generally after u-boot bootup in jtag mode after autoboot time it scans usb and then ethernet and checks for pxelinux.cfg directory with default config file, if found it will load and boot linux. Steps to test: 1.acquire the board 2.in systest point the tftpd <path> 3.open serial terminal and connect com0 4.load the pdi from xsdb 5.stop at uboot promt and set serverip 6.dhcp 7.pxe get 8.pxe boot Signed-off-by: Swagath Gadde <swagathg@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
index d2eedd58..584089ae 100644
--- a/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
+++ b/meta-xilinx-bsp/recipes-bsp/u-boot/u-boot-zynq-scr.bb
@@ -24,11 +24,11 @@ KERNEL_BOOTCMD_zynq ?= "bootm"
24KERNEL_BOOTCMD_versal ?= "booti" 24KERNEL_BOOTCMD_versal ?= "booti"
25 25
26BOOTMODE ?= "sd" 26BOOTMODE ?= "sd"
27BOOTMODE_versal ?= "qspi"
28 27
29SRC_URI = " \ 28SRC_URI = " \
30 file://boot.cmd.sd.zynq \ 29 file://boot.cmd.sd.zynq \
31 file://boot.cmd.sd.zynqmp \ 30 file://boot.cmd.sd.zynqmp \
31 file://boot.cmd.sd.versal \
32 file://boot.cmd.qspi.versal \ 32 file://boot.cmd.qspi.versal \
33 file://pxeboot.pxe \ 33 file://pxeboot.pxe \
34 " 34 "