summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-09-29 23:21:56 +1000
committerNathan Rossi <nathan@nathanrossi.com>2017-10-18 18:00:31 +1000
commitff9f7c1202687ef4c829e9be505e47cc1699c2e5 (patch)
tree3106ae915b3034ac885c2bbd192bee667802c8a2
parentf2bf3acefdbe7a96b8cd2997d4fec6d723c043f7 (diff)
downloadmeta-xilinx-ff9f7c1202687ef4c829e9be505e47cc1699c2e5.tar.gz
linux-yocto_4.4.bbappend: Drop patches for 4.4
Drop patches for the linux-yocto 4.4 kernel. This version of linux-yocto does not have upstream configuration for meta-xilinx targets and is superseded by 4.9 and newer kernels. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Reviewed-by: Alistair Francis <alistair.francis@xilinx.com>
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend6
-rw-r--r--recipes-kernel/linux/linux/ARM-dts-zynq-Enable-USB-and-USB-PHY-for-ZYBO.patch52
2 files changed, 0 insertions, 58 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
deleted file mode 100644
index 1af47733..00000000
--- a/recipes-kernel/linux/linux-yocto_4.4.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
3SRC_URI_append = " \
4 file://ARM-dts-zynq-Enable-USB-and-USB-PHY-for-ZYBO.patch \
5 "
6
diff --git a/recipes-kernel/linux/linux/ARM-dts-zynq-Enable-USB-and-USB-PHY-for-ZYBO.patch b/recipes-kernel/linux/linux/ARM-dts-zynq-Enable-USB-and-USB-PHY-for-ZYBO.patch
deleted file mode 100644
index 26f57bf3..00000000
--- a/recipes-kernel/linux/linux/ARM-dts-zynq-Enable-USB-and-USB-PHY-for-ZYBO.patch
+++ /dev/null
@@ -1,52 +0,0 @@
1From b977025153a6f43ec5070d2f7a26f2ecb22c0319 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Wed, 3 Feb 2016 22:41:05 +1000
4Subject: [PATCH] ARM: dts: zynq: Enable USB and USB PHY for ZYBO
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Setup the USB controller and configure it to operate in host mode.
10Additionally add the USB phy node for the ZYBO, including reset gpio
11which is connected to a external MIO pin.
12
13Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
14Cc: Rob Herring <robh+dt@kernel.org>
15Cc: Mark Rutland <mark.rutland@arm.com>
16Cc: Michal Simek <michal.simek@xilinx.com>
17Cc: Sören Brinkmann <soren.brinkmann@xilinx.com>
18Signed-off-by: Michal Simek <michal.simek@xilinx.com>
19Upstream-Status: Backport
20---
21 arch/arm/boot/dts/zynq-zybo.dts | 11 +++++++++++
22 1 file changed, 11 insertions(+)
23
24diff --git a/arch/arm/boot/dts/zynq-zybo.dts b/arch/arm/boot/dts/zynq-zybo.dts
25index 16c9cac..8f085b3 100644
26--- a/arch/arm/boot/dts/zynq-zybo.dts
27+++ b/arch/arm/boot/dts/zynq-zybo.dts
28@@ -33,6 +33,11 @@
29 stdout-path = "serial0:115200n8";
30 };
31
32+ usb_phy0: phy0 {
33+ #phy-cells = <0>;
34+ compatible = "usb-nop-xceiv";
35+ reset-gpios = <&gpio0 46 1>;
36+ };
37 };
38
39 &clkc {
40@@ -56,3 +61,9 @@
41 &uart1 {
42 status = "okay";
43 };
44+
45+&usb0 {
46+ status = "okay";
47+ dr_mode = "host";
48+ usb-phy = <&usb_phy0>;
49+};
50--
512.8.0.rc3
52