summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-11-14 23:15:23 +1000
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-21 11:19:00 -0800
commiteb0abe02308a8c10a6bb7d77e0d29a343d710cb5 (patch)
treeb21e4de95c14f5af50abce475e082c0e4d34ec48
parent2b6616ec267b766689898723a034302f87e232e6 (diff)
downloadmeta-xilinx-eb0abe02308a8c10a6bb7d77e0d29a343d710cb5.tar.gz
device-tree: Setup COMPATIBLE_MACHINE
Setup COMPATIBLE_MACHINE for the device-tree recipe so that it is only available to machines that have provided sources/device-trees. The COMPATIBLE_MACHINE is defined by overrides to match any machine ('.*') which sets the targeted override. This allows for easy reuse of sources across similar machines. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--recipes-bsp/device-tree/device-tree.bb2
-rw-r--r--recipes-bsp/device-tree/device-tree.bbappend9
2 files changed, 11 insertions, 0 deletions
diff --git a/recipes-bsp/device-tree/device-tree.bb b/recipes-bsp/device-tree/device-tree.bb
index eb1a8792..8aa03f6e 100644
--- a/recipes-bsp/device-tree/device-tree.bb
+++ b/recipes-bsp/device-tree/device-tree.bb
@@ -14,6 +14,8 @@ inherit kernel-arch
14INHIBIT_DEFAULT_DEPS = "1" 14INHIBIT_DEFAULT_DEPS = "1"
15DEPENDS += "dtc-native" 15DEPENDS += "dtc-native"
16 16
17COMPATIBLE_MACHINE ?= "^$"
18
17PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"
18 20
19FILES_${PN} = "/boot/devicetree/*.dtb /boot/devicetree/*.dtbo" 21FILES_${PN} = "/boot/devicetree/*.dtb /boot/devicetree/*.dtbo"
diff --git a/recipes-bsp/device-tree/device-tree.bbappend b/recipes-bsp/device-tree/device-tree.bbappend
index 4f46e358..e128e0e8 100644
--- a/recipes-bsp/device-tree/device-tree.bbappend
+++ b/recipes-bsp/device-tree/device-tree.bbappend
@@ -5,14 +5,23 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
5SRC_URI_append_zynq = " file://zynq-7000-qspi-dummy.dtsi" 5SRC_URI_append_zynq = " file://zynq-7000-qspi-dummy.dtsi"
6 6
7# device tree sources for the various machines 7# device tree sources for the various machines
8COMPATIBLE_MACHINE_picozed-zynq7 = ".*"
8SRC_URI_append_picozed-zynq7 = " file://picozed-zynq7.dts" 9SRC_URI_append_picozed-zynq7 = " file://picozed-zynq7.dts"
10
11COMPATIBLE_MACHINE_microzed-zynq7 = ".*"
9SRC_URI_append_microzed-zynq7 = " file://microzed-zynq7.dts" 12SRC_URI_append_microzed-zynq7 = " file://microzed-zynq7.dts"
13
14COMPATIBLE_MACHINE_qemu-zynq7 = ".*"
10SRC_URI_append_qemu-zynq7 = " file://qemu-zynq7.dts" 15SRC_URI_append_qemu-zynq7 = " file://qemu-zynq7.dts"
16
17COMPATIBLE_MACHINE_zybo-linux-bd-zynq7 = ".*"
11SRC_URI_append_zybo-linux-bd-zynq7 = " \ 18SRC_URI_append_zybo-linux-bd-zynq7 = " \
12 file://zybo-linux-bd-zynq7.dts \ 19 file://zybo-linux-bd-zynq7.dts \
13 file://pcw.dtsi \ 20 file://pcw.dtsi \
14 file://pl.dtsi \ 21 file://pl.dtsi \
15 " 22 "
23
24COMPATIBLE_MACHINE_kc705-microblazeel = ".*"
16SRC_URI_append_kc705-microblazeel = " \ 25SRC_URI_append_kc705-microblazeel = " \
17 file://kc705-microblazeel.dts \ 26 file://kc705-microblazeel.dts \
18 file://pl.dtsi \ 27 file://pl.dtsi \