summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-11-14 23:15:23 +1000
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-21 11:19:00 -0800
commitc29b040639203fd3f1d96db01162db2611e6a7b3 (patch)
treea27eb40b97ad78681a10ec0e27b29cbf5a3b58e9
parent7032447a09c4722a30ebac54593be477fea25d12 (diff)
downloadmeta-xilinx-c29b040639203fd3f1d96db01162db2611e6a7b3.tar.gz
u-boot-xlnx_2017.3: Fix QEMU SD boot partition setup
Add a patch to fix the SD boot partition setup for QEMU targets such that instead of QEMU being special it defaults to the same behaviour as silicon/etc. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/v2017.3/arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch33
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb4
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/v2017.3/arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch b/recipes-bsp/u-boot/u-boot-xlnx/v2017.3/arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch
new file mode 100644
index 00000000..d8261e62
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-xlnx/v2017.3/arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch
@@ -0,0 +1,33 @@
1From 777ac896daaffeaa2fac2bdb424a96def7409a4b Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Wed, 18 Oct 2017 21:29:47 +1000
4Subject: [PATCH] arm64: zynqmp: Setup partid for QEMU to match silicon
5
6During board late init the environment is 'setup' to set the partid to 0
7for QEMU. Change this so that QEMU targets behave just like silicon and
8emulation targets such that partid is set to auto.
9
10Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
11Upstream-Status: Submitted [sent to git@xilinx.com]
12---
13 board/xilinx/zynqmp/zynqmp.c | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/board/xilinx/zynqmp/zynqmp.c b/board/xilinx/zynqmp/zynqmp.c
17index fd80844df6..2df66a4b75 100644
18--- a/board/xilinx/zynqmp/zynqmp.c
19+++ b/board/xilinx/zynqmp/zynqmp.c
20@@ -294,9 +294,9 @@ int board_late_init(void)
21 setenv("setup", "setenv baudrate 4800 && setenv bootcmd run veloce");
22 case ZYNQMP_CSU_VERSION_EP108:
23 case ZYNQMP_CSU_VERSION_SILICON:
24+ case ZYNQMP_CSU_VERSION_QEMU:
25 setenv("setup", "setenv partid auto");
26 break;
27- case ZYNQMP_CSU_VERSION_QEMU:
28 default:
29 setenv("setup", "setenv partid 0");
30 }
31--
322.15.0
33
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
index 867f72e2..c10564f4 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
@@ -5,6 +5,10 @@ XILINX_RELEASE_VERSION = "v2017.3"
5SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded" 5SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded"
6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
7 7
8SRC_URI_append = " \
9 file://arm64-zynqmp-Setup-partid-for-QEMU-to-match-silicon.patch \
10 "
11
8LICENSE = "GPLv2+" 12LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" 13LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
10 14