summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Rossi <nathan@nathanrossi.com>2017-11-14 23:15:23 +1000
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-21 11:19:00 -0800
commit9814008b5ff354142e644609b6b4356c4161c521 (patch)
treec3fb20effbb06b72257e876ea9f4212fc81b9cd2
parent06d3a9509ed38ae39ee4bfaa698e625011576318 (diff)
downloadmeta-xilinx-9814008b5ff354142e644609b6b4356c4161c521.tar.gz
Update recipes for Xilinx v2017.3 release
Update the arm-trusted-firmware, pmu-firmware, u-boot-xlnx, linux-xlnx, qemu-xilinx and qemu-devicetrees recipes for to the 'xilinx-v2017.3' release tags. Drop/update existing patches where applicable. Signed-off-by: Nathan Rossi <nathan@nathanrossi.com> Reviewed-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.1.bb9
-rw-r--r--recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.3.bb6
-rw-r--r--recipes-bsp/arm-trusted-firmware/files/psci_common-Resolve-GCC-static-analysis-false-positi.patch49
-rw-r--r--recipes-bsp/arm-trusted-firmware/files/zynqmp-Remove-duplicate-const-declaration.patch30
-rw-r--r--recipes-bsp/pmu-firmware/pmu-firmware_2017.3.bb (renamed from recipes-bsp/pmu-firmware/pmu-firmware_2017.1.bb)6
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch39
-rw-r--r--recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb (renamed from recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb)12
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees_2017.3.bb (renamed from recipes-devtools/qemu/qemu-devicetrees_2017.1.bb)2
-rw-r--r--recipes-devtools/qemu/qemu-xilinx_2017.3.bb (renamed from recipes-devtools/qemu/qemu-xilinx_2017.1.bb)2
-rw-r--r--recipes-kernel/linux/linux-xlnx.inc2
-rw-r--r--recipes-kernel/linux/linux-xlnx/v2017.3/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch (renamed from recipes-kernel/linux/linux-xlnx/4.9/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch)19
-rw-r--r--recipes-kernel/linux/linux-xlnx/v2017.3/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch (renamed from recipes-kernel/linux/linux-xlnx/4.9/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch)4
-rw-r--r--recipes-kernel/linux/linux-xlnx/v2017.3/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch (renamed from recipes-kernel/linux/linux-xlnx/4.9/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch)29
-rw-r--r--recipes-kernel/linux/linux-xlnx_2017.3.bb (renamed from recipes-kernel/linux/linux-xlnx_2017.1.bb)4
14 files changed, 40 insertions, 173 deletions
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.1.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.1.bb
deleted file mode 100644
index e68e5cfb..00000000
--- a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.1.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1include arm-trusted-firmware.inc
2
3XILINX_RELEASE_VERSION = "v2017.1"
4SRCREV ?= "7d1a6732c9ae113999aeabcb9912369760d05c13"
5
6PV = "1.3-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
7
8SRC_URI += "file://zynqmp-Remove-duplicate-const-declaration.patch"
9SRC_URI += "file://psci_common-Resolve-GCC-static-analysis-false-positi.patch"
diff --git a/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.3.bb b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.3.bb
new file mode 100644
index 00000000..9bf5cacf
--- /dev/null
+++ b/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_2017.3.bb
@@ -0,0 +1,6 @@
1include arm-trusted-firmware.inc
2
3XILINX_RELEASE_VERSION = "v2017.3"
4SRCREV ?= "f9b244beaa7ac6a670b192192b6e92e5fd6044dc"
5
6PV = "1.3-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
diff --git a/recipes-bsp/arm-trusted-firmware/files/psci_common-Resolve-GCC-static-analysis-false-positi.patch b/recipes-bsp/arm-trusted-firmware/files/psci_common-Resolve-GCC-static-analysis-false-positi.patch
deleted file mode 100644
index bc9bf61c..00000000
--- a/recipes-bsp/arm-trusted-firmware/files/psci_common-Resolve-GCC-static-analysis-false-positi.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From 8596a87e75421016b83ed7f2ffb342114f48b5ca Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@xilinx.com>
3Date: Wed, 23 Aug 2017 13:55:21 -0700
4Subject: [PATCH] psci_common: Resolve GCC static analysis false positive
5
6Previously commit 555ebb34db8f3424c1b394df2f10ecf9c1f70901 attmpted to fix this
7GCC issue:
8
9services/std_svc/psci/psci_common.c: In function 'psci_do_state_coordination':
10services/std_svc/psci/psci_common.c:220:27: error: array subscript is above
11array bounds [-Werror=array-bounds]
12 psci_req_local_pwr_states[pwrlvl - 1][cpu_idx] = req_pwr_state;
13
14This fix doesn't work as asserts aren't built in non-debug build flows.
15
16Let's use GCCs #pragma option (documented here:
17https://gcc.gnu.org/onlinedocs/gcc/Diagnostic-Pragmas.html) to avoid
18this false positive instead.
19
20Signed-off-by: Alistair Francis <alistair.francis@xilinx.com>
21---
22Upstream Status: Accepted in mainline, pending for 2017.3
23
24 lib/psci/psci_common.c | 7 +++++++
25 1 file changed, 7 insertions(+)
26
27diff --git a/lib/psci/psci_common.c b/lib/psci/psci_common.c
28index 68cdd6eb..3843d4df 100644
29--- a/lib/psci/psci_common.c
30+++ b/lib/psci/psci_common.c
31@@ -216,8 +216,15 @@ static void psci_set_req_local_pwr_state(unsigned int pwrlvl,
32 unsigned int cpu_idx,
33 plat_local_state_t req_pwr_state)
34 {
35+ /*
36+ * This should never happen, we have this here to avoid
37+ * "array subscript is above array bounds" errors in GCC.
38+ */
39 assert(pwrlvl > PSCI_CPU_PWR_LVL);
40+#pragma GCC diagnostic push
41+#pragma GCC diagnostic ignored "-Warray-bounds"
42 psci_req_local_pwr_states[pwrlvl - 1][cpu_idx] = req_pwr_state;
43+#pragma GCC diagnostic pop
44 }
45
46 /******************************************************************************
47--
482.11.0
49
diff --git a/recipes-bsp/arm-trusted-firmware/files/zynqmp-Remove-duplicate-const-declaration.patch b/recipes-bsp/arm-trusted-firmware/files/zynqmp-Remove-duplicate-const-declaration.patch
deleted file mode 100644
index aeb5a203..00000000
--- a/recipes-bsp/arm-trusted-firmware/files/zynqmp-Remove-duplicate-const-declaration.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From a97f6272b7a7a8e3249df34c22479b3893746395 Mon Sep 17 00:00:00 2001
2From: Soren Brinkmann <soren.brinkmann@xilinx.com>
3Date: Sat, 1 Jul 2017 20:24:47 -0700
4Subject: [PATCH] zynqmp: Remove duplicate 'const' declaration
5
6Fixing compilation errors due to duplicate 'const' keyword:
7 plat/xilinx/zynqmp/pm_service/pm_client.c:39:29: error: duplicate 'const' declaration specifier [-Werror=duplicate-decl-specifier]
8 static const struct pm_proc const pm_procs_all[] = {
9 ^~~~~
10
11Signed-off-by: Soren Brinkmann <soren.brinkmann@xilinx.com>
12---
13Upstream Status: Accepted for 2017.3
14
15 plat/xilinx/zynqmp/pm_service/pm_client.c | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/plat/xilinx/zynqmp/pm_service/pm_client.c b/plat/xilinx/zynqmp/pm_service/pm_client.c
19index f11725d78..08369b99e 100644
20--- a/plat/xilinx/zynqmp/pm_service/pm_client.c
21+++ b/plat/xilinx/zynqmp/pm_service/pm_client.c
22@@ -31,7 +31,7 @@ DEFINE_BAKERY_LOCK(pm_client_secure_lock);
23 extern const struct pm_ipi apu_ipi;
24
25 /* Order in pm_procs_all array must match cpu ids */
26-static const struct pm_proc const pm_procs_all[] = {
27+static const struct pm_proc pm_procs_all[] = {
28 {
29 .node_id = NODE_APU_0,
30 .pwrdn_mask = APU_0_PWRCTL_CPUPWRDWNREQ_MASK,
diff --git a/recipes-bsp/pmu-firmware/pmu-firmware_2017.1.bb b/recipes-bsp/pmu-firmware/pmu-firmware_2017.3.bb
index ee68617f..aceadf7b 100644
--- a/recipes-bsp/pmu-firmware/pmu-firmware_2017.1.bb
+++ b/recipes-bsp/pmu-firmware/pmu-firmware_2017.3.bb
@@ -19,12 +19,12 @@ append_target_provides[eventmask] = "bb.event.RecipeParsed"
19# itself is licensed under a modified MIT license which restricts use to Xilinx 19# itself is licensed under a modified MIT license which restricts use to Xilinx
20# devices only. 20# devices only.
21LICENSE = "Proprietary" 21LICENSE = "Proprietary"
22LIC_FILES_CHKSUM = "file://../../../../license.txt;md5=8c0025a6b0e91b4ab8e4ba9f6d2fb65c" 22LIC_FILES_CHKSUM = "file://../../../../license.txt;md5=530190e8d7ebcdfeddbe396f3f20417f"
23 23
24inherit deploy 24inherit deploy
25 25
26XILINX_RELEASE_VERSION = "v2017.1" 26XILINX_RELEASE_VERSION = "v2017.3"
27SRCREV = "3813f14966bd69e7e1d59943d2a58c64efafa17b" 27SRCREV = "3c9f0cfde9307c2dc1a298f9f22d492601232821"
28PV = "${XILINX_RELEASE_VERSION}+git${SRCPV}" 28PV = "${XILINX_RELEASE_VERSION}+git${SRCPV}"
29 29
30SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1" 30SRC_URI = "git://github.com/Xilinx/embeddedsw.git;protocol=https;nobranch=1"
diff --git a/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch b/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch
deleted file mode 100644
index de7954a8..00000000
--- a/recipes-bsp/u-boot/u-boot-xlnx/v2017.1/arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 05fc0a41a14dac435248aa4ea2afa44450f70d46 Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Fri, 4 Nov 2016 21:33:14 +1000
4Subject: [PATCH] arm: zynqmp: xilinx_zynqmp.h: Auto boot in JTAG if images in
5 memory
6
7Add a command that checks if the Kernel image (in aarch64 Image format)
8and optionally a rootfs is in memory and automatically boot these images
9if in JTAG boot mode.
10
11This allows for simpler boot automation in JTAG boot environments
12(including QEMU) where manual interaction would otherwise be required.
13
14Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
15Upstream-Status: Denied [Upstream prefers FIT instead]
16---
17 include/configs/xilinx_zynqmp.h | 6 ++++--
18 1 file changed, 4 insertions(+), 2 deletions(-)
19
20diff --git a/include/configs/xilinx_zynqmp.h b/include/configs/xilinx_zynqmp.h
21index 9371dbb585..cd4edcf2b5 100644
22--- a/include/configs/xilinx_zynqmp.h
23+++ b/include/configs/xilinx_zynqmp.h
24@@ -253,8 +253,10 @@
25 "run xen_prepare_dt_qemu && " \
26 "tftpb 6000000 xen.ub && tftpb 0x1000000 image.ub && " \
27 "bootm 6000000 0x1000000 $fdt_addr\0" \
28- "jtagboot=tftpboot 80000 Image && tftpboot $fdt_addr system.dtb && " \
29- "tftpboot 6000000 rootfs.cpio.ub && booti 80000 6000000 $fdt_addr\0" \
30+ "jtagmemboot=if itest.w *0x80038 == 0x644d5241; then if iminfo 0x6000000; then booti 0x80000 0x6000000 $fdt_addr; else booti 0x80000 - $fdt_addr; fi; fi\0" \
31+ "jtagboot=run jtagmemboot || " \
32+ "tftpboot 80000 Image && tftpboot $fdt_addr system.dtb && " \
33+ "tftpboot 6000000 rootfs.cpio.ub && booti 80000 6000000 $fdt_addr\0" \
34 "nosmp=setenv bootargs $bootargs maxcpus=1\0" \
35 "nfsroot=setenv bootargs $bootargs root=/dev/nfs nfsroot=$serverip:/mnt/sata,tcp ip=$ipaddr:$serverip:$serverip:255.255.255.0:zynqmp:eth0:off rw\0" \
36 "sdroot0=setenv bootargs $bootargs root=/dev/mmcblk0p2 rw rootwait\0" \
37--
382.11.0
39
diff --git a/recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
index d70dfefd..867f72e2 100644
--- a/recipes-bsp/u-boot/u-boot-xlnx_2017.1.bb
+++ b/recipes-bsp/u-boot/u-boot-xlnx_2017.3.bb
@@ -1,24 +1,20 @@
1include u-boot-xlnx.inc 1include u-boot-xlnx.inc
2include u-boot-spl-zynq-init.inc 2include u-boot-spl-zynq-init.inc
3 3
4XILINX_RELEASE_VERSION = "v2017.1" 4XILINX_RELEASE_VERSION = "v2017.3"
5SRCREV = "92e3dd638b50ad22dd90072673c80d8730903e95" 5SRCREV ?= "da811c4511ef9caeb95f9a22fe49d38bd8e56ded"
6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 6PV = "v2017.01-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
7 7
8SRC_URI_append = " \
9 file://arm-zynqmp-xilinx_zynqmp.h-Auto-boot-in-JTAG-if-imag.patch \
10 "
11
12LICENSE = "GPLv2+" 8LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c" 9LIC_FILES_CHKSUM = "file://README;beginline=1;endline=6;md5=157ab8408beab40cd8ce1dc69f702a6c"
14 10
15# u-boot 2016.07 has support for these 11# u-boot-xlnx has support for these
16HAS_PLATFORM_INIT ?= " \ 12HAS_PLATFORM_INIT ?= " \
17 zynq_microzed_config \ 13 zynq_microzed_config \
18 zynq_zed_config \ 14 zynq_zed_config \
19 zynq_zc702_config \ 15 zynq_zc702_config \
20 zynq_zc706_config \ 16 zynq_zc706_config \
21 zynq_zybo_config \ 17 zynq_zybo_config \
22 xilinx_zynqmp_zcu102_config \ 18 xilinx_zynqmp_zcu102_rev1_0_config \
23 " 19 "
24 20
diff --git a/recipes-devtools/qemu/qemu-devicetrees_2017.1.bb b/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
index df9c2c8c..d5cfe0b0 100644
--- a/recipes-devtools/qemu/qemu-devicetrees_2017.1.bb
+++ b/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
@@ -7,7 +7,7 @@ inherit deploy
7 7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99" 8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9 9
10SRCREV = "294ffabc02d8a3933f7acfb2256489677776af8d" 10SRCREV = "4b951c594078562e9dd828430075968dd91ac425"
11SRC_URI = "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https;nobranch=1" 11SRC_URI = "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https;nobranch=1"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
diff --git a/recipes-devtools/qemu/qemu-xilinx_2017.1.bb b/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
index c0d09621..624715da 100644
--- a/recipes-devtools/qemu/qemu-xilinx_2017.1.bb
+++ b/recipes-devtools/qemu/qemu-xilinx_2017.3.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = " \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \ 10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913 \
11 " 11 "
12 12
13SRCREV = "45d810957b0f837a5685fbe4bc8d9e3268c1fe64" 13SRCREV = "8f8c89b18f6e4523099e41d81769fc534064b8de"
14SRC_URI = "git://github.com/Xilinx/qemu.git;protocol=https;nobranch=1" 14SRC_URI = "git://github.com/Xilinx/qemu.git;protocol=https;nobranch=1"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
diff --git a/recipes-kernel/linux/linux-xlnx.inc b/recipes-kernel/linux/linux-xlnx.inc
index 50d6ebf1..39c146aa 100644
--- a/recipes-kernel/linux/linux-xlnx.inc
+++ b/recipes-kernel/linux/linux-xlnx.inc
@@ -7,7 +7,7 @@ PV = "${LINUX_VERSION}${LINUX_VERSION_EXTENSION}+git${SRCPV}"
7KBRANCH ?= "" 7KBRANCH ?= ""
8SRCBRANCHARG = "${@['nobranch=1', 'branch=${KBRANCH}'][d.getVar('KBRANCH', True) != '']}" 8SRCBRANCHARG = "${@['nobranch=1', 'branch=${KBRANCH}'][d.getVar('KBRANCH', True) != '']}"
9 9
10FILESOVERRIDES_append = ":${LINUX_VERSION}" 10FILESOVERRIDES_append = ":${XILINX_RELEASE_VERSION}"
11KERNELURI ?= "git://github.com/Xilinx/linux-xlnx.git;protocol=https" 11KERNELURI ?= "git://github.com/Xilinx/linux-xlnx.git;protocol=https"
12SRC_URI = "${KERNELURI};${SRCBRANCHARG}" 12SRC_URI = "${KERNELURI};${SRCBRANCHARG}"
13 13
diff --git a/recipes-kernel/linux/linux-xlnx/4.9/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch b/recipes-kernel/linux/linux-xlnx/v2017.3/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch
index 4a9ce4a2..b8ba70ea 100644
--- a/recipes-kernel/linux/linux-xlnx/4.9/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch
+++ b/recipes-kernel/linux/linux-xlnx/v2017.3/0001-drm-xilinx-Add-encoder-for-Digilent-boards.patch
@@ -1,4 +1,4 @@
1From 1dd21beeff5ccb2bd1960bf3ef0578aa602b62bf Mon Sep 17 00:00:00 2001 1From c1bf9e8c50baa237b514715dcb9c8fd367694c93 Mon Sep 17 00:00:00 2001
2From: Jason Wu <jason.wu.misc@gmail.com> 2From: Jason Wu <jason.wu.misc@gmail.com>
3Date: Sun, 10 Apr 2016 13:14:13 +1000 3Date: Sun, 10 Apr 2016 13:14:13 +1000
4Subject: [PATCH 1/3] drm: xilinx: Add encoder for Digilent boards 4Subject: [PATCH 1/3] drm: xilinx: Add encoder for Digilent boards
@@ -49,11 +49,11 @@ index 0000000000..242b24e482
49+ dglnt,edid-i2c = <&i2c1>; 49+ dglnt,edid-i2c = <&i2c1>;
50+ }; 50+ };
51diff --git a/drivers/gpu/drm/xilinx/Kconfig b/drivers/gpu/drm/xilinx/Kconfig 51diff --git a/drivers/gpu/drm/xilinx/Kconfig b/drivers/gpu/drm/xilinx/Kconfig
52index a713b17673..c32a4a679e 100644 52index 12b548c2a9..c3e2562e53 100644
53--- a/drivers/gpu/drm/xilinx/Kconfig 53--- a/drivers/gpu/drm/xilinx/Kconfig
54+++ b/drivers/gpu/drm/xilinx/Kconfig 54+++ b/drivers/gpu/drm/xilinx/Kconfig
55@@ -21,3 +21,9 @@ config DRM_XILINX_DP_SUB 55@@ -57,3 +57,9 @@ config DRM_XILINX_SDI
56 select DRM_XILINX_DP 56 depends on DRM_XILINX
57 help 57 help
58 DRM driver for Xilinx Display Port Subsystem. 58 DRM driver for Xilinx Display Port Subsystem.
59+ 59+
@@ -63,14 +63,17 @@ index a713b17673..c32a4a679e 100644
63+ help 63+ help
64+ DRM slave encoder for Video-out on Digilent boards. 64+ DRM slave encoder for Video-out on Digilent boards.
65diff --git a/drivers/gpu/drm/xilinx/Makefile b/drivers/gpu/drm/xilinx/Makefile 65diff --git a/drivers/gpu/drm/xilinx/Makefile b/drivers/gpu/drm/xilinx/Makefile
66index 705472c338..a571bd96cf 100644 66index 19bc1541ca..c2717e40ea 100644
67--- a/drivers/gpu/drm/xilinx/Makefile 67--- a/drivers/gpu/drm/xilinx/Makefile
68+++ b/drivers/gpu/drm/xilinx/Makefile 68+++ b/drivers/gpu/drm/xilinx/Makefile
69@@ -10,3 +10,4 @@ xilinx_drm-y += xilinx_cresample.o xilinx_osd.o xilinx_rgb2yuv.o xilinx_vtc.o 69@@ -7,6 +7,7 @@ xilinx_drm-y := xilinx_drm_crtc.o xilinx_drm_connector.o xilinx_drm_drv.o \
70 xilinx_drm_plane.o
71 xilinx_drm-y += xilinx_cresample.o xilinx_osd.o xilinx_rgb2yuv.o xilinx_vtc.o
72
73+obj-$(CONFIG_DRM_DIGILENT_ENCODER) += dglnt_encoder.o
70 obj-$(CONFIG_DRM_XILINX) += xilinx_drm.o 74 obj-$(CONFIG_DRM_XILINX) += xilinx_drm.o
71 obj-$(CONFIG_DRM_XILINX_DP) += xilinx_drm_dp.o 75 obj-$(CONFIG_DRM_XILINX_DP) += xilinx_drm_dp.o
72 obj-$(CONFIG_DRM_XILINX_DP_SUB) += xilinx_drm_dp_sub.o 76 obj-$(CONFIG_DRM_XILINX_DP_SUB) += xilinx_drm_dp_sub.o
73+obj-$(CONFIG_DRM_DIGILENT_ENCODER) += dglnt_encoder.o
74diff --git a/drivers/gpu/drm/xilinx/dglnt_encoder.c b/drivers/gpu/drm/xilinx/dglnt_encoder.c 77diff --git a/drivers/gpu/drm/xilinx/dglnt_encoder.c b/drivers/gpu/drm/xilinx/dglnt_encoder.c
75new file mode 100644 78new file mode 100644
76index 0000000000..26a23986f9 79index 0000000000..26a23986f9
@@ -295,5 +298,5 @@ index 0000000000..26a23986f9
295+MODULE_DESCRIPTION("DRM slave encoder for Video-out on Digilent boards"); 298+MODULE_DESCRIPTION("DRM slave encoder for Video-out on Digilent boards");
296+MODULE_LICENSE("GPL v2"); 299+MODULE_LICENSE("GPL v2");
297-- 300--
2982.11.0 3012.14.2
299 302
diff --git a/recipes-kernel/linux/linux-xlnx/4.9/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch b/recipes-kernel/linux/linux-xlnx/v2017.3/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch
index 9f2c4e87..9b6229db 100644
--- a/recipes-kernel/linux/linux-xlnx/4.9/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch
+++ b/recipes-kernel/linux/linux-xlnx/v2017.3/0002-clk-Add-driver-for-axi_dynclk-IP-Core.patch
@@ -1,4 +1,4 @@
1From 8554dd34a68262849622c1c539b0176d525188f4 Mon Sep 17 00:00:00 2001 1From 217e3b6f4393926b8dcad841381527ef3fc808c2 Mon Sep 17 00:00:00 2001
2From: Jason Wu <jason.wu.misc@gmail.com> 2From: Jason Wu <jason.wu.misc@gmail.com>
3Date: Sun, 10 Apr 2016 13:16:06 +1000 3Date: Sun, 10 Apr 2016 13:16:06 +1000
4Subject: [PATCH 2/3] clk: Add driver for axi_dynclk IP Core 4Subject: [PATCH 2/3] clk: Add driver for axi_dynclk IP Core
@@ -603,5 +603,5 @@ index 0000000000..496ad5fc90
603+MODULE_AUTHOR("Sam Bobrowicz <sbobrowicz@digilentinc.com>"); 603+MODULE_AUTHOR("Sam Bobrowicz <sbobrowicz@digilentinc.com>");
604+MODULE_DESCRIPTION("CCF Driver for Digilent axi_dynclk IP Core"); 604+MODULE_DESCRIPTION("CCF Driver for Digilent axi_dynclk IP Core");
605-- 605--
6062.11.0 6062.14.2
607 607
diff --git a/recipes-kernel/linux/linux-xlnx/4.9/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch b/recipes-kernel/linux/linux-xlnx/v2017.3/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch
index 8e36a703..a98d84c5 100644
--- a/recipes-kernel/linux/linux-xlnx/4.9/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch
+++ b/recipes-kernel/linux/linux-xlnx/v2017.3/0003-drm-xilinx-Fix-DPMS-transition-to-on.patch
@@ -1,4 +1,4 @@
1From 26f5c0d18f54cab4437dfdab0ca4a8a05a27edff Mon Sep 17 00:00:00 2001 1From 1a18e2b514ae9e75145597ac509a87f656c976ba Mon Sep 17 00:00:00 2001
2From: Nathan Rossi <nathan@nathanrossi.com> 2From: Nathan Rossi <nathan@nathanrossi.com>
3Date: Mon, 2 May 2016 23:46:42 +1000 3Date: Mon, 2 May 2016 23:46:42 +1000
4Subject: [PATCH 3/3] drm: xilinx: Fix DPMS transition to on 4Subject: [PATCH 3/3] drm: xilinx: Fix DPMS transition to on
@@ -13,14 +13,14 @@ Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
13Upstream-Status: Pending [This is a workaround] 13Upstream-Status: Pending [This is a workaround]
14--- 14---
15 drivers/gpu/drm/xilinx/xilinx_drm_crtc.c | 1 - 15 drivers/gpu/drm/xilinx/xilinx_drm_crtc.c | 1 -
16 drivers/gpu/drm/xilinx/xilinx_drm_plane.c | 7 +++---- 16 drivers/gpu/drm/xilinx/xilinx_drm_plane.c | 3 ++-
17 2 files changed, 3 insertions(+), 5 deletions(-) 17 2 files changed, 2 insertions(+), 2 deletions(-)
18 18
19diff --git a/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c b/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c 19diff --git a/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c b/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c
20index 723bcc47e2..e6777fee05 100644 20index 631d35b921..93dbd4b58a 100644
21--- a/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c 21--- a/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c
22+++ b/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c 22+++ b/drivers/gpu/drm/xilinx/xilinx_drm_crtc.c
23@@ -89,7 +89,6 @@ static void xilinx_drm_crtc_dpms(struct drm_crtc *base_crtc, int dpms) 23@@ -88,7 +88,6 @@ static void xilinx_drm_crtc_dpms(struct drm_crtc *base_crtc, int dpms)
24 default: 24 default:
25 if (crtc->vtc) { 25 if (crtc->vtc) {
26 xilinx_vtc_disable(crtc->vtc); 26 xilinx_vtc_disable(crtc->vtc);
@@ -29,21 +29,10 @@ index 723bcc47e2..e6777fee05 100644
29 if (crtc->cresample) { 29 if (crtc->cresample) {
30 xilinx_cresample_disable(crtc->cresample); 30 xilinx_cresample_disable(crtc->cresample);
31diff --git a/drivers/gpu/drm/xilinx/xilinx_drm_plane.c b/drivers/gpu/drm/xilinx/xilinx_drm_plane.c 31diff --git a/drivers/gpu/drm/xilinx/xilinx_drm_plane.c b/drivers/gpu/drm/xilinx/xilinx_drm_plane.c
32index 2646763b17..4211e1bad8 100644 32index 6a248b72d4..d2518a4bdf 100644
33--- a/drivers/gpu/drm/xilinx/xilinx_drm_plane.c 33--- a/drivers/gpu/drm/xilinx/xilinx_drm_plane.c
34+++ b/drivers/gpu/drm/xilinx/xilinx_drm_plane.c 34+++ b/drivers/gpu/drm/xilinx/xilinx_drm_plane.c
35@@ -151,9 +151,7 @@ void xilinx_drm_plane_dpms(struct drm_plane *base_plane, int dpms) 35@@ -140,7 +140,7 @@ void xilinx_drm_plane_commit(struct drm_plane *base_plane)
36 }
37
38 /* start dma engine */
39- for (i = 0; i < MAX_NUM_SUB_PLANES; i++)
40- if (plane->dma[i].chan && plane->dma[i].is_active)
41- dma_async_issue_pending(plane->dma[i].chan);
42+ xilinx_drm_plane_commit(base_plane);
43
44 if (plane->rgb2yuv)
45 xilinx_rgb2yuv_enable(plane->rgb2yuv);
46@@ -228,7 +226,7 @@ void xilinx_drm_plane_commit(struct drm_plane *base_plane)
47 for (i = 0; i < MAX_NUM_SUB_PLANES; i++) { 36 for (i = 0; i < MAX_NUM_SUB_PLANES; i++) {
48 struct xilinx_drm_plane_dma *dma = &plane->dma[i]; 37 struct xilinx_drm_plane_dma *dma = &plane->dma[i];
49 38
@@ -52,7 +41,7 @@ index 2646763b17..4211e1bad8 100644
52 flags = DMA_CTRL_ACK | DMA_PREP_INTERRUPT; 41 flags = DMA_CTRL_ACK | DMA_PREP_INTERRUPT;
53 desc = dmaengine_prep_interleaved_dma(dma->chan, 42 desc = dmaengine_prep_interleaved_dma(dma->chan,
54 &dma->xt, 43 &dma->xt,
55@@ -241,6 +239,7 @@ void xilinx_drm_plane_commit(struct drm_plane *base_plane) 44@@ -153,6 +153,7 @@ void xilinx_drm_plane_commit(struct drm_plane *base_plane)
56 dmaengine_submit(desc); 45 dmaengine_submit(desc);
57 46
58 dma_async_issue_pending(dma->chan); 47 dma_async_issue_pending(dma->chan);
@@ -61,5 +50,5 @@ index 2646763b17..4211e1bad8 100644
61 } 50 }
62 } 51 }
63-- 52--
642.11.0 532.14.2
65 54
diff --git a/recipes-kernel/linux/linux-xlnx_2017.1.bb b/recipes-kernel/linux/linux-xlnx_2017.3.bb
index 586a635b..9178f970 100644
--- a/recipes-kernel/linux/linux-xlnx_2017.1.bb
+++ b/recipes-kernel/linux/linux-xlnx_2017.3.bb
@@ -1,6 +1,6 @@
1LINUX_VERSION = "4.9" 1LINUX_VERSION = "4.9"
2XILINX_RELEASE_VERSION = "v2017.1" 2XILINX_RELEASE_VERSION = "v2017.3"
3SRCREV ?= "68e6869cfb8154b80ee9ffafd64932971e9d1d07" 3SRCREV ?= "f1b1e077d641fc83b54c1b8f168cbb58044fbd4e"
4 4
5include linux-xlnx.inc 5include linux-xlnx.inc
6 6