summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-10-10 16:49:11 -0700
committerNathan Rossi <nathan@nathanrossi.com>2017-10-18 18:03:28 +1000
commit4867326eb711853e1308d7f304c7beb7bb415a08 (patch)
treebf9c3caba83969b5723eb174cf027979cec10279
parentff9f7c1202687ef4c829e9be505e47cc1699c2e5 (diff)
downloadmeta-xilinx-4867326eb711853e1308d7f304c7beb7bb415a08.tar.gz
kernel-module-mali.bb: Add PM runtime barries after removing from suspend
Runtime PM suspend "put" results in addition of PM suspend API in work queue. This barrier API will remove it from the work queue. Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
-rw-r--r--recipes-graphics/mali/kernel-module-mali.bb1
-rw-r--r--recipes-graphics/mali/kernel-module-mali/0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch31
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-graphics/mali/kernel-module-mali.bb b/recipes-graphics/mali/kernel-module-mali.bb
index 6674071d..edd8cbe9 100644
--- a/recipes-graphics/mali/kernel-module-mali.bb
+++ b/recipes-graphics/mali/kernel-module-mali.bb
@@ -19,6 +19,7 @@ SRC_URI = " \
19 file://0007-mali_memory_os_alloc.c-Align-with-dma_attrs-changes-.patch \ 19 file://0007-mali_memory_os_alloc.c-Align-with-dma_attrs-changes-.patch \
20 file://0008-arm.c-dma_ops-will-be-modified-by-the-driver-only-ti.patch \ 20 file://0008-arm.c-dma_ops-will-be-modified-by-the-driver-only-ti.patch \
21 file://0009-linux-mali_kernel_linux.c-Handle-clock-when-probed-a.patch \ 21 file://0009-linux-mali_kernel_linux.c-Handle-clock-when-probed-a.patch \
22 file://0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch \
22 " 23 "
23SRC_URI[md5sum] = "db3ef3258eb55700484ecadfdce1fee1" 24SRC_URI[md5sum] = "db3ef3258eb55700484ecadfdce1fee1"
24SRC_URI[sha256sum] = "496ba80684aa4236806891a8445978849f7dd07299f5e58b14d52cd5e7ba0536" 25SRC_URI[sha256sum] = "496ba80684aa4236806891a8445978849f7dd07299f5e58b14d52cd5e7ba0536"
diff --git a/recipes-graphics/mali/kernel-module-mali/0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch b/recipes-graphics/mali/kernel-module-mali/0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch
new file mode 100644
index 00000000..ad159ba6
--- /dev/null
+++ b/recipes-graphics/mali/kernel-module-mali/0010-common-mali_pm.c-Add-PM-runtime-barrier-after-removi.patch
@@ -0,0 +1,31 @@
1From 572d234259158bf9f046c2393a65e2800bec1062 Mon Sep 17 00:00:00 2001
2From: Madhurkiran Harikrishnan <madhurki@xilinx.com>
3Date: Mon, 28 Aug 2017 09:40:37 -0700
4Subject: [PATCH] common/mali_pm.c: Add PM runtime barrier after removing
5 suspend
6
7Runtime PM suspend "put" results in addition of PM suspend
8API in work queue. This barrier API will remove it from
9the work queue.
10
11Signed-off-by: Madhurkiran Harikrishnan <madhurki@xilinx.com>
12Upstream-Status: Pending
13---
14 driver/src/devicedrv/mali/common/mali_pm.c | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/driver/src/devicedrv/mali/common/mali_pm.c b/driver/src/devicedrv/mali/common/mali_pm.c
18index 1ef03a6..0343ad3 100755
19--- common/mali_pm.c
20+++ b/common/mali_pm.c
21@@ -301,6 +301,7 @@ void mali_pm_init_end(void)
22 }
23
24 _mali_osk_pm_dev_ref_put();
25+ _mali_osk_pm_dev_barrier();
26 }
27
28 void mali_pm_update_sync(void)
29--
302.7.4
31