summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-30 00:11:37 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-04 14:09:11 -0800
commit3e58d85fa211eb3eca6501d518ae18d9dfccfc13 (patch)
tree74f7ca718feb8517cdcd0a07c69a643e191623e2
parent582f901da315fa29d694bd89f659f7ca6f5aecd6 (diff)
downloadmeta-xilinx-3e58d85fa211eb3eca6501d518ae18d9dfccfc13.tar.gz
device-tree.bb: Add variable to override device tree padding size
Add DT_PADDING_SIZE variable which can override the default setting. There are instances where it is necessary to change device tree padding size. Reviewed-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--recipes-bsp/device-tree/device-tree.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-bsp/device-tree/device-tree.bb b/recipes-bsp/device-tree/device-tree.bb
index 5ecad6bc..7c502838 100644
--- a/recipes-bsp/device-tree/device-tree.bb
+++ b/recipes-bsp/device-tree/device-tree.bb
@@ -37,6 +37,7 @@ KERNEL_DTS_INCLUDE_append_zynqmp = " \
37DTS_FILES_PATH ?= "${S}" 37DTS_FILES_PATH ?= "${S}"
38DTS_INCLUDE ?= "${DTS_FILES_PATH} ${KERNEL_DTS_INCLUDE}" 38DTS_INCLUDE ?= "${DTS_FILES_PATH} ${KERNEL_DTS_INCLUDE}"
39 39
40DT_PADDING_SIZE ?= "0x3000"
40DEVICETREE_FLAGS ?= " \ 41DEVICETREE_FLAGS ?= " \
41 -R 8 -p ${DT_PADDING_SIZE} -b 0 \ 42 -R 8 -p ${DT_PADDING_SIZE} -b 0 \
42 ${@' '.join(['-i %s' % i for i in d.getVar('DTS_INCLUDE', True).split()])} \ 43 ${@' '.join(['-i %s' % i for i in d.getVar('DTS_INCLUDE', True).split()])} \