summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwagath Gadde <swagath.gadde@amd.com>2024-02-28 15:56:42 +0530
committerMark Hatle <mark.hatle@amd.com>2024-02-29 08:47:32 -0600
commite5d7484616d63ac59f311dd5a310bc3979a29116 (patch)
tree411faf58140d7e041a976ebf7d01428da614ffd7
parent436db1242cb80949160e789b38a36d3c9ad83b44 (diff)
downloadmeta-xilinx-e5d7484616d63ac59f311dd5a310bc3979a29116.tar.gz
system-vek280: add workaround device tree node
Add the workaround device tree node to reserve the bad block DDR memory. so that we can boot linux on vek280 board. Signed-off-by: Swagath Gadde <swagath.gadde@amd.com> Signed-off-by: Mark Hatle <mark.hatle@amd.com>
-rw-r--r--meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend2
-rw-r--r--meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi20
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend b/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
index fa4816af..7acda75e 100644
--- a/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
+++ b/meta-xilinx-bsp/recipes-bsp/device-tree/device-tree.bbappend
@@ -5,3 +5,5 @@ COMPATIBLE_MACHINE:qemu-zynq7 = ".*"
5SRC_URI:append:qemu-zynq7 = " file://qemu-zynq7.dts" 5SRC_URI:append:qemu-zynq7 = " file://qemu-zynq7.dts"
6 6
7EXTRA_OVERLAYS:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' pnc.dtsi', '', d)}" 7EXTRA_OVERLAYS:append = "${@bb.utils.contains('MACHINE_FEATURES', 'provencore', ' pnc.dtsi', '', d)}"
8
9EXTRA_OVERLAYS:append:vek280-versal = " system-vek280.dtsi"
diff --git a/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi b/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi
new file mode 100644
index 00000000..0d2ca87d
--- /dev/null
+++ b/meta-xilinx-bsp/recipes-bsp/device-tree/files/system-vek280.dtsi
@@ -0,0 +1,20 @@
1/ {
2/* Reserve the bad block DDR memory for linux to not touch it, refer:CR-1143646 */
3reserved-memory {
4 #address-cells = <2>;
5 #size-cells = <2>;
6 ranges;
7 pl_ddr: buffer@0
8 {
9 no-map;
10 reg = <0x08 0x00 0x00 0x80000000>;
11 };
12
13 lpddr_memory: buffer@1
14 {
15 no-map;
16 reg = <0x500 0x0 0x2 0x0>;
17 };
18
19};
20};