summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-29 22:53:43 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-04 14:09:05 -0800
commit582f901da315fa29d694bd89f659f7ca6f5aecd6 (patch)
treed9af486db3386427d462bcbeb640cc33d16276eb
parent36b644c36deb42ab0028f5ad5893dc9edab24d31 (diff)
downloadmeta-xilinx-582f901da315fa29d694bd89f659f7ca6f5aecd6.tar.gz
device-tree.bb: Provide override device tree directory
Provide a way to override device tree work directory and include file directory, this might be particalarly helpful while using this recipes in other layers, for example in meta-xilinx-tools to override workdir and point it to dtg based build directory Reviewed-by: Nathan Rossi <nathan@nathanrossi.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
-rw-r--r--recipes-bsp/device-tree/device-tree.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-bsp/device-tree/device-tree.bb b/recipes-bsp/device-tree/device-tree.bb
index 27e1017f..5ecad6bc 100644
--- a/recipes-bsp/device-tree/device-tree.bb
+++ b/recipes-bsp/device-tree/device-tree.bb
@@ -34,14 +34,17 @@ KERNEL_DTS_INCLUDE_append_zynqmp = " \
34 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts/xilinx \ 34 ${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts/xilinx \
35 " 35 "
36 36
37DTS_FILES_PATH ?= "${S}"
38DTS_INCLUDE ?= "${DTS_FILES_PATH} ${KERNEL_DTS_INCLUDE}"
39
37DEVICETREE_FLAGS ?= " \ 40DEVICETREE_FLAGS ?= " \
38 -R 8 -p 0x3000 -b 0 -i ${S} \ 41 -R 8 -p ${DT_PADDING_SIZE} -b 0 \
39 ${@' '.join(['-i %s' % i for i in d.getVar('KERNEL_DTS_INCLUDE', True).split()])} \ 42 ${@' '.join(['-i %s' % i for i in d.getVar('DTS_INCLUDE', True).split()])} \
40 " 43 "
41DEVICETREE_OFLAGS ?= "-@ -H epapr" 44DEVICETREE_OFLAGS ?= "-@ -H epapr"
42DEVICETREE_PP_FLAGS ?= " \ 45DEVICETREE_PP_FLAGS ?= " \
43 -nostdinc -Ulinux -x assembler-with-cpp -I${S} \ 46 -nostdinc -Ulinux -x assembler-with-cpp \
44 ${@' '.join(['-I%s' % i for i in d.getVar('KERNEL_DTS_INCLUDE', True).split()])} \ 47 ${@' '.join(['-I%s' % i for i in d.getVar('DTS_INCLUDE', True).split()])} \
45 " 48 "
46 49
47python () { 50python () {
@@ -51,7 +54,7 @@ python () {
51} 54}
52 55
53do_compile() { 56do_compile() {
54 for DTS_FILE in ${S}/*.dts; do 57 for DTS_FILE in ${DTS_FILES_PATH}/*.dts; do
55 DTS_NAME=`basename -s .dts ${DTS_FILE}` 58 DTS_NAME=`basename -s .dts ${DTS_FILE}`
56 ${BUILD_CPP} ${DEVICETREE_PP_FLAGS} -o `basename ${DTS_FILE}`.pp ${DTS_FILE} 59 ${BUILD_CPP} ${DEVICETREE_PP_FLAGS} -o `basename ${DTS_FILE}`.pp ${DTS_FILE}
57 60